Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemi acpid dopo update kernel
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
triki
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2005
Posts: 133
Location: Zena Italy

PostPosted: Tue Dec 25, 2007 10:20 pm    Post subject: problemi acpid dopo update kernel Reply with quote

ho aggiornato il kernel (da 2.6.19 a 2.6.23-gentoo-r3) su un portatile Dell Latitude LS e nonostante abbia abilitato le varie opzioni batteria, alimentatore, ecc nella sezione acpi del kernel mi dà questi problemi:

- vede il battery slot ma non la batteria (e quindi non mi dice quanto eè carica la batteria...)
- vede l'alimentatore sempre collegato anche quando non lo è
- mi indica come temperatura del processore sempre 50° (e vi garantisco che non è vero)
- vede sempre la ventola spenta anche quando non lo è

queste sono le opzioni del mio kernel relative ad acpi:

Code:
# zcat /proc/config.gz |grep ACPI   
# Power management options (ACPI, APM)
CONFIG_ACPI=y
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_PROC_EVENT=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_FAN=y
CONFIG_ACPI_DOCK=y
# CONFIG_ACPI_BAY is not set
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
# CONFIG_ACPI_CONTAINER is not set
# CONFIG_ACPI_SBS is not set
CONFIG_PNPACPI=y
# CONFIG_BLK_DEV_IDEACPI is not set


cosa posso fare?
Back to top
View user's profile Send private message
falko
Apprentice
Apprentice


Joined: 03 Dec 2004
Posts: 223
Location: Rovereto (TN) Italy

PostPosted: Mon Dec 31, 2007 3:43 pm    Post subject: Reply with quote

Hai già provato a ricompilare acpid? (soluzione stupida ma a volte efficace)
_________________
Io non sarò mai nessuno ma... nessuno sarà mai come me. (Jim Morrison)

A ciacere no se sgonfa done

Gentoo on: Lenovo R500
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Mon Dec 31, 2007 5:05 pm    Post subject: Reply with quote

capitato lo stesso anche a me ed ho risolto facendo un diff tra i due kernel e compilando qualche modulo che nel secondo era "saltato"
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
triki
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2005
Posts: 133
Location: Zena Italy

PostPosted: Tue Jan 01, 2008 12:34 pm    Post subject: Reply with quote

si ho già provato a ricompilare acpid ma non è servito... per il kernel invece non posso recuperare quello vecchio perchè ho pasticciato e ho cancellato tutto... :(
Back to top
View user's profile Send private message
falko
Apprentice
Apprentice


Joined: 03 Dec 2004
Posts: 223
Location: Rovereto (TN) Italy

PostPosted: Tue Jan 01, 2008 7:27 pm    Post subject: Reply with quote

Questo è invece la mia configurazione del kernel relativa a ACPI.
Code:

#cat .config | grep ACPI
# Power management options (ACPI, APM)
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_PROC_EVENT=y
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=m
CONFIG_ACPI_DOCK=m
# CONFIG_ACPI_BAY is not set
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_HOTPLUG_CPU=y
CONFIG_ACPI_THERMAL=m
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
CONFIG_ACPI_CONTAINER=m
# CONFIG_ACPI_SBS is not set
# CONFIG_HOTPLUG_PCI_ACPI is not set
CONFIG_PNPACPI=y
# CONFIG_THINKPAD_ACPI is not set
CONFIG_ATA_ACPI=y


Prova a mettere le opzioni
Code:

CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=m
CONFIG_ACPI_DOCK=m

come moduli e quindi prova a caricarli manualmente per vedere se ti salta fuori qualcosa
_________________
Io non sarò mai nessuno ma... nessuno sarà mai come me. (Jim Morrison)

A ciacere no se sgonfa done

Gentoo on: Lenovo R500
Back to top
View user's profile Send private message
triki
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2005
Posts: 133
Location: Zena Italy

PostPosted: Fri Jan 04, 2008 2:26 pm    Post subject: Reply with quote

allora, ho un po' di problemi coi moduli perchè ho sempre usato kernel monolitici e non riesco a caricare i moduli... però ho anche provato a fare un kernel monolitico con le opzioni che mi hai consigliato senza però avere successo, inoltre alcune opzioni che tu hai scelto non mi compaiono proprio... che kernel stai usando?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Jan 04, 2008 5:32 pm    Post subject: Reply with quote

vedi nella sezione processore il supporto ai bios dell CONFIG_KI8 o qualcosa del genere. Alcune opzioni tipo il supporto custom dsdt sono attivate e disattivate dal supporto per i firmware nella sezione drivers. (non ho volgia di andare a vedere l'opzione esatta)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
triki
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2005
Posts: 133
Location: Zena Italy

PostPosted: Fri Jan 04, 2008 7:45 pm    Post subject: Reply with quote

l'opzione del bios l'ho attivata, quella del custom dsdt invece no perchè non saprei che file allegarci... del resto se col kernel precedente funzionava tutto senza dsdt particolare perchè dovrei mettercelo ora? o sbaglio? comunque non ne sono venuto a capo, continua a non darmi info su batteria, alimentatore, temperatura del processore e lid...

è possibile che le due opzioni relative a /proc/acpi diano dei problemi? perchè è proprio nei file di quella cartella che ho trovato le informazioni errate su batteria, lid, ecc. In realtà ho già provato a disattivarle però all'avvio acpid mi dà errore perchè non riesce a trovarle, può essere questo il problema?
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Sat Jan 05, 2008 12:37 pm    Post subject: Reply with quote

triki wrote:
lquella del custom dsdt invece no perchè non saprei che file allegarci... del resto se col kernel precedente funzionava tutto senza dsdt particolare perchè dovrei mettercelo ora?

perchè è possibile che una dsdt bacata faccia riportare all'acpi informazioni sballate, cerca se per il tuo modello di pc c'è una fix dedicata al problema.
E principalmente volevo spiegarti perchè alcune opzioni ci sono ed altre no secondo quello che attivi in altre sezioni della configurazione, e quell'esempio è il primo che mi è venuto a mente perchè dimentico sistematicamente di abilitarlo e compilo sempre due volte il kernel.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum