Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Решено] интегрированая видюха Intel® Desktop Board DQ965GF
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
alexd73
n00b
n00b


Joined: 02 Jul 2007
Posts: 15

PostPosted: Mon Dec 24, 2007 1:56 pm    Post subject: [Решено] интегрированая видюха Intel® Desktop Board DQ965GF Reply with quote

Имеется Intel® Desktop Board DQ965GF, траблы с загрузкой с CD-ROM решил подключением через переходник USB-IDE... сейчас проблема с видео.. не могу ни как воткнуть....
lspci -v

Code:
00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation Unknown device 4f43
   Flags: bus master, fast devsel, latency 0, IRQ 11
   Memory at 30200000 (32-bit, non-prefetchable) [size=1M]
   Memory at 20000000 (64-bit, prefetchable) [size=256M]
   I/O ports at 2440 [size=8]
   Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
   Capabilities: [d0] Power Management version 2

на сайте Intel® Desktop Board DQ965GF
Code:
Video    Intel® Graphics Media Accelerator 3000 (Intel® GMA 3000) onboard graphics subsystem


Автоматический конфиг
Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   RgbPath      "/usr/share/X11/rgb"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "dbe"
   Load  "record"
   Load  "GLcore"
   Load  "glx"
   Load  "dri"
   Load  "extmod"
   Load  "xtrap"
   Load  "freetype"
   Load  "type1"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "NEC"
   ModelName    "LCD72VM"
   HorizSync    31.0 - 81.0
   VertRefresh  56.0 - 75.0
   Option       "DPMS"
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "intel"
   VendorName  "Intel Corporation"
   BoardName   "82Q963/Q965 Integrated Graphics Controller"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


Усеченные ошибки
Code:

(II) LoadModule: "kbd"
(WW) Warning, couldn't open module kbd
(II) UnloadModule: "kbd"
(EE) Failed to load module "kbd" (module does not exist, 0)
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, 965G, 965G, 965Q, 946GZ,
   965GM, 965GME/GLE, G33, Q35, Q33
(II) Primary Device is: PCI 00:02:0
(--) Chipset 965Q found
(II) Setting vga for screen 0.
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/lib/xorg/modules//libint10.so
(II) Module int10: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.0.0
   ABI class: X.Org Video Driver, version 1.2
(II) Loading sub module "vbe"
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules//libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.1.0
   ABI class: X.Org Video Driver, version 1.2
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/lib/xorg/modules//libvgahw.so
(II) Module vgahw: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 0.1.0
   ABI class: X.Org Video Driver, version 1.2
(==) intel(0): Depth 24, (==) framebuffer bpp 32
(==) intel(0): RGB weight 888
(==) intel(0): Default visual is TrueColor
(II) intel(0): Integrated Graphics Chipset: Intel(R) 965Q
(--) intel(0): Chipset: "965Q"
(--) intel(0): Linear framebuffer at 0x20000000
(--) intel(0): IO registers at addr 0x30200000
(II) intel(0): 2 display pipes available.
(==) intel(0): Using XAA for acceleration
(--) intel(0): Will try to allocate texture pool for old Mesa 3D driver.
(II) intel(0): Will try to reserve 32768 kiB of AGP aperture space
   for the DRM memory manager.
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"(II) Module already built-in
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"(II) Module already built-in

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
[drm] failed to load kernel module "i915"
(II) intel(0): [drm] drmOpen failed
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.
(II) intel(0): Page Flipping disabled
(==) intel(0): Write-combining range (0x20000000,0x10000000)
(II) intel(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(II) intel(0): Using XFree86 Acceleration Architecture (XAA)
   Screen to screen bit blits
   Solid filled rectangles
   8x8 mono pattern filled rectangles
   Indirect CPU to Screen color expansion
   Solid Horizontal and Vertical Lines
   Offscreen Pixmaps
   Setting up tile and stipple cache:
      32 128x128 slots
      32 256x256 slots
      16 512x512 slots
(==) intel(0): Backing store disabled
(==) intel(0): Silken mouse enabled
(II) intel(0): Initializing HW Cursor
(II) intel(0): xf86BindGARTMemory: bind key 0 at 0x0077f000 (pgoffset 1919)
(II) intel(0): xf86BindGARTMemory: bind key 1 at 0x02148000 (pgoffset 8520)
(II) intel(0): Output configuration:
(II) intel(0):   Pipe A is on
(II) intel(0):   Display plane A is now enabled and connected to pipe A.
(II) intel(0):   Pipe B is off
(II) intel(0):   Display plane B is now disabled and connected to pipe B.
(II) intel(0):   Output VGA is connected to pipe A
(**) Option "dpms"
(**) intel(0): DPMS enabled
(II) intel(0): Set up textured video
(II) intel(0): direct rendering: Failed
(II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(--) RandR disabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(EE) AIGLX: Screen 0 is not DRI capable
(II) Loading local sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
   compiled for 1.3.0, module version = 1.0.0
   ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(II) intel(0): Setting screen physical size to 338 x 270
(**) Option "Protocol" "auto"
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/input/mice"
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5 6 7"
(**) Mouse0: ZAxisMapping: buttons 4, 5, 6 and 7
(**) Mouse0: Buttons: 11
(**) Mouse0: Sensitivity: 1
(EE) No Input driver matching `kbd'
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(--) Mouse0: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
No core keyboard

Fatal server error:
failed to initialize core devices
(II) intel(0): xf86UnbindGARTMemory: unbind key 0
(II) intel(0): xf86UnbindGARTMemory: unbind key 1

Что можно сделать?


Last edited by alexd73 on Sun Dec 30, 2007 3:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
ba
l33t
l33t


Joined: 25 May 2003
Posts: 804

PostPosted: Tue Dec 25, 2007 2:05 am    Post subject: Reply with quote

там же все написано
Code:
[drm] failed to load kernel module "i915"
Back to top
View user's profile Send private message
alexd73
n00b
n00b


Joined: 02 Jul 2007
Posts: 15

PostPosted: Tue Dec 25, 2007 5:42 am    Post subject: Reply with quote

Я это видел.. но у меня нет этого модуля.. поддержка включена на уровне ядра...
Back to top
View user's profile Send private message
ba
l33t
l33t


Joined: 25 May 2003
Posts: 804

PostPosted: Tue Dec 25, 2007 12:29 pm    Post subject: Reply with quote

alexd73 wrote:
Я это видел.. но у меня нет этого модуля.. поддержка включена на уровне ядра...

попробуй модулем тогда

а dri включено в ядре?
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Thu Dec 27, 2007 7:32 am    Post subject: Reply with quote

Code:
(II) LoadModule: "kbd"
(WW) Warning, couldn't open module kbd

А это что?
Back to top
View user's profile Send private message
alexd73
n00b
n00b


Joined: 02 Jul 2007
Posts: 15

PostPosted: Fri Dec 28, 2007 10:03 am    Post subject: Reply with quote

Спасибо! все получилось, я как удак, ошибся и в input_devices пропустил "y" в слове keyboard...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum