Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[COMPILATION] Problèmes multiples (nouvelle install)(résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Sun Dec 23, 2007 9:50 am    Post subject: [COMPILATION] Problèmes multiples (nouvelle install)(résolu) Reply with quote

Salut à tous :) !


Après avoir complètement crashé ma gentoo, j'ai décidé de réinstaller. Seulement, j'ai plein de problèmes de compilation. Premièrement avec l'eternel svgalib (je ne sais toujours pas ce qu'il faut faire, parfois un USE="-svga" arrange les choses), et des problèmes OpenGL qui m'empêchent de compiler certains trucs comme WxGTK ou mesa-progs ... Voilà les build logs et mon emerge --info :

svgalib :

Code:
  CC [M]  /var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/interrupt.o
In file included from /var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/interrupt.c:4:
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/kernel26compat.h:74: attention : 'struct file_operations' declared inside parameter list
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/kernel26compat.h:74: attention : visible uniquement depuis cette d�finition ou d�claration, ce qui n'est probablement pas ce que vous d�sirez
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/kernel26compat.h: In function 'devfs_register_chrdev':
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/kernel26compat.h:76: erreur: implicit declaration of function 'register_chrdev'
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/kernel26compat.h: In function 'devfs_unregister_chrdev':
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/kernel26compat.h:80: erreur: implicit declaration of function 'unregister_chrdev'
make[2]: *** [/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/interrupt.o] Erreur 1
make[2]: *** Attente des t�ches non termin�es....
In file included from /var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.c:47:
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/kernel26compat.h: In function 'devfs_unregister_chrdev':
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/kernel26compat.h:80: erreur: valeur void n'a pas �t� ignor�e comme elle aurait d� l'�tre
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.c: In function 'svgalib_helper_ioctl':
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.c:363: attention : 'deprecated_irq_flag' is deprecated (declared at include/linux/interrupt.h:64)
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.c:363: attention : passing argument 2 of 'request_irq' from incompatible pointer type
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.c:363: attention : ignoring return value of 'request_irq', declared with attribute warn_unused_result
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.c: In function 'svgalib_helper_open':
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.c:451: attention : 'deprecated_irq_flag' is deprecated (declared at include/linux/interrupt.h:64)
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.c:451: attention : passing argument 2 of 'request_irq' from incompatible pointer type
/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.c:451: attention : ignoring return value of 'request_irq', declared with attribute warn_unused_result
make[2]: *** [/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper/main.o] Erreur 1
make[1]: *** [_module_/var/tmp/portage/media-libs/svgalib-1.9.25/work/svgalib-1.9.25/kernel/svgalib_helper] Erreur 2
make[1]: quittant le r�pertoire � /usr/src/linux-2.6.23-gentoo-r4 �
make: *** [default] Erreur 2
 *
 * ERROR: media-libs/svgalib-1.9.25 failed.
 * Call stack:
 *               ebuild.sh, line 1701:  Called dyn_compile
 *               ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *               ebuild.sh, line   44:  Called src_compile
 *   svgalib-1.9.25.ebuild, line   78:  Called linux-mod_src_compile
 *        linux-mod.eclass, line  518:  Called die
 * The specific snippet of code:
 *                      emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" \
 *                                ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} \
 *                              || die "Unable to make ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}."
 *  The die message:
 *   Unable to make  KDIR=/usr/src/linux default.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-libs/svgalib-1.9.25/temp/build.log'.
 *

 * Messages for package media-libs/svgalib-1.9.25:

 *
 * ERROR: media-libs/svgalib-1.9.25 failed.
 * Call stack:
 *               ebuild.sh, line 1701:  Called dyn_compile
 *               ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *               ebuild.sh, line   44:  Called src_compile
 *   svgalib-1.9.25.ebuild, line   78:  Called linux-mod_src_compile
 *        linux-mod.eclass, line  518:  Called die
 * The specific snippet of code:
 *                      emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" \
 *                                ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} \
 *                              || die "Unable to make ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}."
 *  The die message:
 *   Unable to make  KDIR=/usr/src/linux default.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-libs/svgalib-1.9.25/temp/build.log'.
 *
 * GNU info directory index is up-to-date.


wxGTK (problème OpenGL) :
Code:
checking GL/gl.h usability... yes
checking GL/gl.h presence... yes
checking for GL/gl.h... yes
checking for -lGL... no
checking for -lMesaGL... no
configure: error: OpenGL libraries not available

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/x11-libs/wxGTK-2.6.4.0-r1/work/wxPython-src-2.6.4.0/build_ansi/config.log
 *
 * ERROR: x11-libs/wxGTK-2.6.4.0-r1 failed.
 * Call stack:
 *                 ebuild.sh, line 1701:  Called dyn_compile
 *                 ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                 ebuild.sh, line   44:  Called src_compile
 *   wxGTK-2.6.4.0-r1.ebuild, line  115:  Called build_wx 'ansi'
 *   wxGTK-2.6.4.0-r1.ebuild, line  186:  Called econf '--enable-shared' '--disable-optimise' '--disable-rpath' '--enable-compat24' '--with-regex=builtin' '--with-zlib=sys' '--with-expat' '--disable-precomp-headers' '--disable-joystick' '--with-sdl' '--without-odbc' '--enable-gui' '--with-libpng' '--with-libxpm' '--with-libjpeg' '--with-libtiff' '--enable-opengl' '--with-opengl' '--without-gnomeprint' '--disable-unicode'
 *                 ebuild.sh, line  638:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-libs/wxGTK-2.6.4.0-r1/temp/build.log'.
 *

 * Messages for package x11-libs/wxGTK-2.6.4.0-r1:

 *
 * ERROR: x11-libs/wxGTK-2.6.4.0-r1 failed.
 * Call stack:
 *                 ebuild.sh, line 1701:  Called dyn_compile
 *                 ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                 ebuild.sh, line   44:  Called src_compile
 *   wxGTK-2.6.4.0-r1.ebuild, line  115:  Called build_wx 'ansi'
 *   wxGTK-2.6.4.0-r1.ebuild, line  186:  Called econf '--enable-shared' '--disable-optimise' '--disable-rpath' '--enable-compat24' '--with-regex=builtin' '--with-zlib=sys' '--with-expat' '--disable-precomp-headers' '--disable-joystick' '--with-sdl' '--without-odbc' '--enable-gui' '--with-libpng' '--with-libxpm' '--with-libjpeg' '--with-libtiff' '--enable-opengl' '--with-opengl' '--without-gnomeprint' '--disable-unicode'
 *                 ebuild.sh, line  638:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-libs/wxGTK-2.6.4.0-r1/temp/build.log'.
 *


mesa-progs :
Code:
>>> Compiling source in /var/tmp/portage/x11-apps/mesa-progs-7.0.1/work/Mesa-7.0.1 ...
i686-pc-linux-gnu-gcc -I../../include -Wall -Wmissing-prototypes -std=c99 -ffast-math -march=prescott -O2 -pipe -fomit-frame-pointer   -m32 -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DHAVE_POSIX_MEMALIGN -DUSE_X86_ASM -DUSE_MMX_ASM -DUSE_3DNOW_ASM -DUSE_SSE_ASM glxinfo.c -L../../lib -lglut -lGLU -lGL -lm -o glxinfo
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lGL
collect2: ld a retourn� 1 code d'�tat d'ex�cution
make: *** [glxinfo] Erreur 1
 *
 * ERROR: x11-apps/mesa-progs-7.0.1 failed.
 * Call stack:
 *                 ebuild.sh, line 1701:  Called dyn_compile
 *                 ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                 ebuild.sh, line   44:  Called src_compile
 *   mesa-progs-7.0.1.ebuild, line   68:  Called die
 * The specific snippet of code:
 *      emake glxinfo || die "glxinfo failed"
 *  The die message:
 *   glxinfo failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-apps/mesa-progs-7.0.1/temp/build.log'.
 *

 * Messages for package x11-apps/mesa-progs-7.0.1:

 *
 * ERROR: x11-apps/mesa-progs-7.0.1 failed.
 * Call stack:
 *                 ebuild.sh, line 1701:  Called dyn_compile
 *                 ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                 ebuild.sh, line   44:  Called src_compile
 *   mesa-progs-7.0.1.ebuild, line   68:  Called die
 * The specific snippet of code:
 *      emake glxinfo || die "glxinfo failed"
 *  The die message:
 *   glxinfo failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-apps/mesa-progs-7.0.1/temp/build.log'.
 *


mon emerge --info :
Code:
Portage 2.1.3.19 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-14-generic i686)
=================================================================
System uname: 2.6.22-14-generic i686 Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
Timestamp of tree: Sun, 23 Dec 2007 09:16:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.1.3
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer "
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer "
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://213.186.33.38/gentoo-distfiles/"
LANG="fr_FR@euro"
LC_ALL="fr_FR@euro"
LINGUAS="fr"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 acl alsa apm arts asf avi berkdb bitmap-fonts cli corba cracklib crypt css cups dbus dri dts dvd dvdnav dvdr dvdread encode exif f77 ffmpeg firefox foomaticdb fortran gdbm gif gpm gtk gtk2 hal iconv imlib ipv6 isdnlog java jpeg jpeg2k libg++ libwww mad midi mikmod mjpeg mjpegtools motif mozilla mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin nvidia objc++ oggvorbis opengl opengloss openmp pam pcre pdflib perl png pppd python qt quicktime readline real reflection sdl session shout skins spell spl ssl stream svga tcpd truetype truetype-fonts type1-fonts unicode vlc vlm win32codecs wxgtk wxwindows x86 xine xine-lib xml2 xorg xv xvid xvmc yv12 zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev mice event" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev nv vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


C'est grave docteur ? 8-)

D'avance merci !
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]


Last edited by BoOmSlAnGz on Sun Dec 23, 2007 2:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Sun Dec 23, 2007 10:38 am    Post subject: Reply with quote

et avec FEATURES="-sandbox" ca dis quoi ?

EDIT = eselect opengl list et sélectionne celui quiqui vas bien ^^
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Sun Dec 23, 2007 11:16 am    Post subject: Reply with quote

dapsaille wrote:
et avec FEATURES="-sandbox" ca dis quoi ?

EDIT = eselect opengl list et sélectionne celui quiqui vas bien ^^


Déjà essayé :) c'est pas un problème sandbox.

Pour mesa-progs j'ai trouvé ! Il n'y avait pas de libGL.so dans mon /usr/lib/opengl/nvidia/lib
jai fait un re-emerge de nvidia-drivers et de mesa et c'est OK :)

On progresse... je continues à chercher pour le reste :)

Par contre pour svgalib ... :(

// EDIT : wxGTK est en cours de compilation mais toujours le problème svgalib ...
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
elgrande71
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 131
Location: France

PostPosted: Sun Dec 23, 2007 1:32 pm    Post subject: Reply with quote

Pour le paquetage svgalib, quelle est la valeur de la variable MAKEOPTS dans le fichier /etc/make.conf ?
_________________
Asustek P5Q-PRO Core2Quad Q9550 - 4Gb DDRII1066
Gentoo Linux 10.0 amd64 - fs ext3 - 2.6.39-gentoo-r3
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Sun Dec 23, 2007 1:40 pm    Post subject: Reply with quote

elgrande71 wrote:
Pour le paquetage svgalib, quelle est la valeur de la variable MAKEOPTS dans le fichier /etc/make.conf ?

-j2
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
elgrande71
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 131
Location: France

PostPosted: Sun Dec 23, 2007 1:41 pm    Post subject: Reply with quote

Essaie d'installer svgalib avec MAKEOPTS="-j1".
_________________
Asustek P5Q-PRO Core2Quad Q9550 - 4Gb DDRII1066
Gentoo Linux 10.0 amd64 - fs ext3 - 2.6.39-gentoo-r3
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Sun Dec 23, 2007 1:43 pm    Post subject: Reply with quote

elgrande71 wrote:
Essaie d'installer svgalib avec MAKEOPTS="-j1".

Aucun changement :(
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
elgrande71
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 131
Location: France

PostPosted: Sun Dec 23, 2007 1:49 pm    Post subject: Reply with quote

As-tu essayé plutôt d'installer la version 1.9.24 de svgalib via la ligne de commande suivante : emerge =media-libs/svga-lib-1.9.24 ?
_________________
Asustek P5Q-PRO Core2Quad Q9550 - 4Gb DDRII1066
Gentoo Linux 10.0 amd64 - fs ext3 - 2.6.39-gentoo-r3
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Sun Dec 23, 2007 1:55 pm    Post subject: Reply with quote

elgrande71 wrote:
As-tu essayé plutôt d'installer la version 1.9.24 de svgalib via la ligne de commande suivante : emerge =media-libs/svga-lib-1.9.24 ?


Euh, je dois avouer que je n'y ai pas pensé ! C'est vrai que c'est une des premières choses que j'aurai dû faire :P

J'essaye tout de suite.
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Sun Dec 23, 2007 1:58 pm    Post subject: Reply with quote

Même erreur :'(
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
elgrande71
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 131
Location: France

PostPosted: Sun Dec 23, 2007 2:01 pm    Post subject: Reply with quote

Quand tu lances emerge -vp svgalib quelles sont les USE utilisées (build, no-helper) ?
_________________
Asustek P5Q-PRO Core2Quad Q9550 - 4Gb DDRII1066
Gentoo Linux 10.0 amd64 - fs ext3 - 2.6.39-gentoo-r3
Back to top
View user's profile Send private message
elgrande71
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 131
Location: France

PostPosted: Sun Dec 23, 2007 2:05 pm    Post subject: Reply with quote

Essaie de l'installer comme ceci : USE="no-helper" emerge svgalib

Qu'est-ce que ça te dit ?
_________________
Asustek P5Q-PRO Core2Quad Q9550 - 4Gb DDRII1066
Gentoo Linux 10.0 amd64 - fs ext3 - 2.6.39-gentoo-r3
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Sun Dec 23, 2007 2:09 pm    Post subject: Reply with quote

elgrande71 wrote:
Essaie de l'installer comme ceci : USE="no-helper" emerge svgalib

Qu'est-ce que ça te dit ?


Excellent, ça fonctionne, merci ! :)
J'aurais dû y penser ^^

Bonne journée et joyeuses fêtes à tous ;)
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
elgrande71
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2004
Posts: 131
Location: France

PostPosted: Sun Dec 23, 2007 2:12 pm    Post subject: Reply with quote

De même, merci.

J'ai vu aussi que certains maintainers voudraient supprimer le paquetage svgalib. Pour ceux que ça intéressent, on peut essayer de reconstruire le système sans le flag "svga".

Le lien : https://forums.gentoo.org/viewtopic-t-626555-highlight-svgalib.html

A voir. :wink:
_________________
Asustek P5Q-PRO Core2Quad Q9550 - 4Gb DDRII1066
Gentoo Linux 10.0 amd64 - fs ext3 - 2.6.39-gentoo-r3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum