Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]Gentoo muto
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Soulless6.3
n00b
n00b


Joined: 19 Dec 2007
Posts: 50

PostPosted: Sun Dec 23, 2007 8:45 am    Post subject: [RISOLTO]Gentoo muto Reply with quote

Dopo problemi con il video non potevo non averceli con l'audio...
Quindi eccoli il pc non emette alcun suono: ad esempio all'entrata o uscita di kde anche se ho impostato che riproduca dei suoni non sento niente, se provo a far partire amarok dice che non trova nessun driver da utilizzare.
Io ho emerso gli alsa anche se avevo gi messo alsa e oss come built-in nel kernel ma continua a non funzionare.
Come scheda audio ho una Trust( :cry: ) SC-5200 5.1
Infine una curiosta'(stavolta ho sbagliato a mettere il layout e ho messo quello senza stressed ecco perche ho gli accenti cosi') dove trovo la voce per i suoni di sistema tipo quella della tipa che fa il conto alla rovescia per l'autodistruzione nei film(quella di knoppix per capirci)?


Last edited by Soulless6.3 on Sun Dec 23, 2007 3:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Dec 23, 2007 9:13 am    Post subject: Reply with quote

provato a lanciare alsaconf ?

in media, trova i driver da solo.
a volte, bisogna anche alzare il volume, che di default è (o almeno era) messo a zero.

alsamixer
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Soulless6.3
n00b
n00b


Joined: 19 Dec 2007
Posts: 50

PostPosted: Sun Dec 23, 2007 10:05 am    Post subject: Reply with quote

Code:
soulless@MrEvil ~ $ alsaconf
bash: alsaconf: command not found
soulless@MrEvil ~ $ alsa-conf
bash: alsa-conf: command not found


Code:
soulless@MrEvil ~ $ alsamixer

alsamixer: function snd_ctl_open failed for default: No such device


fra l'altro alsamixer e alsa conf non li trovo manco con emerge -s.

P.s. Alsa-tools e alsa-utils li ho scaricati
Back to top
View user's profile Send private message
Jisaw
n00b
n00b


Joined: 14 Dec 2007
Posts: 15
Location: Torino

PostPosted: Sun Dec 23, 2007 10:21 am    Post subject: Reply with quote

Soulless6.3 wrote:
Code:
soulless@MrEvil ~ $ alsaconf
bash: alsaconf: command not found
soulless@MrEvil ~ $ alsa-conf
bash: alsa-conf: command not found


Code:
soulless@MrEvil ~ $ alsamixer

alsamixer: function snd_ctl_open failed for default: No such device


fra l'altro alsamixer e alsa conf non li trovo manco con emerge -s.

P.s. Alsa-tools e alsa-utils li ho scaricati


Da quello che hai postato mi pare che alsamixer sia correttamente installato, ti dice solamente che non trova nessun device. Su alsaconf non saprei aiutarti perchè uso i driver del kernel. Comunque, hai dato una lettura a questo?
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Dec 23, 2007 10:34 am    Post subject: Reply with quote

Soulless6.3 wrote:
Code:
soulless@MrEvil ~ $ alsaconf
bash: alsaconf: command not found


Code:

cloc3@s939 ~ $ alsaconf
bash: alsaconf: command not found

8O anche a me uguale?
...
:)
Code:

s939 ~ # which alsaconf
/usr/sbin/alsaconf

anzi no.
vediamo se capisci la differenza.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Soulless6.3
n00b
n00b


Joined: 19 Dec 2007
Posts: 50

PostPosted: Sun Dec 23, 2007 11:35 am    Post subject: Reply with quote

Quote:
anzi no.
vediamo se capisci la differenza.


Root?

Ora funziona però mi dice che mancano i legacy driver...
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Dec 23, 2007 11:44 am    Post subject: Reply with quote

root.
Soulless6.3 wrote:

Ora funziona però mi dice che mancano i legacy driver...

quelli vanno cercati nel kernel, sezione audio.
li puoi compilare come moduli e rilanciare senza nemmeno fare reboot.

se nessuno di quelli presenti funzionasse, google sarà la tua speranza.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Dec 23, 2007 12:02 pm    Post subject: Reply with quote

qui trovi una dritta che potrebbe giovarti.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Soulless6.3
n00b
n00b


Joined: 19 Dec 2007
Posts: 50

PostPosted: Sun Dec 23, 2007 3:28 pm    Post subject: Reply with quote

Ho trovato una guida al riguardo ai driver che mi servono(cmpci) nella wiki di ALSA.
Ma dice che nel kernel devo attivare il soundcore che citando il testo

Quote:
You must turn on the sound support soundcore module. This is in the kernel. Look in the sound drivers directory and it should be the first option


Dovrebbe trovarsi sotto Device Drivers--->Sound
Ma io sotto tale voce non trovo nulla di simile ma solo:

Code:
      <*> Sound card support
         Advanced Linux Sound Architecture  --->
         Open Sound System  --->


E non c'è nulla neanche nei sottomenù...
Back to top
View user's profile Send private message
Soulless6.3
n00b
n00b


Joined: 19 Dec 2007
Posts: 50

PostPosted: Sun Dec 23, 2007 3:46 pm    Post subject: Reply with quote

Risolto...
Sotto la voce alsa del kernel c'erano i driver per la mia scheda(solo che non capivo che era lei perchè è un prodotto rimarchiato).

GOD save the kernel, Grazie a tutti
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum