Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[firefox] conflit entre source et binaire en 64 bits(résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Tue Dec 18, 2007 12:25 am    Post subject: [firefox] conflit entre source et binaire en 64 bits(résolu) Reply with quote

Bonjour,

Je viens de me réinstaller une Gentoo toute propre, j'ai un Core 2 Duo, j'ai donc installé ma Gentoo en 64bits.
Pour ne pas me prendre la tête avec firefox et nspluginwrapper, j'ai installé le binaire de firefox www-client/mozilla-firefox-bin avec le flash et le java, jusque là pas de problèmes, mais en faisant un petit
Code:
emerge --ask --update --deep world
j'ai des softs qui ont besoin de firefox comme dépendance et qui ne tiennent pas compte du fait que j'ai déja un firefox d'installer, du coup je me retrouve avec l'erreur suivante:
Code:

* Messages for package www-client/mozilla-firefox-2.0.0.11:

 * You are enabling official branding. You may not redistribute this build
 * to any users on your network or the internet. Doing so puts yourself into
 * a legal problem with Mozilla Foundation
 * You can disable it by emerging mozilla-firefox _with_ the bindist USE-flag
 * This package will overwrite one or more files that may belong to other
 * packages (see list below). Add "collision-protect" to FEATURES in
 * make.conf if you would like the merge to abort in cases like this. You
 * can use a command such as `portageq owners / <filename>` to identify
 * the installed package that owns a file. If portageq reports that only
 * one package owns a file then do NOT file a bug report. A bug report is
 * only useful if it identifies at least two or more packages that are
 * known to install the same file(s). If a collision occurs and you can
 * not explain where the file came from then you should simply ignore the
 * collision since there is not enough information to determine if a real
 * problem exists. Please do NOT file a bug report at
 * http://bugs.gentoo.org unless you report exactly which two packages
 * install the same file(s). Once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *      /usr/bin/firefox
 * Please remember to rebuild any packages that you have built
 * against Firefox. Some packages might be broken by the upgrade; if this
 * is the case, please search at http://bugs.gentoo.org and open a new bug
 * if one does not exist. Before filing any bugs, please move or remove
 *  ~/.mozilla and test with a clean profile directory.
 * GNU info directory index is up-to-date.


Code:

emerge --info
Portage 2.1.3.19 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.23-gentoo-r3 x86_64 Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz
Timestamp of tree: Mon, 17 Dec 2007 22:16:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "
LANG="fr_FR.UTF-8"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi aim alsa amd64 ao apm arts audiofile bash-completion berkdb bitmap-fonts bonobo branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt cscope cups curl curlwrappers dbus dri dv dvb dvd dvdr dvdread emacs encode esd exif expat ffmpeg flac foomaticdb fortran ftp gd gdbm gif gnome gphoto2 gpm gstreamer gtk hal iconv icq imagemagick imap imlib innodb ipv6 isdnlog jabber java javascript jpeg jpeg2k lame libnotify libwww lm_sensors mhash midi mmx mp3 mpeg mplayer msn mudflap mule mysql mysqli ncurses nls nptl nptlonly ogg opengl openmp osc oscar oss pam pcre pdf perl php png posix pppd python quicktime rdesktop readline reflection session simplexml snmp soap spl sse sse2 ssl syslog tcpd tiff truetype truetype-fonts type1-fonts unicode usb vhosts videos vim-syntax vorbis x264 xine xinerama xml xorg xosd xpm xsl xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


J'ai viré firefox, mozilla et nsplugin de mon /etc/make.conf

Avez-vous une idée de comment je pourrais résoudre mon problème? J'ai essayé de masquer le package firefox mais en vain ...
_________________
Caleçon qui gratte, morpions qui squattent.


Last edited by Re[s]eT on Wed Dec 19, 2007 12:38 am; edited 2 times in total
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Tue Dec 18, 2007 1:24 am    Post subject: Reply with quote

C'est quels paquets qui posent problème ?
regarde si ils n'ont pas un useflag "xulrunner" qui pourrait remplacer la dépendance de Firefox,
Back to top
View user's profile Send private message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Tue Dec 18, 2007 7:50 pm    Post subject: Reply with quote

vlc ou epiphany par exemple et non ils n'ont pas le useflag xulrunner ...
_________________
Caleçon qui gratte, morpions qui squattent.
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Dec 18, 2007 8:12 pm    Post subject: Reply with quote

La version binaire de Firefox ne fourni par les headers nécessaires à la compilation d'Epiphany et co. Il te faut soit la version source de Firefox, soit la version source de Seamonkey, soit Xulrunner, mais la compilation de Xulrunner prendra pratiquement autant de temps que de compiler Firefox, et ça prendre 2 fois plus de place que la normale au final, donc il n'y aurai aucun gain.
Donc, il faut que tu compiles Firefox ;)
Back to top
View user's profile Send private message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Tue Dec 18, 2007 8:16 pm    Post subject: Reply with quote

oué je veux bien mais quand je compile firefox, vu que j'ai censervé la version binaire de firefox, j'ai le droit au message suivant:
Code:

* Detected file collision(s):
 *
 *      /usr/bin/firefox
 * Please remember to rebuild any packages that you have built
 * against Firefox. Some packages might be broken by the upgrade; if this
 * is the case, please search at http://bugs.gentoo.org and open a new bug
 * if one does not exist. Before filing any bugs, please move or remove
 *  ~/.mozilla and test with a clean profile directory.
 * GNU info directory index is up-to-date.

_________________
Caleçon qui gratte, morpions qui squattent.
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Dec 18, 2007 8:28 pm    Post subject: Reply with quote

Portage ne devrait même pas te laisser emerger une version pendant que t'en a une autre d'installé ... tu dois virer la version binaire avant d'installer la version source :)
Back to top
View user's profile Send private message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Tue Dec 18, 2007 8:31 pm    Post subject: Reply with quote

Je veux bien mais si j'ai mis la version binaire c'etait pour ne pas trop me faire chier à recompiler à chaque fois firefox quand il y a une nouvelle version et surtout pour éviter de galerer avec nspluginwrapper pour le flash etc ...
_________________
Caleçon qui gratte, morpions qui squattent.
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Tue Dec 18, 2007 10:03 pm    Post subject: Reply with quote

Epiphany a le flag xulrunner...

Quote:
www-client/epiphany
Available versions: 2.16.3 2.18.2 2.18.3 ~2.20.0 2.20.1 ~2.20.2 {debug doc networkmanager python spell xulrunner}


Et devine quoi

Quote:
* media-video/vlc
Available versions: 0.8.6c ~0.9.0_alpha20071009 ~0.9.0_alpha20071022 -*9999999[1] {3dfx X a52 aac aalib alsa altivec arts audioscrobbler avahi bidi cdda cddb cdio corba daap dbus dc1394 debug dirac directfb dts dvb dvbpsi dvd esd fbcon ffmpeg flac freetype fribidi ggi gnome gnutls gtk2 hal httpd id3tag jack java joystick libcaca libcddb libcdio libgcrypt libnotify lirc live live555 lua madmusipac matroska mod modplug mp3 mpc mpeg musepack musicbrainz ncurses nls nsplugin ogg opengl optimisememory oss png pvr python qt4 qt_embedded quicktime real rtsp samba screen sdl sdl-image seamonkey shout skins skins2 speex stream svg svga taglib tarkin theora tremor truetype twolame unicode upnp v4l v4l2 vcd vcdx vlm vorbis win32codecs wxwindows x264 xinerama xml xml2 xosd xulrunner xv}


oui vlc aussi

:roll:
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Tue Dec 18, 2007 10:05 pm    Post subject: Reply with quote

arf, c'est quoi la commande qui t'a donné ca ? :evil:
Vous me conseillez de recompiler epiphany et vlc avec un petit:
Code:

USE="-xulrunner" emerge vlc epiphany


? :twisted:
_________________
Caleçon qui gratte, morpions qui squattent.
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Tue Dec 18, 2007 10:13 pm    Post subject: Reply with quote

roh lalalalalala

ajoute ce flag -xulrunner à ton make.conf et emerge epipahny et vlc...

Ensuite le prog que j'utilise (que tout le monde utilise ^^ ) est eix
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Tue Dec 18, 2007 10:18 pm    Post subject: Reply with quote

Pour le rajout à mon make.conf c'est fait depuis quelques minutes et la recompilation est en cours.
Pour ce qui d'eix je ne connaissais pas, on en apprend tous les jours :)
Merci pour l'info.
_________________
Caleçon qui gratte, morpions qui squattent.
Back to top
View user's profile Send private message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Tue Dec 18, 2007 11:06 pm    Post subject: Reply with quote

Malgrès le rajout a mon make.conf du USE -xulrunner, lorsque que je fais un update de mon système, j'ai le droit à :
Code:

# emerge --update --ask --deep --newuse world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild  N    ] www-client/mozilla-firefox-2.0.0.11  USE="gnome ipv6 java xinerama -bindist -debug -filepicker -iceweasel -mozdevelop -moznopango -restrict-javascript -xforms -xprint" LINGUAS="-af -ar -be -bg -ca -cs -da -de -el -en_GB -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW"


Une petite idée pour éviter ca ? :)

ps:
Code:

# emerge --info
Portage 2.1.3.19 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.23-gentoo-r3 x86_64 Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz
Timestamp of tree: Tue, 18 Dec 2007 19:16:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "
LANG="fr_FR.UTF-8"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi aim alsa amd64 ao apm arts audiofile bash-completion berkdb bitmap-fonts bonobo branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt cscope cups curl curlwrappers dbus dri dv dvb dvd dvdr dvdread emacs encode esd exif expat ffmpeg flac foomaticdb fortran ftp gd gdbm gif gnome gphoto2 gpm gstreamer gtk hal iconv icq imagemagick imap imlib innodb ipv6 isdnlog jabber java javascript jpeg jpeg2k lame libnotify libwww lm_sensors mhash midi mmx mp3 mpeg mplayer msn mudflap mule mysql mysqli ncurses nls nptl nptlonly ogg opengl openmp osc oscar oss pam pcre pdf perl php png posix pppd python quicktime rdesktop readline reflection session simplexml snmp soap spl sse sse2 ssl syslog tcpd tiff truetype truetype-fonts type1-fonts unicode usb vhosts videos vim-syntax vorbis x264 xine xinerama xml xorg xosd xpm xsl xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

_________________
Caleçon qui gratte, morpions qui squattent.
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Tue Dec 18, 2007 11:16 pm    Post subject: Reply with quote

ajoute l'option --tree à ton emerge qu'on puisse voir quel ebuild demande firefox
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Tue Dec 18, 2007 11:19 pm    Post subject: Reply with quote

Code:

borealis space # emerge --ask --update --deep --newuse --tree world

These are the packages that would be merged, in reverse order:

Calculating world dependencies... done!
[nomerge      ] gnome-base/gnome-2.20.1 
[nomerge      ]  gnome-extra/yelp-2.20.0 
[ebuild  N    ]   www-client/mozilla-firefox-2.0.0.11  USE="gnome ipv6 java xinerama -bindist -debug -filepicker -iceweasel -mozdevelop -moznopango -restrict-javascript -xforms -xprint" LINGUAS="-af -ar -be -bg -ca -cs -da -de -el -en_GB -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW"


Voilà

Code:

borealis space # eix yelp
[I] gnome-extra/yelp
     Available versions:  2.14.2-r2 2.16.2 2.18.1 2.20.0 {beagle debug firefox xulrunner}
     Installed versions:  2.20.0(16:22:26 16.12.2007)(-beagle -debug -xulrunner)
     Homepage:            http://www.gnome.org/
     Description:         Help browser for GNOME

_________________
Caleçon qui gratte, morpions qui squattent.
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Tue Dec 18, 2007 11:24 pm    Post subject: Reply with quote

ajoute dans ton package.use

Code:
gnome-extra/yelp -firefox

("+"xulrunner est déjà dans ton make.conf ;) )

recompile yelp (ou emerge -auvDN world)

Hum d'après ton edit, pas besoin de ma ligne dans le package.use... recompile juste yelp.
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Tue Dec 18, 2007 11:28 pm    Post subject: Reply with quote

Code:

borealis space # emerge -auvDN world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild  N    ] www-client/mozilla-firefox-2.0.0.11  USE="gnome ipv6 java xinerama -bindist -debug -filepicker -iceweasel -mozdevelop -moznopango -restrict-javascript -xforms -xprint" LINGUAS="-af -ar -be -bg -ca -cs -da -de -el -en_GB -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW" 0 kB
[ebuild  N    ] gnome-extra/yelp-2.20.0  USE="-beagle -debug -xulrunner" 0 kB

Total: 2 packages (2 new), Size of downloads: 0 kB


Il persiste à me rebalancer firefox :evil:
_________________
Caleçon qui gratte, morpions qui squattent.
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Tue Dec 18, 2007 11:42 pm    Post subject: Reply with quote

recompile dabord yelp avec le flag xulrunner activé (je comprend pas pourquoi il persiste à indiquer -xulrunner, tu ne l'as pas mis dans le make.conf ? sinon force le dans package.use )
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Tue Dec 18, 2007 11:46 pm    Post subject: Reply with quote

Bah met lui l'useflag xulrunner a lui aussi.

Au fait pour définir un useflag c'est son nom "xulrunner", "-xulrunner" c'est pour enlever l'useflag.
Back to top
View user's profile Send private message
Re[s]eT
n00b
n00b


Joined: 25 Oct 2004
Posts: 35
Location: Nice

PostPosted: Wed Dec 19, 2007 12:37 am    Post subject: Reply with quote

C'est bon depuis que j'ai supprimé le package net-www/mplayerplug-in-3.35 :)
Merci pour votre aide.
_________________
Caleçon qui gratte, morpions qui squattent.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum