Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bus error after upgrading
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
korz
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2003
Posts: 140
Location: Cologne, Germany

PostPosted: Tue Dec 18, 2007 12:07 am    Post subject: Bus error after upgrading Reply with quote

Hi,
I have a problem with my ultra 60 workstation. After upgrading to gnome 2.20, some applications refused to work, e.g. gnome-appearance-properties and seamonkey. While seamonkey at least works for some time, before it dies, the gnome-appearance-properties window closes directly, after it had opened.
The error message is in both cases "Bus error".
In other postings, I read, that this behavior may or may not be the result of a hardware failure.

Other applications, like firefox, xorg and the major part of gnome run without problems.

Very strange.

Can someone give me an advice, what to do?

Thanks!
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Tue Dec 18, 2007 1:52 pm    Post subject: Reply with quote

Bus errors are usually software problems, and they mean that some application is using unaligned addresses (sparc requires that the address of a data item must be aligned modulo its size, so, for example, 0x8 is a good address for a double precision item but 0xA is not). I don't know about your specific problem because I do not know gnome. I do know, however, if as part of your upgrade you happened to install =x11-libs/cairo-1.5.4, you will have just the sort of problem you are describing, and you should use x11-libs/cairo-1.4.12.

Hope this makes some sense, at least.
Regards,
Back to top
View user's profile Send private message
korz
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2003
Posts: 140
Location: Cologne, Germany

PostPosted: Wed Dec 26, 2007 4:34 pm    Post subject: Reply with quote

Hi, thank you for your answer.
I had cairo 1.4.10 installed on my system. I upgraded to 1.4.12 without any improvement.
I created a completely new stage 3 installation on a different harddisk and emerged xorg-x11 and seamonkey. Again, without any improvement. Still the same error.
At least, Solaris seems to run fine.

Frank
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum