Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]errore cpufreqd dopo aggiornamento kernel
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Mon Dec 17, 2007 4:33 pm    Post subject: [Risolto]errore cpufreqd dopo aggiornamento kernel Reply with quote

ho compilato i gentoo-sources-2.6.23-r1, tutto bene, tranne che al boot ed allo shutdown, mi compaiono i seguenti messaggi
Code:
cpufreqd: term_handler             : Caught TERM signal (Terminated), forcing exit.
Dec 17 17:21:06 tiger cpufreqd: acpi_battery_init        : error, acpi_battery module not compiled or inserted (/proc/acpi/battery/: No such file or directory)?
Dec 17 17:21:06 tiger cpufreqd: acpi_battery_init        : exiting.
cpufreqd   sensors_post_conf     :   sensors_init()  failed,  sensors disabled!


in dmesg
Code:
Dec 17 17:21:47 tiger [ 2460.648051] bat.pc[20144]: segfault at 00000000 eip b7f5af9d esp bfacbbe0 error 6
Dec 17 17:21:47 tiger [ 2460.664499] bat.pc[20145]: segfault at 00000000 eip b7f33f9d esp bfe15720 error 6
Dec 17 17:22:03 tiger [ 2476.637516] bat.pc[20194]: segfault at 00000000 eip b7f2cf9d esp bf8cc9e0 error 6
Dec 17 17:22:03 tiger [ 2476.653585] bat.pc[20195]: segfault at 00000000 eip b7f98f9d esp bfea5fb0 error 6

inoltre ho notato che in /proc non ho più le directory /battery e /ac_adapter che invece con il kernel precedente avevo.
Ho compilato con il .config precedente, dando make oldconfig .
Ho ricontrollato i moduli relativi al power-managment e sembra tutto invariato.
Idee per risolvere?
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)


Last edited by Tigerwalk on Wed Dec 19, 2007 7:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Dec 17, 2007 5:33 pm    Post subject: Reply with quote

hai ancora l'opzione per la "deprecated /proc interface" o qualcosa del genere nel menù dell'acpi (riferito al solito make menuconfig)?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Mon Dec 17, 2007 5:56 pm    Post subject: Reply with quote

djinnZ wrote:
hai ancora l'opzione per la "deprecated /proc interface" o qualcosa del genere nel menù dell'acpi (riferito al solito make menuconfig)?

l' avevo, adesso sto ricompilando con l'opzione disattivata e poi ti faccio sapere.
Grazie, nel mentre...
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Mon Dec 17, 2007 6:25 pm    Post subject: Reply with quote

no djinnZ, non è quello il problema, la ricompilazione senza la voce da te segnalata non ha apportato cambiamenti nei messaggi d'errore.....
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
Ty[L]eR
Apprentice
Apprentice


Joined: 18 May 2004
Posts: 190
Location: it

PostPosted: Mon Dec 17, 2007 6:46 pm    Post subject: Reply with quote

c'è stato un aggiornamento di sysfs-utils prova a vedere con revdep-rebuild se magari è dovuto a quello (io ho dovuto ricompilare cpufrequtils e lm-sensors)
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Mon Dec 17, 2007 8:29 pm    Post subject: Reply with quote

Ty[L]eR wrote:
c'è stato un aggiornamento di sysfs-utils prova a vedere con revdep-rebuild se magari è dovuto a quello (io ho dovuto ricompilare cpufrequtils e lm-sensors)

nessuna libreria broken ed anche ricompilando cpufreqd cpufrequtils e lm_sensors non cambia niente. Deve essere qualcosa nel kernel che non mi fa nemmeno apparire le cartelle battery e ac_adapter in /proc/acpi ma non riesco a capire cosa.
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Dec 18, 2007 10:59 am    Post subject: Reply with quote

Tigerwalk wrote:
la ricompilazione senza la voce da te segnalata non ha apportato cambiamenti nei messaggi d'errore...
8O veramente mi riferivo al fatto che il supporto tramite /proc è deprecato e potevano averlo rimosso (non ho ancora guardato la versione del kernel che usi e pensavo la avessero tolta definitivamente di mezzo, e se non mi sbaglio è così)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Tue Dec 18, 2007 4:05 pm    Post subject: Reply with quote

probabilmente, avendo dato make oldconfig se l'era portata dietro....
[Edit]: risolto con una ricompilazione del kernel facendo un diff dei .config attuale e precedente e attivando alcune opzioni che make oldconfig non aveva "passato"....
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum