Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gcc 4.1 can't compile KDE because it needs gcc 3.4??
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
darkwingduck823
n00b
n00b


Joined: 13 Dec 2007
Posts: 4
Location: Iowa

PostPosted: Thu Dec 13, 2007 1:27 am    Post subject: gcc 4.1 can't compile KDE because it needs gcc 3.4?? Reply with quote

hello, this is my first time posting and i am having some real trouble that i have never run into before.
i have compiled gentoo many times on this board, but i switched to a new one, chick busted on me, so i am back to my old intel p4. but this time around when i went to compile the ATI drivers i needed GCC 3.4 which wouldnt compile on account of a bootstrap-lean problem. so i popped the card out, re-compiled the kernel for my on board video and moved on to KDE (mind you, xorg is configured and working fine) and i got the same problem. it has gcc 3.4 for a dependency and that wont compile on account of a bootstrap-lean problem. i havent set bootstrap in the make.conf. does anyone know what is up?

i also checked gcc-config which of course said that i only have 4.1 installed on account of me using a brand me minimal disk anyways.
_________________
- Darkwing Duck
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Thu Dec 13, 2007 6:01 am    Post subject: Reply with quote

Do an "emerge -pvt" to get a better idea of what's pulling in the dependency. I can tell you, it's actually not gcc-3.4 that's needed. Rather, it's virtual/libstdc++, and it's defaulting to gcc to satisfy that. If you just want to work around it for now, try doing this first:

Code:

emerge libstdc++-v3


which may avoid the trouble you're seeing with trying to build the entire compiler instead of just the C++ library.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
darkwingduck823
n00b
n00b


Joined: 13 Dec 2007
Posts: 4
Location: Iowa

PostPosted: Fri Dec 14, 2007 3:16 pm    Post subject: thanks Reply with quote

thank you very much. i had tried libstdc++ but i didnt know i needed the v3. its finally doing its thing, and i even was able to get my ati-drivers to compile!!!
_________________
- Darkwing Duck
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Fri Dec 14, 2007 4:15 pm    Post subject: Reply with quote

Well, now it makes sense: ati-drivers is what needs libstdc++.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Sat Dec 15, 2007 4:02 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads, refer to topic "Portage wants me to merge gcc 3?!".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum