Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] revdep-rebuild impazzito su libkdecore.so.4.2.0
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Dec 12, 2007 1:41 pm    Post subject: [RISOLTO] revdep-rebuild impazzito su libkdecore.so.4.2.0 Reply with quote

Ciao a tutti,

Mi sta accadendo una cosa strana facendo revdep-rebuild.
Sono già tre volte di seguito che do un revdep-rebuild e per tre volte mi dice che:
Code:
 broken /usr/kde/3.5/lib32/libkdecore.so.4.2.0 (requires  libexpat.so.0)

Ok...

Poi mi vuole riemergere app-emulation/emul-linux-x86-qtlibs-10.0 e lo fa.
Lancio di nuovo revdep-rebuild per vedere se ci sono dipendenze insoddisfatte o link rotti e di nuovo la stessa storia.

Com'è possibile? Eppure il pacchetto finisce l'emerge senza problemi. 8O :?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Wed Dec 12, 2007 5:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
Kind_of_blue
Guru
Guru


Joined: 10 Oct 2004
Posts: 485

PostPosted: Wed Dec 12, 2007 2:27 pm    Post subject: Reply with quote

problema dell'aggiornamento di libexpat:

https://forums.gentoo.org/viewtopic-t-575340.html
_________________
"I got off the concept of Progress, it's over-rated"
Arthur Dent
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Dec 12, 2007 2:42 pm    Post subject: Reply with quote

Ok, grazie, in realtà non mi ero accorto che fosse un problema di expat ed avevo dato per scontato che fosse colpa di revdep-rebuild.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Dec 12, 2007 2:45 pm    Post subject: Re: revdep-rebuild impazzito su libkdecore.so.4.2.0 Reply with quote

fbcyborg wrote:
broken /usr/kde/3.5/lib32/libkdecore.so.4.2.0 (requires libexpat.so.0)

sei su amd64?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Dec 12, 2007 2:48 pm    Post subject: Reply with quote

Sì, amd64.
EDIT: mi sono letto tutto l'altro thread sull'aggiornamento di expat ma non trovo che i problemi di cui si parla lì siano proprio simili al mio. Ho visto che si parla di ekiga, di problemi di compilazione (emerge falliti) e di altro, ma non di revdep-rebuild che finiscono in un loop come nel mio caso. Poi per carità, sarà anche colpa di expat.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
table
Apprentice
Apprentice


Joined: 17 Feb 2007
Posts: 279
Location: Gazzaniga (BG) Italy

PostPosted: Wed Dec 12, 2007 3:06 pm    Post subject: Reply with quote

fbcyborg wrote:
Sì, amd64.
EDIT: mi sono letto tutto l'altro thread sull'aggiornamento di expat ma non trovo che i problemi di cui si parla lì siano proprio simili al mio. Ho visto che si parla di ekiga, di problemi di compilazione (emerge falliti) e di altro, ma non di revdep-rebuild che finiscono in un loop come nel mio caso. Poi per carità, sarà anche colpa di expat.


prova con un revdep-rebuild -X
_________________
Pulisci l'html con:
Code:
sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'

skype: matteopinguino
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Dec 12, 2007 3:07 pm    Post subject: Reply with quote

fbcyborg wrote:
Sì, amd64.

tenere kdelibs a 32 bit non è configurazione standard.
bisognerebbe capire perché ce l'hai e se ne vale la pena.

io la disinstallerei dopo un quickpkg per ricompilarla a 64.

quanto a expat, alla fine la cosa da fare dovrebbe essere un revdep con l'opzione -X.
ma nel tuo caso mi aspetto che riproponga lo stesso problema di dipendenze, perché il pacchetto è probabilmente caduto in disuso e forza certe configurazioni legate ad arts che forse non vuoi più avere.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Dec 12, 2007 3:39 pm    Post subject: Reply with quote

table wrote:
fbcyborg wrote:
Sì, amd64.
EDIT: mi sono letto tutto l'altro thread sull'aggiornamento di expat ma non trovo che i problemi di cui si parla lì siano proprio simili al mio. Ho visto che si parla di ekiga, di problemi di compilazione (emerge falliti) e di altro, ma non di revdep-rebuild che finiscono in un loop come nel mio caso. Poi per carità, sarà anche colpa di expat.


prova con un revdep-rebuild -X


Allora ho provato a fare come dici ma l'opzione -X non sembra risolutiva, infatti sebbene revdep-rebuild -X non voglia emergermi nulla e mi dica
Code:
Checking dynamic linking consistency...
  broken /usr/kde/3.5/lib32/libkdecore.so.4.2.0 (requires  libexpat.so.0)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to packages...
  /usr/kde/3.5/lib32/libkdecore.so.4.2.0 -> app-emulation/emul-linux-x86-qtlibs
 done.
  (/root/.revdep-rebuild.4_packages_raw, /root/.revdep-rebuild.4_package_owners)

e
Code:
Dynamic linking on your system is consistent... All done.


Poi quando vado a rifare revdep-rebuild (senza l'opzione -X) risiamo da capo.
Infatti:
Code:
Checking dynamic linking consistency...
  broken /usr/kde/3.5/lib32/libkdecore.so.4.2.0 (requires  libexpat.so.0)
 done.

e
Code:
All prepared. Starting rebuild...
emerge --oneshot -av =app-emulation/emul-linux-x86-qtlibs-10.0


mi era venuto in mente di aggiornare il pacchetto emul-linux-x86-qtlibs ma non mi è stato possibile a causa del fatto che mi chiede la flag arts attivata (ecco perché ho fatto "spam" nell'altro thread - scusate ma il problema è del tutto inerente anche all'altro thread visto che di arts si parla, d'ora in poi comunque cercherò di evitare).

EDIT:
come si può vedere... dopo aver disinstallato soundlibs provo ad aggiornare qtlibs ee... ecco il colpevole!

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] app-emulation/emul-linux-x86-soundlibs-20071125  USE="alsa esd -arts" 4,014 kB
[ebuild     U ] app-emulation/emul-linux-x86-qtlibs-20071210 [10.0] 0 kB

Total: 2 packages (1 upgrade, 1 new), Size of downloads: 4,014 kB


ok, allora provo a fare un bell'emerge -C emul-linux-x86-soundlibs emul-linux-x86-qtlibs && revdep-rebuild e vediamo cosa succede.

dopo qualche minuto...
revdep-rebuild mi vuole emergere di nuovo i seguenti pacchetti:
Code:
All prepared. Starting rebuild...
emerge --oneshot  =app-emulation/emul-linux-x86-sdl-20071121 =app-emulation/emul-linux-x86-medialibs-20071114 =app-emulation/wine-0.9.46

Poiché c'è qualcuno che ne ha bisogno
Code:
Checking dynamic linking consistency...
  broken /usr/lib32/libSDL_mixer-1.2.so.0.2.5 (requires  libmikmod.so.2)
  broken /usr/lib32/libSDL_sound-1.0.so.1.0.0 (requires  libFLAC.so.8 libaudiofile.so.0 libmikmod.so.2 libmodplug.so.0 libogg.so.0 libvorbis.so.0 libvorbisenc.so.2 libvorbisfile.so.3)
  broken /usr/lib32/libtheora.so.0.2.0 (requires  libogg.so.0)
  broken /usr/lib32/wine/winealsa.drv.so (requires  libasound.so.2)
  broken /usr/lib32/wine/wineesd.drv.so (requires  libasound.so.2 libaudiofile.so.0 libesd.so.0)


Finisce il revdep-rebuild e risolve il problema. Non era colpa di expat.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Kind_of_blue
Guru
Guru


Joined: 10 Oct 2004
Posts: 485

PostPosted: Wed Dec 12, 2007 6:07 pm    Post subject: Reply with quote

per vedere le dipendenze inverse
Code:
equery d <pacchetto>

_________________
"I got off the concept of Progress, it's over-rated"
Arthur Dent
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum