Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Configuração do mouse
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Web
n00b
n00b


Joined: 10 Jun 2003
Posts: 26
Location: Blumenau/Santa Catarina/Brasil

PostPosted: Tue Jun 24, 2003 3:33 pm    Post subject: Configuração do mouse Reply with quote

Olá pessoal.


Estou tentando configurar o meu mouse no Gentoo, mas não estou conseguindo.

Uso a mesma configuração do XF86Config do meu Conectiva onde funciona.


Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "off"
Option "Emulate3Timeout" "50"
Option "ZAxisMapping" "4 5"
EndSection


No comando dmesg aparece a seguinte mensagem:

mice: PS/2 mouse device common for all mice

Já tentei várias opções em "Protocol" (PS/2, NetMousePS/2, etc) e também em "Device" (/dev/input/mice, /dev/misc/psaux).

Recompilei o kernel 3 vezes modificando opções e nada.

Tive o mesmo problema com o Slackware 8.x, acredito que selecionei todas as opções de mouse existente e não funcionou.

Estou usando um mouse PS/2 - Genius NetScroll+


Obs: Se eu der boot pelo Conectiva e entrar com chroot no Gentoo ele funciona.

Agradeço qualquer ajuda.
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Tue Jun 24, 2003 3:49 pm    Post subject: Reply with quote

Hum ...
Coisas que eu verificaria:
1. Se o /dev/psaux e /dev/mouse são links para /dev/misc/psaux

Você, talvez queira dar uma olhada nessas threads aqui e aqui.

Boa sorte 8)

Editado: removi uma sugestão que não tinha nada a ver.
_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
Web
n00b
n00b


Joined: 10 Jun 2003
Posts: 26
Location: Blumenau/Santa Catarina/Brasil

PostPosted: Tue Jun 24, 2003 4:04 pm    Post subject: Reply with quote

AngusYoung wrote:
Hum ...
Coisas que eu verificaria:
1. Se o /dev/psaux e /dev/mouse são links para /dev/misc/psaux

Você, talvez queira dar uma olhada nessas threads aqui e aqui.

Boa sorte 8)

Editado: removi uma sugestão que não tinha nada a ver.


Pois é, eu já tinha lido esses tópicos antes. O problema é que o mouse não dá nem sinal. Eu verifiquei o log do XFree e não tinha nenhuma informação de erro ou aviso.

o /dev/mouse e /dev/psaux estão com link para /dev/misc/psaux

Obrigado por enquanto. Alguma outra dica?
Back to top
View user's profile Send private message
humpback
Retired Dev
Retired Dev


Joined: 19 Oct 2002
Posts: 394
Location: Coimbra - Portugal

PostPosted: Tue Jun 24, 2003 4:17 pm    Post subject: Reply with quote

Em consola tenta um cat /dev/psaux e depois move o rato. Caso o kernel esteja bem configurado tens de ver aparecer "lixo".
Caso não apareça é porque nao tens as opções certas no kernel.

A outra parte da questão é que o gentoo usa devfs, por isso se tu tens os devices é porque o kernel esta bem configurado.... Mas prontos tenta....
_________________
Gustavo Felisberto
Humpback @ #gentoo-pt
------------
It's most certainly GNU/Linux, not Linux. Read more at
http://www.gnu.org/gnu/why-gnu-linux.html .
-------------
Back to top
View user's profile Send private message
Web
n00b
n00b


Joined: 10 Jun 2003
Posts: 26
Location: Blumenau/Santa Catarina/Brasil

PostPosted: Tue Jun 24, 2003 4:28 pm    Post subject: Reply with quote

humpback wrote:
Em consola tenta um cat /dev/psaux e depois move o rato. Caso o kernel esteja bem configurado tens de ver aparecer "lixo".
Caso não apareça é porque nao tens as opções certas no kernel.

A outra parte da questão é que o gentoo usa devfs, por isso se tu tens os devices é porque o kernel esta bem configurado.... Mas prontos tenta....


Hoje à noite vou tentar isso lá em casa e se não funcionar eu coloco as opções do "input devices" que usei para compilar o kernel.

Até mais.
Back to top
View user's profile Send private message
PT_LAmb
Guru
Guru


Joined: 22 Apr 2002
Posts: 332
Location: Lisboa (Lisbon), Portugal

PostPosted: Tue Jun 24, 2003 5:02 pm    Post subject: Reply with quote

Vivas,

Se nada funcionar ve o que te diz o log do X (/var/log/XFree86.?.log)...

O meu diz o seguinte:
Code:
...
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
        compiled for 4.2.1, module version = 1.0.0
        Module class: XFree86 XInput Driver
        ABI class: XFree86 XInput driver, version 0.3
...
(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
...
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) 3rd Button detected: disabling emulate3Button


Boa sorte,
Ricardo Cordeiro :)
_________________
SETI@Home - http://setiathome.ssl.berkeley.edu/
Back to top
View user's profile Send private message
Web
n00b
n00b


Joined: 10 Jun 2003
Posts: 26
Location: Blumenau/Santa Catarina/Brasil

PostPosted: Wed Jun 25, 2003 12:59 am    Post subject: Reply with quote

humpback wrote:
Em consola tenta um cat /dev/psaux e depois move o rato. Caso o kernel esteja bem configurado tens de ver aparecer "lixo".
Caso não apareça é porque nao tens as opções certas no kernel.

A outra parte da questão é que o gentoo usa devfs, por isso se tu tens os devices é porque o kernel esta bem configurado.... Mas prontos tenta....


Tentei usar o comando cat /dev/psaux e não aparece nada.


Fiz o mesmo no Conectiva e no Live-CD do Gentoo e em ambos funcionaram.

Recompilei o kernel com o /proc/config do Live-CD apenas alterando o processador
e acrescentando alguns módulos para dispositivos que eu tenho.


-------------Parte final do XFree86.0.log----------------

(==) NV(0): Write-combining range (0xf0000000,0x4000000)
(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
8x8 mono pattern filled rectangles
Indirect CPU to Screen color expansion
Solid Lines
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Keyboard "Keyboard0" handled by legacy driver
(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons"
(**) Option "Emulate3Timeout" "50"
(**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: ps2EnableDataReporting: succeeded

------------------------------------------------------------

O /usr/src/linux/.config tem as seguintes linhas com o nome "mouse"

#
# Input core support
#
CONFIG_INPUT=y
CONFIG_INPUT_KEYBDEV=m
CONFIG_INPUT_MOUSEDEV=m
CONFIG_INPUT_MOUSEDEV_SCREEN_X=1024
CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
CONFIG_INPUT_JOYDEV=m
CONFIG_INPUT_EVDEV=m

#
# Mice
#
CONFIG_BUSMOUSE=m
CONFIG_ATIXL_BUSMOUSE=m
CONFIG_LOGIBUSMOUSE=m
CONFIG_MS_BUSMOUSE=m
CONFIG_MOUSE=m
CONFIG_PSMOUSE=y
CONFIG_82C710_MOUSE=m
CONFIG_PC110_PAD=m
CONFIG_MK712_MOUSE=m

#
# USB support
#
# CONFIG_USB_MOUSE is not set



Diante disso tudo, o problema so pode ser na compilação do kernel, mas qual opção eu devo habilitar/desabilitar para fazer funcionar?
Back to top
View user's profile Send private message
lmpinto
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2003
Posts: 94
Location: somewhere near a computer and a beer.

PostPosted: Sun Jun 29, 2003 4:06 pm    Post subject: Reply with quote

Tens o módulo mousedev carregado? Não tenho a certeza se isso é ps2 ou usb, mas acho que é indiferente...
Back to top
View user's profile Send private message
Web
n00b
n00b


Joined: 10 Jun 2003
Posts: 26
Location: Blumenau/Santa Catarina/Brasil

PostPosted: Mon Jun 30, 2003 4:10 pm    Post subject: Reply with quote

lmpinto wrote:
Tens o módulo mousedev carregado? Não tenho a certeza se isso é ps2 ou usb, mas acho que é indiferente...


Carreguei quando eu compilei como módulo. Já tentei incluir no kernel e como módulo e nenhum deles funcionou.

Sei lá o que tá acontecendo.

Obrigado mesmo assim.
Back to top
View user's profile Send private message
Web
n00b
n00b


Joined: 10 Jun 2003
Posts: 26
Location: Blumenau/Santa Catarina/Brasil

PostPosted: Tue Jul 01, 2003 4:11 pm    Post subject: Reply with quote

Finalmente consegui.

Depois de compilar o kernel diversas vezes, descobri o módulo que preciso carregar para fazer o meu mouse PS/2 funcionar. É o usb-ohci.

Mas afinal, o que tem a ver esse módulo com PS/2? Alguém teria alguma informação sobre isso?
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Tue Jul 01, 2003 10:46 pm    Post subject: USB Reply with quote

isso eh estranho pois se o rato é ps/2 n pode ser usb :D vé se n é qq coisa no "character devices"

:wink:
_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
Web
n00b
n00b


Joined: 10 Jun 2003
Posts: 26
Location: Blumenau/Santa Catarina/Brasil

PostPosted: Fri Jul 04, 2003 4:13 pm    Post subject: Re: USB Reply with quote

MetalGOD wrote:
isso eh estranho pois se o rato é ps/2 n pode ser usb :D vé se n é qq coisa no "character devices"

:wink:


Essas são seções "input core support" e "character devices" do arquivo .config

Meu mouse é um Genius Netscroll+ PS/2.

#
# Input core support
#
CONFIG_INPUT=m
CONFIG_INPUT_KEYBDEV=m
CONFIG_INPUT_MOUSEDEV=m
CONFIG_INPUT_MOUSEDEV_SCREEN_X=1024
CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
CONFIG_INPUT_JOYDEV=m
CONFIG_INPUT_EVDEV=m

#
# Character devices
#
CONFIG_VT=y
# CONFIG_ECC is not set
CONFIG_VT_CONSOLE=y
CONFIG_SERIAL=m
# CONFIG_SERIAL_EXTENDED is not set
CONFIG_SERIAL_NONSTANDARD=y
CONFIG_COMPUTONE=m
CONFIG_ROCKETPORT=m
CONFIG_CYCLADES=m
CONFIG_CYZ_INTR=y
CONFIG_DIGIEPCA=m
# CONFIG_ESPSERIAL is not set
CONFIG_MOXA_INTELLIO=m
CONFIG_MOXA_SMARTIO=m
CONFIG_ISI=m
CONFIG_SYNCLINK=m
CONFIG_SYNCLINKMP=m
CONFIG_N_HDLC=m
CONFIG_RISCOM8=m
CONFIG_SPECIALIX=m
CONFIG_SPECIALIX_RTSCTS=y
CONFIG_SX=m
CONFIG_RIO=m
# CONFIG_RIO_OLDPCI is not set
# CONFIG_STALDRV is not set
CONFIG_UNIX98_PTYS=y
CONFIG_UNIX98_PTY_COUNT=256
CONFIG_PRINTER=m
# CONFIG_LP_CONSOLE is not set
# CONFIG_PPDEV is not set
Back to top
View user's profile Send private message
metralha761
n00b
n00b


Joined: 03 Jan 2005
Posts: 10
Location: Patopolis

PostPosted: Sat Feb 05, 2005 9:15 pm    Post subject: Reply with quote

Isto é uma suposta teoria, após algum tempo na andança da informatica.

As portas USB e PS/2 devem ser similares. Se repararem os ratos PS/2 podem ser ligado á porta USB sem algum problema, bastando usar o conversor.

Pode ser dai alguma ligação que tenha.

Já agora, este topico ja tem uma boa camada de pó, mas tive o mesmo problema, o rato nao funcava na porta PS/2, após uma pesquisa com alguma paciencia, fui deparar com este topico mt util :D

Obrigado.
_________________
Tou a iniciar :D ajuda sao sempre bem vindas
Back to top
View user's profile Send private message
Web
n00b
n00b


Joined: 10 Jun 2003
Posts: 26
Location: Blumenau/Santa Catarina/Brasil

PostPosted: Sun Feb 06, 2005 12:17 pm    Post subject: Reply with quote

metralha761 wrote:
Isto é uma suposta teoria, após algum tempo na andança da informatica.

As portas USB e PS/2 devem ser similares. Se repararem os ratos PS/2 podem ser ligado á porta USB sem algum problema, bastando usar o conversor.

Pode ser dai alguma ligação que tenha.

Já agora, este topico ja tem uma boa camada de pó, mas tive o mesmo problema, o rato nao funcava na porta PS/2, após uma pesquisa com alguma paciencia, fui deparar com este topico mt util :D

Obrigado.


Eu nem lembrava que esse tópico ainda existia ... :D

Mas para deixá-lo um pouco mais completo, vou colocar mais algumas informações que descobri posteriormente.

Tive o mesmo problema quando atualizei o kernel para o 2.6, e, pesquisando novamente na net, descobri o real motivo do mouse não funcionar. Era porque eu tinha habilitado no Setup a opção:

-- USB Legacy support

Foi só desabilitar esta opção que tudo funcionou perfeitamente, inclusive sem o carregamento do módulo USB no kernel 2.4

Até mais.
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Wed Feb 09, 2005 1:08 am    Post subject: Reply with quote

Btw o /dev/psaux é um dispositivo de legado, que tem os dias contados. É bom nos acostumarmos a desabilitá-lo e apontar /dev/mouse sempre para /dev/input/mouse0.
_________________
RTFM!
Back to top
View user's profile Send private message
Matheus Villela
Apprentice
Apprentice


Joined: 25 Oct 2003
Posts: 263

PostPosted: Wed Feb 09, 2005 1:17 am    Post subject: Reply with quote

Olá, vou aproveitar o tópico pra perguntar algo que estive procurando ontem.

Eu me lembro de ter visto isso no KDE e acho que até no GNOME mas omo não uso mais nenhum dos dois queria perguntar: como faço pra "setar" velocidade e aceleração do mouse?

Segundo a man page do xorg.conf não tem nenhuma "option" pra isso, somente essas: CorePointer, CoreKeyboard, AlwaysCore, SendCoreEvents, HistorySize e SendDragEvents. Será que existe alguma opção pra determinar isso mas que não está na man page? Ou só teria como fazer usando um daemon da vida de um ambiente gráfico?

Se alguém tiver conhecimento sobre isso, souber de algum documento explicando, qualquer coisa concreta tá valendo ;)
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Wed Feb 09, 2005 3:42 am    Post subject: Reply with quote

Tente ajustar a resolução. Se não me engano, Option "Resolution" 600, por exemplo.
_________________
RTFM!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum