Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas acentuação OpenOffice <RESOLVIDO>
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
mfdzerohour
Tux's lil' helper
Tux's lil' helper


Joined: 31 Aug 2005
Posts: 122
Location: Campo Grande-MS

PostPosted: Sat Dec 08, 2007 8:51 pm    Post subject: Problemas acentuação OpenOffice <RESOLVIDO> Reply with quote

Boa Tarde,

Já fiz tudo que achei pelo no forum do gentoo e outras distribuições para conseguir fazer os acentos funcionarem, mas não funciona, só no OpenOffice.
Vi que em alguns casos o ' Ç ' não funcionava, mas no meu caso funciona, mas os acentos É Â Â, etc... não! Já mechi nos locales, no make.conf e mesmo assim não funciona, acredito que o problema pode estar no meu make.conf e no gtk, apesar qu outras aplicações que usem o GTK funciona, usei como teste o aMSN e o aMule, e todos os acentos funcionam.

MAKE.CONF

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /etc/make.conf.example for a more detailed example.
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"
# This should not be changed unless you know exactly what you are doing. You
# should probably be using a different stage, instead.
CHOST="i686-pc-linux-gnu"
MAKEOPTS="-j2"

#Mirrors do Gentoo
GENTOO_MIRRORS="ftp://mirrors.tera-byte.com/pub/gentoo "

#Aplicativos devem ser compilados com suporte a esses protocolos
USE="ogg alsa cdr dri dvb dvd dvdr gif gpm -gnome gtk java jpeg kde mp3 mpeg ncurses nsplugin png samba vcd vim-syntax X win32codecs symlink cairo bash-completion vram sdl opengl mmx mmx2 sse sse2 a52"


#Traducao dos aplicativos do Gentoo
LANG="pt_BR"
LINGUAS="pt_BR"
LANGUAGE="pt_BR"
MM_CHARSET="pt_BR"
LANG_ALL="pt_BR"#LANG=pt_BR.ISO8859-1
#LC_ALL=pt_BR.ISO8859-1
#LANGUAGE=pt_BR.ISO8859-1
#LOCALE=pt_BR.ISO8859-1
#MM_CHARSET=pt_BR.ISO8859-1
#export LANG LC_ALL LANGUAGE LOCALE MM_CHARSET

#Compialando oà kernel com suporte a minha placa de video
VIDEO_CARDS="i810"


Last edited by mfdzerohour on Sun Jan 13, 2008 7:35 am; edited 1 time in total
Back to top
View user's profile Send private message
melloferraz
n00b
n00b


Joined: 22 Aug 2006
Posts: 11

PostPosted: Thu Dec 13, 2007 11:39 pm    Post subject: Reply with quote

Ja' tentou deixar simples assim:

No MAKE.CONF:

LINGUAS="pt_BR"

e em /etc/env.d/02locale:

LANG="pt_BR.UTF-8"
LC_ALL="pt_BR.UTF-8"

Comigo sempre funcionou perfeitamente assim....
Back to top
View user's profile Send private message
mfdzerohour
Tux's lil' helper
Tux's lil' helper


Joined: 31 Aug 2005
Posts: 122
Location: Campo Grande-MS

PostPosted: Sun Jan 13, 2008 7:35 am    Post subject: Reply with quote

a sua ideía estava certa porém no arquivo errado, o certo seria em acrescente (ou substitua) as seguintes linhas no arquivo /etc/profile:

export LC_ALL=pt_BR
export LANG=pt_BR

Agora basta fazer logout e login novamente para que as alterações surtam efeito e os benditos acentos estejam funcionando no OpenOffice.

Pronto! Agora é desfrutar dessa excelente suíte para escritório.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum