Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] problema automount chiavetta USB
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Sat Dec 08, 2007 10:46 am    Post subject: [Risolto] problema automount chiavetta USB Reply with quote

Fino a qualche giorno fa tutto funzionava alla perfezione, il problema è nato quando ho provato ad installare il livecd di gentoo sulla chiavetta USB ... e più precisamente è iniziato quando ho cercato di rendere avviabile la chiavetta scrivendo il MBR .... non ho ancora capito da cosa possa dipendere, ma ora quando inserisco la chiavetta in un qualsiasi slot, non viene più montata in automatico ... ho provato anche a formattarla ma niente :(

Non ho aggiornato nienete quindi non ho sovrascritto nessun file di configurazione .... hald e dbus sono nel runlevel di default .... ho provato a riemergere sia hal che dbus .... la chiavetta viene riconosciuta all'inserimento .... e gli viene assegnato (come prima del fattaccio) il /dev/sdc .... il problema non esiste se inserisco un cd nel lettore, quiesto viene tranquillamenmte montato in /media

se può servire, questo è l'output di lsusb ... Logitech è il mouse e PQI è la chiavetta

Code:
dj lele # lsusb
Bus 005 Device 001: ID 0000:0000 
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 001: ID 0000:0000 
Bus 002 Device 002: ID 046d:c024 Logitech, Inc.
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 003: ID 3538:0050 Power Quotient International Co., Ltd
Bus 001 Device 001: ID 0000:0000


e questo è l'output di fdisk ... la chiavetta come ho già detto è /dev/sdc

Code:
dj lele # fdisk -l

Disk /dev/hdb: 122.9 GB, 122942324736 bytes
255 heads, 63 sectors/track, 14946 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1       10199    81923436    b  W95 FAT32
/dev/hdb2           10200       14946    38130277+   b  W95 FAT32

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1               1         153     1228941   83  Linux
/dev/sda2             154         408     2048287+  82  Linux swap / Solaris
/dev/sda3             409        4232    30716280   83  Linux
/dev/sda4            4233        9729    44154652+  83  Linux

Disk /dev/sdb: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sdb1               1         131     1052226   83  Linux
/dev/sdb2             132         262     1052257+  82  Linux swap / Solaris
/dev/sdb3             263        5361    40957717+  83  Linux
/dev/sdb4            5362        9964    36973597+  83  Linux

Disk /dev/sdc: 1043 MB, 1043595264 bytes
255 heads, 63 sectors/track, 126 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sdc1               1         126     1012063+   6  FAT16


Cosa posso fare? :?


Last edited by lele_dj on Sun Dec 09, 2007 11:30 am; edited 1 time in total
Back to top
View user's profile Send private message
danielinux
Apprentice
Apprentice


Joined: 10 Nov 2004
Posts: 202

PostPosted: Sat Dec 08, 2007 1:04 pm    Post subject: Reply with quote

Ma riesci a montare manualmente la partizione sdc1?
_________________
I've seen things you people wouldn't believe.
Attack ships on fire off the shoulder of Orion.
I watched C-beams glitter in the dark near the Tannhauser gate.
All those moments will be lost in time, like tears in rain.
Time to die.
Back to top
View user's profile Send private message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Sat Dec 08, 2007 1:14 pm    Post subject: Reply with quote

danielinux wrote:
Ma riesci a montare manualmente la partizione sdc1?


Si ... montandola a mano da terminale nessun problema ... se non che per poi scriverci ho bisogno dei permessi di root

Ho provato anche a loggarmi in gnome come root e inserendo la penna non viene montata comunque in automatico
Back to top
View user's profile Send private message
danielinux
Apprentice
Apprentice


Joined: 10 Nov 2004
Posts: 202

PostPosted: Sat Dec 08, 2007 1:23 pm    Post subject: Reply with quote

Hai provato con altre chiavette usb per vedere se te le monta in auto?
_________________
I've seen things you people wouldn't believe.
Attack ships on fire off the shoulder of Orion.
I watched C-beams glitter in the dark near the Tannhauser gate.
All those moments will be lost in time, like tears in rain.
Time to die.
Back to top
View user's profile Send private message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Sat Dec 08, 2007 1:26 pm    Post subject: Reply with quote

danielinux wrote:
Hai provato con altre chiavette usb per vedere se te le monta in auto?

Purtroppo non ne ho altre ... mi era anche venuto in mente di provarci .....
Back to top
View user's profile Send private message
danielinux
Apprentice
Apprentice


Joined: 10 Nov 2004
Posts: 202

PostPosted: Sat Dec 08, 2007 1:30 pm    Post subject: Reply with quote

Domanda stupida ... hai creato il file system?
_________________
I've seen things you people wouldn't believe.
Attack ships on fire off the shoulder of Orion.
I watched C-beams glitter in the dark near the Tannhauser gate.
All those moments will be lost in time, like tears in rain.
Time to die.
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sat Dec 08, 2007 1:39 pm    Post subject: Reply with quote

danielinux wrote:
Domanda stupida ... hai creato il file system?

Se la riesce a montare a mano direi proprio di si ...
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Sun Dec 09, 2007 10:46 am    Post subject: Reply with quote

Il filesystem è OK ... qualcuno ha altre idee su cosa possa essere successo? :?
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sun Dec 09, 2007 11:05 am    Post subject: Reply with quote

lele_dj wrote:
Il filesystem è OK ... qualcuno ha altre idee su cosa possa essere successo? :?

Visto che l'unica cosa che hai modificato è stato l'MBR forse il problema è da ricercare li.
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Sun Dec 09, 2007 11:30 am    Post subject: Reply with quote

Risolto ...

In pratica il responsabile era gparted .... lo avevo usato per partizionare la chiavetta e a quanto ho capito a lui non piace l'automount perchè interferisce con il suo funzionamento ... quindi lo disbilita 8O ...
... Googleando ho scoperto che basta rimuopvere il file
Code:
/usr/share/hal/fdi/policy/gparted-disable-automount.fdi

poi riavviare hald
Code:
/etc/init.d/hald restart

e tutto torna a funzionare :D

grazie a tutti per l'aiuto
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Sun Dec 09, 2007 3:50 pm    Post subject: Reply with quote

sei la manna dal cielo... avevo lo stesso problema !!!
_________________
C.
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Fri Feb 01, 2008 3:24 pm    Post subject: Reply with quote

mitico... anche io ho avuto lo stesso problema, ed ho appena risolto! :D

tnx
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum