Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge gcc-3.3.6-r1 sucks
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
nelsooon
n00b
n00b


Joined: 08 Aug 2004
Posts: 58

PostPosted: Sat Dec 08, 2007 8:08 am    Post subject: emerge gcc-3.3.6-r1 sucks Reply with quote

Hi all,
I'd emerge ati-drivers. It depends on GCC-3.3.6-r1.
So when compiling gcc-3.3.6-r1, it sucks, here are the "latest error lines":
Quote:

make CC=" stage1/xgcc -Bstage1/ -B/usr/i686-pc-linux-gnu/bin/" \
STAGE_PREFIX=stage1/ \
ADAC="\$(CC)" AR_FOR_TARGET="ar" RANLIB_FOR_TARGET="ranlib" CFLAGS="-O2 -march=pentium-m -pipe" LDFLAGS="" WARN_CFLAGS="\$(GCC_WARN_CFLAGS)" STRICT_WARN="-Wtraditional -pedantic -Wno-long-long" libdir=/usr/lib LANGUAGES="c gcov c++ f77 treelang proto" MAKEOVERRIDES= OUTPUT_OPTION="-o \$@"
make[2]: Entering directory `/home/tmp/portage/sys-devel/gcc-3.3.6-r1/work/build/gcc'
stage1/xgcc -Bstage1/ -B/usr/i686-pc-linux-gnu/bin/ -c -O2 -march=pentium-m -pipe -DIN_GCC -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long -DHAVE_CONFIG_H -DGENERATOR_FILE -I. -I. -I/home/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc -I/home/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc/. -I/home/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc/config -I/home/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc/../include /home/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc/gengenrtl.c -o gengenrtl.o
cc1: error: bad value (pentium-m) for -march= switch
cc1: error: bad value (pentium-m) for -mcpu= switch
make[2]: *** [gengenrtl.o] Error 1
make[2]: Leaving directory `/home/tmp/portage/sys-devel/gcc-3.3.6-r1/work/build/gcc'
make[1]: *** [stage2_build] Error 2
make[1]: Leaving directory `/home/tmp/portage/sys-devel/gcc-3.3.6-r1/work/build/gcc'
make: *** [bootstrap-lean] Error 2
*
* ERROR: sys-devel/gcc-3.3.6-r1 failed.
* Call stack:
* ebuild.sh, line 1701: Called dyn_compile
* ebuild.sh, line 1039: Called qa_call 'src_compile'
* ebuild.sh, line 44: Called src_compile
* ebuild.sh, line 1383: Called toolchain_src_compile
* toolchain.eclass, line 26: Called gcc_src_compile
* toolchain.eclass, line 1548: Called gcc_do_make
* toolchain.eclass, line 1422: Called die
* The specific snippet of code:
* emake \
* LDFLAGS="${LDFLAGS}" \
* STAGE1_CFLAGS="${STAGE1_CFLAGS}" \
* LIBPATH="${LIBPATH}" \
* BOOT_CFLAGS="${BOOT_CFLAGS}" \
* ${GCC_MAKE_TARGET} \
* || die "emake failed with ${GCC_MAKE_TARGET}"
* The die message:
* emake failed with bootstrap-lean
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/home/tmp/portage/sys-devel/gcc-3.3.6-r1/temp/build.log'.
*
/home/tmp/portage/sys-devel/gcc-3.3.6-r1/temp/build.log lines 3542-3579/3579 (END)


Some help ?
I don't want to use gcc-3.3.6-r1, can I compile with no problem ati-drivers with the gcc-4.1.2 ?
thanks
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sat Dec 08, 2007 8:43 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See https://forums.gentoo.org/viewtopic-t-577369.html
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum