Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2 problems: sound and permission denied to be root!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
guest
Guest





PostPosted: Sat Apr 20, 2002 11:54 pm    Post subject: 2 problems: sound and permission denied to be root! Reply with quote

1. I installed Gentoo with KDE. When I'm root sound is working, but not as normal user. When I log as user a window appears saying error while initialisaion sound driver. Device /dev/dsp can't be opened....

So, I tried chmod 644 /dev/dsp but did not help.

2. I have another problem. When I'm a normal user and I open up a terminal to be "root", it failed. I get this message:

su
password: ******

su: Permission denied
Sorry.


Thanks for your help.
Back to top
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Sun Apr 21, 2002 12:12 am    Post subject: Reply with quote

1. add your user account to the "audio" group

2. add your user account to the "wheel" group
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
Guest






PostPosted: Sun Apr 21, 2002 5:49 am    Post subject: Reply with quote

Just wanted to say I was having the same problem too, but this fixed it. Thanks.
Back to top
febisfebi
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2002
Posts: 76
Location: seattle wa

PostPosted: Sun Apr 21, 2002 9:31 am    Post subject: Reply with quote

i had the same problem, and i fixed it by chmod 666 /dev/dsp
i dont think this is the best way to do it, what permissions should it be set to?
Back to top
View user's profile Send private message
Princess Firefly
Guest





PostPosted: Sun Apr 21, 2002 10:10 am    Post subject: stupid devfs Reply with quote

I've been killing myself over devfs for a few days and I finally got my sound working a few hours ago.

Everytime you boot devfs overwrites the /dev directory so any permissions you set are going to be overwritten.

In the installation guide it said to have the following in your /etc/devfsd.conf file (under the ALSA section):

REGISTER sound/.* PERMISSIONS root.audio 660
REGISTER snd/.* PERMISSIONS root.audio 660


I guess this is suppossed to make it so people belonging to the "audio" group can use the sound stuff. Great idea, but it didn't work for me at all. dsp and mixer and all the sound devices were NOT 660 after boot. I almost uninstalled gentoo after about 10 hours of trying to figure this out and move to something not so dependent on devfs but I couldn't give up the speedups of gentoo :wink:

Here's what I did that finally got it to work, someone out there will probably say I'm doing something "un-devfs" like but I don't care, it works. I commented out the two lines above in my /etc/devfsd.conf file. so the ALSA section now looks like this:

..

# ALSA/OSS stuff
# Comment/change these if you want to change the permissions on
# the audio devices
LOOKUP snd MODLOAD ACTION snd
LOOKUP dsp MODLOAD
LOOKUP mixer MODLOAD
LOOKUP midi MODLOAD
#REGISTER sound/.* PERMISSIONS root.audio 660
#REGISTER snd/.* PERMISSIONS root.audio 660

...

*shrug* it finally works. I don't know why exactly but I'm glad that it does. Also, make sure if you're using gnome that you get esd working (emerge esound) and that you have ALSA working (sound compiled ONLY as modules in the kernel, emerge alsa-utils, setup conf files as described in desktop configuration guide).

Hope this helps some poor soul out there struggling with fricken devfs.

The Princess
Back to top
ProGuy
n00b
n00b


Joined: 14 Apr 2002
Posts: 17
Location: Denmark

PostPosted: Sun Apr 21, 2002 11:40 pm    Post subject: Reply with quote

I have the exact same problem with devfs not setting permissions as it should. I mainly have this problem for /dev/nvidia* and /dev/sound/*.

I'll have to try to remove those permissions line from my /etc/devfsd.conf, but I am really wondering why this is necesarry.

Is this a bug in the devfs daemon (it surely needs to be fixed then)?
Has anyone looked into this? (I can't seem to find any information about this anywhere).
_________________
//ProGuy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum