Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[resolu][emerge] Probleme avec gcc-3.3.6-r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
rhaamo
n00b
n00b


Joined: 20 Sep 2007
Posts: 17

PostPosted: Tue Dec 04, 2007 5:46 am    Post subject: [resolu][emerge] Probleme avec gcc-3.3.6-r1 Reply with quote

Bonjour a tous.

J'avais deja tenter l'aventure gentoo sur un autre de mes pc mais j'avais vite arreter. Mais la je reprend cette fois sur mon pc perso et je bute encore sur une erreur.

J'ai donc installer une gentoo normalement, donc pour le moment il n'y a pas X ni de WM, et j'essaye de mettre mon systeme en UTF-8 donc j'ai suivit: http://www.gentoo.org/doc/fr/utf-8.xml et j'en suis donc au code n°3.6
Code:
emerge --update --deep --newuse world


J'ai donc rajouter dans mon USE unicode.

et lancer l'emerge. Mais il veut installer gcc-3.3.6-r1 alors que j'ai la 4.1.2 d'installer :?

Donc deja il y a eu conflict avec mon CFLAGS="-march=pentium4m -O2 -pipe" que j'ai du remetre en CFLAGS="-march=i686 -O2 -pipe" et maintenant sa se termine pour gcc en

Code:
stage1/xgcc -Bstage1/ -B/usr/i686-pc-linux-gnu/bin/    -O2 -march=i686 -pipe -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long   -DHAVE_CONFIG_H  -o f771 f/bad.o f/bit.o f/bld.o f/com.o f/data.o f/equiv.o f/expr.o f/global.o f/implic.o f/info.o f/intrin.o f/lab.o f/lex.o f/malloc.o f/name.o f/parse.o f/src.o f/st.o f/sta.o f/stb.o f/stc.o f/std.o f/ste.o f/storag.o f/stp.o f/str.o f/sts.o f/stt.o f/stu.o f/stv.o f/stw.o f/symbol.o f/target.o f/top.o f/type.o f/where.o main.o libbackend.a   ../libiberty/libiberty.a
bison  -v /var/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc/treelang/parse.y\
        --output=/var/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc/treelang/parse.c --defines
bison: ne peut ouvrir le fichier « /var/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc/treelang/parse.y--output=/var/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc/treelang/parse.c »: Aucun fichier ou répertoire de ce type
make[2]: *** [/var/tmp/portage/sys-devel/gcc-3.3.6-r1/work/gcc-3.3.6/gcc/treelang/parse.h] Erreur 1
make[2]: quittant le répertoire « /var/tmp/portage/sys-devel/gcc-3.3.6-r1/work/build/gcc »
make[1]: *** [stage2_build] Erreur 2
make[1]: quittant le répertoire « /var/tmp/portage/sys-devel/gcc-3.3.6-r1/work/build/gcc »
make: *** [bootstrap-lean] Erreur 2
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m ERROR: sys-devel/gcc-3.3.6-r1 failed.
:(

Y-a t'il moyen d'empecher l'installation de ce gcc la afin de garder mon optimisation P4m ?

Voici mon make.conf si sa peut aider:
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /etc/make.conf.example for a more detailed example.
CFLAGS="-O2 -march=i686 -pipe"
#CFLAGS="-march=pentium4m -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# This should not be changed unless you know exactly what you are doing.  You
# should probably be using a different stage, instead.
CHOST="i686-pc-linux-gnu"

GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "

SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"

USE="aac aalib apache2 audiofile bash-completion bluetooth bzip2 cdb cddb cdparanoia curl exif ffmpeg flac foomatic ftp glut -gnome gps gtk2 ieee1394 imagemagick imap jack java javascript joystick jpeg2k -kde ladspa libcaca libwww lm_sensors mime mmx mplayer pcmcia php slang smartcard sse sse2 theora usb v4l wifi wmf xcomposite xinerama cdr dvd qt3 qt4 unicode"


Merci d'avance :)

Ps: je ne reponderais pas avant ce soir, je part d'ici quelques instants au bahut :P
EDIT: up & i'm ready pour repondre :)


Last edited by rhaamo on Tue Dec 04, 2007 7:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
rhaamo
n00b
n00b


Joined: 20 Sep 2007
Posts: 17

PostPosted: Tue Dec 04, 2007 7:13 pm    Post subject: Reply with quote

Resolut sur irc :)

J'ai installer sys-libs/libstdc++-v3 puis relancer l'emerge et c'est passer nickel pour GCC3.x...
Back to top
View user's profile Send private message
bouleetbil
Guru
Guru


Joined: 06 Jul 2004
Posts: 456
Location: Montpellier

PostPosted: Tue Dec 04, 2007 8:31 pm    Post subject: Reply with quote

Salut,
Pour info, pour ceux qui ont besoin gcc3 (qemu) il y a un bug ouvert sur ce sujet

https://bugs.gentoo.org/show_bug.cgi?id=183766
Il faut utiliser l'overlay en attendant :
Code:
  layman -f -o http://tapir.sajinet.com.pe/gentoo/layman.xml -a sajinet
  emerge -DNv =sys-devel/gcc-3.3.6-r2

_________________
L'homme n'est pas fait pour travailler ça le fatigue.
LiveCD Gentoo : http://www.frogdev.info
Gentoo/Freebsd : http://www.frogdev.info/gentoo_freebsd.php
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum