Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
portage 2.0.7 broken (again)?
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Thu Jun 27, 2002 12:19 pm    Post subject: portage 2.0.7 broken (again)? Reply with quote

There seem to be more portage errors in the last weeks ... I got a new one:
Code:
FOGELNEST root # emerge -pu world

These are the packages that I would merge, in order.

Calculating world dependencies /Traceback (most recent call last):
  File "/usr/bin/emerge", line 1224, in ?
    if not mydepgraph.syscreate(getworldlist()):
  File "/usr/bin/emerge", line 510, in syscreate
    if not self.create(self.match(myline,mykey="update (likely old /var/db/pkg entry)")):
  File "/usr/bin/emerge", line 463, in create
    if not self.create(mynew,mybigkey):
  File "/usr/bin/emerge", line 463, in create
    if not self.create(mynew,mybigkey):
  File "/usr/bin/emerge", line 407, in create
    edepend=portage.db[myroot]["porttree"].dbapi.aux_get(mykey,portage.auxdbkeys)
  File "/usr/lib/python2.2/site-packages/portage.py", line 2563, in aux_get
    self.auxcache[mycpv][auxdbkeys[x]]=mylines[x][:-1]
IndexError: list index out of range

I wanted to upgrade to gnome2, upgraded portage from 2.0.5 first, then I got stuck at the above error. I do not get this error when emerge -pu gnome-core or any other package, but it also breaks the same way when trying emerge -pu system. (emerge rsync is up2date)

.. Any help welcome!

* ElCondor pasa *
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
phantasm
n00b
n00b


Joined: 21 Jun 2002
Posts: 71
Location: Cincinnati

PostPosted: Thu Jun 27, 2002 12:27 pm    Post subject: Reply with quote

See https://forums.gentoo.org/viewtopic.php?t=6002 here this is the way to fix it.
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Thu Jun 27, 2002 12:43 pm    Post subject: Reply with quote

I gave
Code:
emerge /usr/portage/sys-apps/portage/portage-2.0.5.ebuild
a try and now it works, though 2.0.7 is still installed .. I don't think this is "clean", but for the moment. ..
looking forward to a working portage

* ElCondor pasa *
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
phantasm
n00b
n00b


Joined: 21 Jun 2002
Posts: 71
Location: Cincinnati

PostPosted: Thu Jun 27, 2002 12:55 pm    Post subject: Reply with quote

You will have to emerge unmerge portage 2.0.7. It seems that emerge does not "clean" up or remove a package when it installs a new package. Some one could correct me if I am wrong, but it would be nice if emerge would remove all the packages that we just updated.
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Thu Jun 27, 2002 1:08 pm    Post subject: Reply with quote

Yup, found it out in the meantime. what did make everything work again :
Code:
emerge /usr/portage/sys-apps/portage/portage-2.0.4.ebuild
emerge -c portage

the last installed portage seems to be protected by default, so this works. with 2.0.5 ORBit didn't compile, now I hope that portaging around is done for the moment. (Currently emerge -bu world is doing fine at the 12th package)

* ElCondor pasa *
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
phantasm
n00b
n00b


Joined: 21 Jun 2002
Posts: 71
Location: Cincinnati

PostPosted: Thu Jun 27, 2002 1:43 pm    Post subject: Reply with quote

I am just glad for the most part it is an easy fix nothing like having your installation application broken
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Thu Jun 27, 2002 2:01 pm    Post subject: Reply with quote

Folks -- let's keep on thread for the recent portage-related problems.

Locking this thread in favor of this one

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum