Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with emerging XFE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Matti Kuokkanen
n00b
n00b


Joined: 03 Dec 2007
Posts: 14

PostPosted: Mon Dec 03, 2007 12:45 pm    Post subject: Problem with emerging XFE Reply with quote

While emerging XFE with command emerge -av xfe, at the end of it I get following:
Code:
main.o: In function `FX::FXDCWindow::drawText(int, int, char const*, unsigned int)':
main.cc:(.text+0xf83): undefined reference to `XftDrawStringUtf8'
main.cc:(.text+0xfbe): undefined reference to `XftDrawString8'
main.o: In function `FX::FXFont::getTextWidth(char const*, unsigned int) const':
main.cc:(.text+0x104b): undefined reference to `XftTextExtentsUtf8'
main.cc:(.text+0x1085): undefined reference to `XftTextExtents8'
collect2: ld returned 1 exit status
make[2]: *** [xfe] Virhe 1
make[2]: Poistutaan hakemistosta "/var/tmp/portage/x11-misc/xfe-1.00/work/xfe-1.00/src"
make[1]: *** [all-recursive] Virhe 1
make[1]: Poistutaan hakemistosta "/var/tmp/portage/x11-misc/xfe-1.00/work/xfe-1.00"
make: *** [all] Virhe 2
 *
 * ERROR: x11-misc/xfe-1.00 failed.
 * Call stack:
 *         ebuild.sh, line 1701:  Called dyn_compile
 *         ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *         ebuild.sh, line   44:  Called src_compile
 *   xfe-1.00.ebuild, line   21:  Called die
 * The specific snippet of code:
 *      emake || die "emake failed."
 *  The die message:
 *   emake failed.

What's the matter and how do I get it fixed?

System info:
CPU: K6-2, 400 MHz
RAM: 384 MB
X server: X.org
WM: IceWM

make.conf
Code:
CFLAGS="-O2 -mtune=k6-2 -pipe"
CXXFLAGS="${CFLAGS}"
# This should not be changed unless you know exactly what you are doing.  You
# should probably be using a different stage, instead.
CHOST="i486-pc-linux-gnu"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ ftp://trumpetti.atm.tut.fi/gentoo/ http://ftp.public.fix.fi/gentoo/ ftp://ftp.public.fix.fi/gentoo "
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow usb slang X"
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Mon Dec 03, 2007 2:40 pm    Post subject: Reply with quote

emerge --info plz.
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
Matti Kuokkanen
n00b
n00b


Joined: 03 Dec 2007
Posts: 14

PostPosted: Tue Dec 04, 2007 11:59 am    Post subject: Reply with quote

Problem solved. I got help from IRC. But for those who have same problem, here is what I did:
emerge -av gentoolkit
revdep-rebuild
emerge --sync
emerge -uDvN wolrd
emerge -av xft
emerge -av libXft

In addition USE-flag truetype is required in make.conf and also png flag recommended (to say the least ;)). When all is done, then once again:
emerge -av xfe
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Tue Dec 04, 2007 12:32 pm    Post subject: Reply with quote

nice :)
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum