Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] compilazione qt 4.3.2 fallita
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Gr3yFox
Apprentice
Apprentice


Joined: 11 May 2006
Posts: 218
Location: Genoa, Italy

PostPosted: Fri Nov 30, 2007 1:47 pm    Post subject: [risolto] compilazione qt 4.3.2 fallita Reply with quote

Ciao a tutti,
aggiornando il pacchetto delle qt ho avuto un errore da portage:

Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status[/b]
make[1]: *** [../../lib/libQtOpenGL.so.4.3.2] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/qt-4.3.2/work/qt-x11-opensource-src-4.3.2/src/opengl'
make: *** [sub-opengl-all-ordered] Error 2
 *
 * ERROR: x11-libs/qt-4.3.2 failed.
 * Call stack:
 *         ebuild.sh, line 1701:  Called dyn_compile
 *         ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *         ebuild.sh, line   44:  Called src_compile
 *   qt-4.3.2.ebuild, line  229:  Called die
 * The specific snippet of code:
 *      emake all || die
 *  The die message:
 *   (no error message)
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-libs/qt-4.3.2/temp/build.log'.
 *


Non ho idea di cosa sia quel link a GL che gli manca, come faccio a rimediare?
Grazie :)
_________________
GreyFox (Linux registered user #435102)
greyfox.imente.org - GreyFox's shots (photoblog)


Last edited by Gr3yFox on Fri Nov 30, 2007 2:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Fri Nov 30, 2007 1:58 pm    Post subject: Reply with quote

probabilmente devi ricompilare le qt con USE opengl.
Per sicurezza fai una ricerca sul forum per qt, ci sono diverse discussioni!
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
Gr3yFox
Apprentice
Apprentice


Joined: 11 May 2006
Posts: 218
Location: Genoa, Italy

PostPosted: Fri Nov 30, 2007 2:10 pm    Post subject: Reply with quote

Grazie. Ho la flag opengl di default in make.conf. Mi ha dato un errore identico anche emergendo pango e ati-drivers, deve esserci qualche pacchetto da reinstallare evidentemente ma non capisco cosa. Cercando "qt" non trovo nulla di che, provo un po' con -lGL...
_________________
GreyFox (Linux registered user #435102)
greyfox.imente.org - GreyFox's shots (photoblog)
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Fri Nov 30, 2007 2:16 pm    Post subject: Reply with quote

Gr3yFox wrote:
Grazie. Ho la flag opengl di default in make.conf. Mi ha dato un errore identico anche emergendo pango e ati-drivers, deve esserci qualche pacchetto da reinstallare evidentemente ma non capisco cosa. Cercando "qt" non trovo nulla di che, provo un po' con -lGL...


riesci a postare qualche riga in più dell'errore ???

ciauz
Back to top
View user's profile Send private message
Gr3yFox
Apprentice
Apprentice


Joined: 11 May 2006
Posts: 218
Location: Genoa, Italy

PostPosted: Fri Nov 30, 2007 2:20 pm    Post subject: Reply with quote

L'errore è esattamente quello postato nel primo mex, cmq non serve più, ho trovato il problema: avevo installato i driver fglrx tramite il pacchetto .run di ati e mi sono dimenticato di rimettere l'interfaccia opengl di xorg come default:
E' bastato eselect opengl set xorg-x11 per rimettere a posto, ha installato gli ati-drivers correttamente. Non penso che ripresenterà il problema con pango e con le qt :)
_________________
GreyFox (Linux registered user #435102)
greyfox.imente.org - GreyFox's shots (photoblog)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum