Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PPC] !!! No gcc found
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Heverkuhn
n00b
n00b


Joined: 02 Nov 2007
Posts: 71
Location: Italy

PostPosted: Thu Nov 22, 2007 9:22 pm    Post subject: [PPC] !!! No gcc found Reply with quote

Premessa: ho appena installato gentoo su un G3. Dopo l'emersione di qualche pacchetto e la rimozione e l'aggiunta di qualche USE flag lancio un emerge -uNDv world && emerge --depclean && revdep-rebuild
quest'ultimo mi si pianta su dev-perl:XML-Parser-2.34-r1.
Dopodiche non sono riuscito piu' ad emergere nulla e guarda un po....
Code:
 emerge --info
!!! No gcc found. You probably need to 'source /etc/profile'
!!! to update the environment of this terminal and possibly
!!! other terminals also.
Portage 2.1.3.19 (default-linux/ppc/ppc32/2007.0/G3, [unavailable], glibc-2.7-r0, 2.6.23-gentoo-r1 ppc)
=================================================================
System uname: 2.6.23-gentoo-r1 ppc 750CXe
Timestamp of tree: Thu, 22 Nov 2007 17:30:01 +0000
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.5.1-r3
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r1
ACCEPT_KEYWORDS="ppc ~ppc"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O3 -pipe -mcpu=750 -mpowerpc-gfxopt -mmultiple -mstring"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O3 -pipe -mcpu=750 -mpowerpc-gfxopt -mmultiple -mstring"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=500"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl alsa berkdb bitmap-fonts cdr cli cracklib crypt cups dri fortran gdbm gpm iconv ipv6 isdnlog midi mudflap ncurses nls nptl nptlonly openmp pcre perl ppc pppd python qt3 qt4 readline reflection session spl ssl tcpd truetype-fonts type1-fonts unicode xorg zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="r128 fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTDIR_OVERLAY


Ovviamente gcc c'e' ancora e ho lanciato un source /etc/profile e un env-update
mi sfugge qualcosa di veramente stupido, vero?
Grazie
Heverz
Ciao :)
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Nov 22, 2007 9:36 pm    Post subject: Reply with quote

Code:

gcc-config -l

che dice?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Heverkuhn
n00b
n00b


Joined: 02 Nov 2007
Posts: 71
Location: Italy

PostPosted: Fri Nov 23, 2007 12:08 am    Post subject: Reply with quote

Scen wrote:
Code:

gcc-config -l

che dice?

mi dice
Code:

 * gcc-config: Active gcc profile is invalid!
 [1] powerpc-unknown-linux-gnu-4.2.2


ci sono problemi anche con libstdc++.so.6

infatti non si aprono nemmeno le pagine del man
Code:

groff: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Fri Nov 23, 2007 6:48 am    Post subject: Reply with quote

I messaggi sono chiari: c'è qualcosa che non va nella tua toolchain. Non essendo esperto dell'architettura ppc lascio il posto a chi ne sa + di me, nel frattempo di consiglio di postare l'output di
Code:

emerge --info

e il contenuto di /etc/make.conf
in modo da poterti aiutare + facilmente.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Fri Nov 23, 2007 9:19 am    Post subject: Reply with quote

Moved from Forum di discussione italiano to Forum italiano (Italian).

Trattasi di un problema di supporto.
Peraltro, come da linee guida, é bene evidenzare già nel subject l'architettura diversa da x86 (stavolta lo faccio io)
_________________
Ciao da me!
Back to top
View user's profile Send private message
Heverkuhn
n00b
n00b


Joined: 02 Nov 2007
Posts: 71
Location: Italy

PostPosted: Fri Nov 23, 2007 7:14 pm    Post subject: Reply with quote

randomaze wrote:
Moved from Forum di discussione italiano to Forum italiano (Italian).

Trattasi di un problema di supporto.
Peraltro, come da linee guida, é bene evidenzare già nel subject l'architettura diversa da x86 (stavolta lo faccio io)


Scusate l'errore.

Scen wrote:
nel frattempo di consiglio di postare l'output di emerge --info


Ho quotato tali informazioni nel primo messaggio del topic...

In ogni caso credo che, visto che nel sistema non ho ancora emerso l'ambiente grafico tanto vale formattare e reinstallare tutto.
Non so quale possa essere l'errore ma suppongo che comunque dipenda dalla leggerezza con quale ho aggiunto una miriade di USE flag all'inizio ( non avevo quest'errore) per poi concellarle subito dopo. Le ho copiate direttamente da un secondo pc nel quale gentoo è già installato..mi sono reso presto conto che non avevo bisogno del supporto per tutti quei pacchetti che tanto non avrei mai installato. Perciò le ho cancellate e ho fatto un update completo...mea culpa:P
Grazie
Heverz
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Sat Nov 24, 2007 1:04 am    Post subject: Reply with quote

Non credo che delle semplici USE flag che a quanto ho capito poi non hai nemmeno usato per compilare niente possano compromettere cosi' tanto un sistema. purtroppo non ho mai avuto esperienza di ppc e non so proprio come aiutarti.
Back to top
View user's profile Send private message
Heverkuhn
n00b
n00b


Joined: 02 Nov 2007
Posts: 71
Location: Italy

PostPosted: Sat Nov 24, 2007 4:47 pm    Post subject: Reply with quote

MeMyselfAndI wrote:
Non credo che delle semplici USE flag che a quanto ho capito poi non hai nemmeno usato per compilare niente possano compromettere cosi' tanto un sistema. purtroppo non ho mai avuto esperienza di ppc e non so proprio come aiutarti.


Grazie lo stesso, tanto ora sto rifacendo tutto da capo. Comunque le USE flag le ho usate, tanto è vero che per scaricare il logger di sistema mi ha emerso qualcosa come una cinquantina di pacchetti.E' li che mi sono reso conto che forse avevo esagerato un pò... :P
Visto che la cosa mi è saltata agli occhi solo quando sono tornato a casa, ho deciso di rimediare cancellando quelle USE flag e facendo una bella pulizia...
Qualcosa deve essere andato male a quanto pare....:P
Grazie comunque del supporto...:)
Ciao
Heverz
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Sat Nov 24, 2007 11:54 pm    Post subject: Re: [PPC] !!! No gcc found Reply with quote

Code:
ACCEPT_KEYWORDS="ppc ~ppc"

Fossi in te deciderei di tenerne solo una: la stabile.
Code:
CFLAGS="-O3 -pipe -mcpu=750 -mpowerpc-gfxopt -mmultiple -mstring"

Secondo le Safe CFLAGS -O3 è instabile su G4.
Se ti servissero dei binari, tanto per accorciare i tempi, prova a seguire questo thread:
G4 binaries available
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
Heverkuhn
n00b
n00b


Joined: 02 Nov 2007
Posts: 71
Location: Italy

PostPosted: Sun Nov 25, 2007 5:00 am    Post subject: Re: [PPC] !!! No gcc found Reply with quote

xdarma wrote:

Secondo le Safe CFLAGS -O3 è instabile su G4.

Il pc è un vecchio G3 perciò ho inserito le CFLAFS consigliate nel make.examples per tali computer:

Code:
CFLAGS="-O3 -pipe -mcpu=G3 -fno-strict-aliasing"


e

Code:
ACCEPT_KEYWORDS="~ppc"


Credo che cosi vada, trall'altro su questo pc avrò bisogno esclusivamente deigli strumenti indispensabili e di samba. Non credo emergerò ambiente grafico per ora...
Grazie a tutti per il supporto
Heverz
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum