Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba 3.0.26 upgrade: home directories not working anymore
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Nahor
n00b
n00b


Joined: 05 Jun 2003
Posts: 51

PostPosted: Thu Nov 15, 2007 7:17 pm    Post subject: Samba 3.0.26 upgrade: home directories not working anymore Reply with quote

Hey,

I updated samba on my server from samba-3.0.24-r3 to samba-3.0.26a-r2 and now, I can't access my home directory from a Windows machine using "\\<hostname>\<username>". I can still access it using "\\<ip>\<username>" or "\\<hostname>\homes", but not "\\<hostname>\<username>". It says:
Code:
\\<hostname>\<username> refers to a location that is unavailable. It could be on a hard drive on this computer, or on a network. Check to make sure that the disk is properly inserted, or that you are connected to the Internet or your network, and then try again. If it still cannot be located, the information might have been moved to a different location.

I don't see any thing out of the ordinary in Samba's log.

Has anyone seen this before? Any idea how to fix it?
Back to top
View user's profile Send private message
ipic
Apprentice
Apprentice


Joined: 29 Dec 2003
Posts: 177
Location: UK

PostPosted: Fri Nov 16, 2007 1:30 pm    Post subject: Re: Samba 3.0.26 upgrade: home directories not working anymo Reply with quote

Nahor wrote:

Code:
\\<hostname>\<username> refers to a location that is unavailable. It could be on a hard drive on this computer, or on a network. Check to make sure that the disk is properly inserted, or that you are connected to the Internet or your network, and then try again. If it still cannot be located, the information might have been moved to a different location.


I saw a similar problem - some saved shortcuts worked, others didn't.
My solution was to reboot the Windows machine - all shares worked after that.
Regards
Ian
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1157
Location: Motown

PostPosted: Fri Nov 16, 2007 3:36 pm    Post subject: Reply with quote

Probably due to this from the release notes archive:
Quote:
Changes to MS-DFS Root Share Behavior
=====================================

Please be aware that the initial value for the "msdfs root" share
parameter was changed in the 3.0.25 release series and that this
option is now disabled by default. Windows clients frequently require
a reboot in order to clear any cached information about MS-DFS
root shares on a server and you may experience failures accessing
file services on Samba 3.0.25 servers until the client reboot
is performed. Alternately, you may explicitly re-enable the
parameter in smb.conf. Please refer to the smb.conf(5) man page
for more details.

Not really a good idea to blindly upgrade such a package. RTFM!
_________________
A mouse is a device used to point at the xterm you want to type in.
Back to top
View user's profile Send private message
Zaister
n00b
n00b


Joined: 08 Apr 2004
Posts: 20
Location: Germany

PostPosted: Fri Nov 16, 2007 4:14 pm    Post subject: Reply with quote

I have similar problem: I have Samba shares on my fileserver that I can no longer access from a Linux client after both machines have been updated to Samba 3.0.27. Accessing the server from a Windows client worked after rebooting the client, but rebooting the Linux client did not help. Trying to mount a share results in this error:

Code:
mount: wrong fs type, bad option, bad superblock on //mercutio/music,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


Checking out dmesg brings up this message:

Code:
CIFS VFS: cifs_mount failed w/return code = -22


Any ideas?
_________________
Regards,
Stefan.
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1157
Location: Motown

PostPosted: Fri Nov 16, 2007 4:21 pm    Post subject: Reply with quote

The ebuild notes inform to emerge net-fs/mount-cifs if desired, as Gentoo has split that support from the main Samba install in order to simplify for those that just want the helper without the full Samba package.
_________________
A mouse is a device used to point at the xterm you want to type in.
Back to top
View user's profile Send private message
Zaister
n00b
n00b


Joined: 08 Apr 2004
Posts: 20
Location: Germany

PostPosted: Fri Nov 16, 2007 4:31 pm    Post subject: Reply with quote

darkphader wrote:
The ebuild notes inform to emerge net-fs/mount-cifs if desired, as Gentoo has split that support from the main Samba install in order to simplify for those that just want the helper without the full Samba package.


Thank you, that worked.
_________________
Regards,
Stefan.
Back to top
View user's profile Send private message
Nahor
n00b
n00b


Joined: 05 Jun 2003
Posts: 51

PostPosted: Fri Nov 16, 2007 5:15 pm    Post subject: Reply with quote

Indeed, just rebooting the client fixed it. Thanks
Back to top
View user's profile Send private message
JackxSt007
n00b
n00b


Joined: 18 Nov 2007
Posts: 12

PostPosted: Sun Nov 18, 2007 9:25 am    Post subject: Reply with quote

darkphader wrote:
The ebuild notes inform to emerge net-fs/mount-cifs if desired, as Gentoo has split that support from the main Samba install in order to simplify for those that just want the helper without the full Samba package.
That is nice, but i got some problem with the names.. when i try to use
Code:
mount -t cifs //workgroup/dir /mnt/smb
it is not working. Solution is to use the ip and not the name.
Code:
mount -t cifs //192.168.5.23/dir /mnt/smb

I have only installed net-fs/mount-cifs and not samba. If samba is installed it works, of course.
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1157
Location: Motown

PostPosted: Sun Nov 18, 2007 2:50 pm    Post subject: Reply with quote

JackxSt007 wrote:
when i try to use
Code:
mount -t cifs //workgroup/dir /mnt/smb
it is not working. Solution is to use the ip and not the name.
Code:
mount -t cifs //192.168.5.23/dir /mnt/smb

I have only installed net-fs/mount-cifs and not samba. If samba is installed it works, of course.

If Samba is just installed? Or actually running?
You may not have any NetBIOS (or otherwise) name resolution.
_________________
A mouse is a device used to point at the xterm you want to type in.
Back to top
View user's profile Send private message
JackxSt007
n00b
n00b


Joined: 18 Nov 2007
Posts: 12

PostPosted: Sun Nov 18, 2007 6:41 pm    Post subject: Reply with quote

darkphader wrote:

If Samba is just installed? Or actually running?
You may not have any NetBIOS (or otherwise) name resolution.


If samba is installed, (not running) it works. But without the package samba, I can only use the ip. Maybe it will be changed in later versions of mount-cifs.
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1157
Location: Motown

PostPosted: Sun Nov 18, 2007 8:00 pm    Post subject: Reply with quote

JackxSt007 wrote:
If samba is installed, (not running) it works. But without the package samba, I can only use the ip. Maybe it will be changed in later versions of mount-cifs.

Hmm...that's very odd. If mount.cifs is installed the rest of the Samba package should have nothing to add.
If you're mounting as a user make sure that mount.cifs is suid.
_________________
A mouse is a device used to point at the xterm you want to type in.
Back to top
View user's profile Send private message
whig
l33t
l33t


Joined: 27 Nov 2004
Posts: 970
Location: New Zealand

PostPosted: Mon Nov 19, 2007 2:39 am    Post subject: Reply with quote

Like this bug details I downgraded to fix a problem in 3.0.27.
Back to top
View user's profile Send private message
tam
Guru
Guru


Joined: 04 Mar 2003
Posts: 569
Location: freiburg.de

PostPosted: Fri Jan 11, 2008 2:53 pm    Post subject: Reply with quote

darkphader wrote:
The ebuild notes inform to emerge net-fs/mount-cifs if desired, as Gentoo has split that support from the main Samba install in order to simplify for those that just want the helper without the full Samba package.


Thanks for your help :wink:
_________________
http://tam.belchenstuermer.de/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum