Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200711-19 ] TikiWiki: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Wed Nov 14, 2007 11:26 pm    Post subject: [ GLSA 200711-19 ] TikiWiki: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: TikiWiki: Multiple vulnerabilities (GLSA 200711-19)
Severity: high
Exploitable: remote
Date: November 14, 2007
Bug(s): #195503
ID: 200711-19

Synopsis


Multiple vulnerabilities have been discovered in TikiWiki, possibly
resulting in the remote execution of arbitrary code.


Background


TikiWiki is an open source content management system written in PHP.


Affected Packages

Package: www-apps/tikiwiki
Vulnerable: < 1.9.8.3
Unaffected: >= 1.9.8.3
Architectures: All supported architectures


Description


Stefan Esser reported that a previous vulnerability (CVE-2007-5423,
GLSA 200710-21) was not properly fixed in TikiWiki 1.9.8.1
(CVE-2007-5682). The TikiWiki development team also added several
checks to avoid file inclusion.


Impact


A remote attacker could exploit these vulnerabilities to inject
arbitrary code with the privileges of the user running the application.


Workaround


There is no known workaround at this time.


Resolution


All TikiWiki users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/tikiwiki-1.9.8.3"


References

GLSA 200710-21
CVE-2007-5423
CVE-2007-5682


Last edited by GLSA on Mon Jun 10, 2013 4:26 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum