Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200711-20 ] Pioneers: Multiple Denials of Service
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Thu Nov 15, 2007 12:26 am    Post subject: [ GLSA 200711-20 ] Pioneers: Multiple Denials of Service Reply with quote

Gentoo Linux Security Advisory

Title: Pioneers: Multiple Denials of Service (GLSA 200711-20)
Severity: normal
Exploitable: remote
Date: November 14, 2007
Updated: November 29, 2007
Bug(s): #198807
ID: 200711-20

Synopsis


Two Denial of Service vulnerabilities were discovered in Pioneers.


Background


Pioneers (formerly gnocatan) is a clone of the popular board game "The
Settlers of Catan".


Affected Packages

Package: games-board/pioneers
Vulnerable: < 0.11.3-r1
Unaffected: >= 0.11.3-r1
Architectures: All supported architectures


Description


Roland Clobus discovered that the Pioneers server may free sessions
objects while they are still in use, resulting in access to invalid
memory zones (CVE-2007-5933). Bas Wijnen discovered an error when
closing connections which can lead to a failed assertion
(CVE-2007-6010).


Impact


A remote attacker could send specially crafted data to the vulnerable
server, resulting in a Denial of Service.


Workaround


There is no known workaround at this time.


Resolution


All Pioneers users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=games-board/pioneers-0.11.3-r1"


References

CVE-2007-5933
CVE-2007-6010


Last edited by GLSA on Wed May 23, 2012 4:24 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum