Joined: 12 May 2004
|Posted: Wed Nov 14, 2007 11:26 pm Post subject: [ GLSA 200711-19 ] TikiWiki: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: TikiWiki: Multiple vulnerabilities (GLSA 200711-19)
Date: November 14, 2007
Multiple vulnerabilities have been discovered in TikiWiki, possibly
resulting in the remote execution of arbitrary code.
TikiWiki is an open source content management system written in PHP.
Vulnerable: < 22.214.171.124
Unaffected: >= 126.96.36.199
Architectures: All supported architectures
Stefan Esser reported that a previous vulnerability (CVE-2007-5423,
GLSA 200710-21) was not properly fixed in TikiWiki 188.8.131.52
(CVE-2007-5682). The TikiWiki development team also added several
checks to avoid file inclusion.
A remote attacker could exploit these vulnerabilities to inject
arbitrary code with the privileges of the user running the application.
There is no known workaround at this time.
All TikiWiki users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/tikiwiki-184.108.40.206"
Last edited by GLSA on Mon Jun 10, 2013 4:26 am; edited 3 times in total