Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Kwrite emerge - masked by EAPI -1 ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 938
Location: Greece

PostPosted: Wed Nov 14, 2007 12:08 am    Post subject: [SOLVED]Kwrite emerge - masked by EAPI -1 ? Reply with quote

When I try to emerge kwrite I got:

Code:
Calculating dependencies |
!!! All ebuilds that could satisfy "kwrite" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kwrite-3.94.0 (masked by: required EAPI -1, supported EAPI 0)


What does it means? What should I do to emerge kwrite?
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)


Last edited by Holysword on Wed Nov 14, 2007 8:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2584
Location: userland

PostPosted: Wed Nov 14, 2007 12:24 am    Post subject: Reply with quote

Update to >=portage-2.1.3.12, this is the first version to support EAPI-1.
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 938
Location: Greece

PostPosted: Wed Nov 14, 2007 12:58 am    Post subject: Reply with quote

Ah, yes ( a most carefully read at man emerge and I could solve it by myself...)

But now it is like this:
Code:
Calculating dependencies |
!!! All ebuilds that could satisfy "kwrite" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kwrite-3.95.0 (masked by: missing keyword)
- kde-base/kwrite-3.95.2 (masked by: missing keyword)


I ever thought that kwrite was a base editor from kde. Why it is so "masked" ?
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2584
Location: userland

PostPosted: Wed Nov 14, 2007 9:29 am    Post subject: Reply with quote

Because its the kde-4 version, which is currently in beta. You might want either to remove the kde-4 overlay, or do
Code:
echo kde-base/kwrite ** >> /etc/portage/package.keywords

(and likewise for all other kde packages) if you want to go with the unstable version of kde.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2658
Location: Slovenia

PostPosted: Wed Nov 14, 2007 9:55 am    Post subject: Reply with quote

There is no kwrite ebuild for kde3. If you want kwrite, you need to emerge kate.
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 938
Location: Greece

PostPosted: Wed Nov 14, 2007 8:29 pm    Post subject: Reply with quote

Its true: emerging kate I got kwrite

Thx you both!
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum