Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ndiswrapper non associa l'interfaccia di rete
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mmiki
n00b
n00b


Joined: 12 Nov 2007
Posts: 6

PostPosted: Tue Nov 13, 2007 1:19 pm    Post subject: ndiswrapper non associa l'interfaccia di rete Reply with quote

bonjour a tut le mond

dunque sto provando un'installazione gentoo ma ho qualche problema con la chiavetta wireless usb
e' una d-link dwl-g132

ho installato correttamente ndiswrapper e i driver, e quando inserisco la chiavetta, effettivamente, l'output di ndiswrapper -l e' "device present"

solo che non viene associata un'interfaccia!
dmesg non da' indicazioni utili (si ferma a ndiswrapper 1.33 loaded ecc.. )

ho cercato anche su internet e sul forum, ma non ho trovato nulla di utile, nemmeno provando (come si consigliava nel forum inglese di gentoo) a caricare ripetutamente il modulo di ndiswrapper
c'e' anche gia' la riga "alias wlan0 ndiswrapper" in /etc/modules.conf

giusto per completezza, anche ifconfig non vede altre interfacce di rete oltre a lo e eth0

qualche consiglio?

grazie
mmiki
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Tue Nov 13, 2007 4:33 pm    Post subject: Reply with quote

prova a leggere il tutorial sul sito di ndiswrapper poi vediamo che errori ti da.
http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,installation/
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
mmiki
n00b
n00b


Joined: 12 Nov 2007
Posts: 6

PostPosted: Tue Nov 13, 2007 5:28 pm    Post subject: Reply with quote

sì nel tutorial non c'è scritto nulla di diverso da quello che ho fatto.

nè da dmesg nè da ndiswrapper -l risultano errori, semplicemente non viene "creata" wlan0.
anche usando la versione precedente dei driver, anche reinstallando il driver nuovo.

ho però scoperto che nella lista delle chiavette supportate, per la mia consigliano di usare ndiswrapper -a per forzare l'utilizzo di un driver per una periferica (cosa che però, su fedora e ubuntu dove ho già provato con successo, non è mai stata necessaria, per questo non avevo mai notato il consiglio).

ora, posto che l'id della mia chiavetta è 2001:3a03, dando "ndiswrapper -a 2001:3a03 neta5agu" ricevo una serie di errori del tipo

Code:
couldn't create symlink for "2001:3a01.F.conf": File exists - installation may be incomplete
couldn't create symlink for "2001:3a03.F.conf": File exists - installation may be incomplete
couldn't create symlink for "2001:3a08.F.conf": File exists - installation may be incomplete
driver 'neta5agu' is not installed (properly)!


insomma, c'è decisamente qualcosa di nuovo!
adesso proverò ad indagare

grazie dell'aiuto!
Back to top
View user's profile Send private message
mmiki
n00b
n00b


Joined: 12 Nov 2007
Posts: 6

PostPosted: Wed Nov 14, 2007 10:06 pm    Post subject: Reply with quote

ok, sono riuscito a far andare ndiswrapper, ora ho un'interfaccia wlan0

però dev'esserci qualcosa che mi sfugge, perchè per farlo andare ho dovuto installarlo da sorgenti seguendo il consiglio di un utente suse -.-
ho provato con molto scetticismo, pensando al limite a qualche impostazione di portage sbagliata (qualche flag USE, ma ndiswrapper ne supporta tre: usb, kernel_linux e debug...)
e invece sta di fatto che ora funziona.

perchè?
Back to top
View user's profile Send private message
mmiki
n00b
n00b


Joined: 12 Nov 2007
Posts: 6

PostPosted: Thu Nov 15, 2007 4:33 pm    Post subject: Reply with quote

CODE:
# emerge -pv ndiswrapper

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] net-wireless/ndiswrapper-1.47 USE="-debug -usb" 194 kB

Total: 1 package (1 new), Size of downloads: 194 kB
/CODE

no comment

chiedo scusa per l'idiozia del thread, non aspetto neanche di controllare che funzioni tutto davvero
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum