Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ext3fs Error on Gentoo startup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
FireGecko
n00b
n00b


Joined: 12 Nov 2007
Posts: 6

PostPosted: Mon Nov 12, 2007 7:49 pm    Post subject: Ext3fs Error on Gentoo startup Reply with quote

Hi,

I'm new to Gentoo, and I've installed it for tests on my old Pentium III Laptop (Fujitsu Lifebook S Series).
The installation went well (excepting the minor problem with the Config files that needed updating).
But now that I've started Gentoo for the first time, I get the following error.
Code:

fsck.ext3: No such file or directory while trying to open /dev/ROOT
/dev/ROOT:
The superblock could not be read or describe a correct ext2 filesystem. If the device is valid and it really
contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might
try running e2fsck with an alternate superblock:
   e2fsck -b 8193 <device>


I don't know if this is relevant, but according to my /etc/fstab, the ROOT-Filesystem is ext3, so what am I supposed to do with e2fsck ?
What can I do against this problem (so I can finally use Gentoo, and I didn't waste an entire weekend) ?

Greetings,

FireGecko
Back to top
View user's profile Send private message
Habbit
Apprentice
Apprentice


Joined: 01 Sep 2007
Posts: 237
Location: 3.7137 W, 40.3873 N

PostPosted: Mon Nov 12, 2007 8:13 pm    Post subject: Reply with quote

Most probably you didn't edit your /etc/fstab file as instructed. /dev/ROOT is not a valid block device, you need to substitute "ROOT" for your root's partition device path. Example: /dev/sdb6 for my Gentoo root partition on 2nd logical partition (6) of the 2nd SATA/SCSI hard drive (sdb).
Same thing goes for /dev/SWAP. And again, the default /etc/fstab file is just a pattern. If it says "ext3" there but your root partition is reiserfs (as is mine), ext2, xfs, jfs or whatever, you need to put it right.
Your system boots because the kernel does not use /etc/fstab to locate its root partition: the root= kernel command line option does that, but other filesystems (like your swap) do fail to automatically mount if their /etc/fstab is missing or bad.
_________________
Code:
~ $ objdump -d ./habbit_mind
90      xchg %rax, %rax
EB FD   jmp $-3
Back to top
View user's profile Send private message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2319
Location: /home/zach

PostPosted: Mon Nov 12, 2007 10:46 pm    Post subject: Reply with quote

Please post the contents of /etc/fstab. Habbit is probably correct about that being the cause of the problem. If you post the file, it will be much easier to show you the problem.
_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Tue Nov 13, 2007 6:02 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.
Moved in favour of https://forums.gentoo.org/viewtopic-t-2104.html
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum