Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Problemi aggiornamento a pam-0.99
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
LastHope
Apprentice
Apprentice


Joined: 11 May 2005
Posts: 237
Location: Mordor

PostPosted: Fri Nov 09, 2007 8:20 pm    Post subject: [Risolto] Problemi aggiornamento a pam-0.99 Reply with quote

Ciao a tutti,
non riesco a fare l'aggiornamento da pam 0.78-r5 a 0.99.8.1-r1...inizialmente mi segnalava di controllare l'how-to per l'aggiornamento, che ho seguito:
Quote:

The most common presence of orphan files in /etc/pam.d are the backup files created by most editors, ending with a tilde character (~). The remaining files, unless you created them yourself for your particular setup, should be safe to remove (or at least move away), as they are probably leftovers from previously installed packages.

Io avevo solo xdm come file trovato da qfile...l'ho quindi spostato, e ha iniziato a fare il processo di emerge, fino a che...
Code:

-lpam -L../libpam_misc -lpam_misc
tst-pam_limits1.c: In function `main':
tst-pam_limits1.c:130: error: `RLIMIT_NICE' undeclared (first use in this function)
tst-pam_limits1.c:130: error: (Each undeclared identifier is reported only once
tst-pam_limits1.c:130: error: for each function it appears in.)
make[2]: *** [tst-pam_limits1.o] Error 1
make[2]: *** Waiting for unfinished jobs....
mkdir .libs
i686-pc-linux-gnu-gcc -DLIBPAM_COMPILE -I../libpam/include -I../libpamc/include -I../libpam_misc/include -O2 -march=i686 -pipe -W -Wall -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wstrict-prototypes -Wwrite-strings -Winline -Wshadow -Wl,--as-needed -Wl,-O1 -o .libs/tst-pam_dispatch1 tst-pam_dispatch1.o  -L/var/tmp/portage/sys-libs/pam-0.99.8.1-r1/work/Linux-PAM-0.99.8.1/libpam -L/var/tmp/portage/sys-libs/pam-0.99.8.1-r1/work/Linux-PAM-0.99.8.1/libpam_misc /var/tmp/portage/sys-libs/pam-0.99.8.1-r1/work/Linux-PAM-0.99.8.1/libpam_misc/.libs/libpam_misc.so /var/tmp/portage/sys-libs/pam-0.99.8.1-r1/work/Linux-PAM-0.99.8.1/libpam/.libs/libpam.so -ldl
creating tst-pam_dispatch1
make[2]: Leaving directory `/var/tmp/portage/sys-libs/pam-0.99.8.1-r1/work/Linux-PAM-0.99.8.1/xtests'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-libs/pam-0.99.8.1-r1/work/Linux-PAM-0.99.8.1'
make: *** [all] Error 2

Qualche idea?
Grazie a tutti,

LastHope


Last edited by LastHope on Wed Nov 21, 2007 9:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Mon Nov 19, 2007 3:16 pm    Post subject: Reply with quote

quel limite dovrebbe essere impostato in resource.h o negli header del kernel o da glibc (su chi vada a linkare non so, bisognerebbe vedere un pelo più di output forse)

che versioni hai installate di glibc e kernel-headers ?
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
LastHope
Apprentice
Apprentice


Joined: 11 May 2005
Posts: 237
Location: Mordor

PostPosted: Mon Nov 19, 2007 3:24 pm    Post subject: Reply with quote

Peach wrote:
quel limite dovrebbe essere impostato in resource.h o negli header del kernel o da glibc (su chi vada a linkare non so, bisognerebbe vedere un pelo più di output forse)

che versioni hai installate di glibc e kernel-headers ?

Ciao,
in effetti ho delle versioni vecchie (e dovendo fare la tesi sotto Linux, ho sempre avuto paura ad aggiornare che poi mi crashasse il tutto :P):
Code:

dani@dani_lap ~/tesiLevner/Latex $ eix glibc
[U] sys-libs/glibc
     Available versions:  (2.2)  [P]2.2.5-r10 [P]2.3.2-r12 2.3.5-r3 2.3.6-r4 2.3.6-r5 2.4-r4 2.5-r2 2.5-r3 2.5-r4 **2.5.1 ~2.6 2.6.1 ~2.7
        {build debug erandom glibc-compat20 glibc-omitfp hardened linuxthreads-tls multilib nls nptl nptlonly pic profile selinux userlocales vanilla}
     Installed versions:  2.3.6-r3(2.2)(11:59:39 06/11/06)(-build -erandom -glibc-compat20 -glibc-omitfp -hardened -linuxthreads-tls -multilib nls nptl -nptlonly -pic -profile -selinux -userlocales)
     Homepage:            http://www.gnu.org/software/libc/libc.html
     Description:         GNU libc6 (also called glibc2) C library

dani@dani_lap ~/tesiLevner/Latex $ eix linux-headers
[U] sys-kernel/linux-headers
     Available versions:  *2.0.40-r1 *2.2.26-r1 2.4.26-r1 ~2.4.33.3 2.6.8.1-r4 2.6.11-r2 ~2.6.11-r3 *2.6.11-r4 2.6.11-r5 *2.6.11-r6 *2.6.16 ~2.6.17 2.6.17-r1 2.6.17-r2 ~2.6.19.2-r2 ~2.6.20-r2 2.6.21 2.6.22-r2 ~2.6.23 ~2.6.23-r1
     Installed versions:  2.6.11-r2(09:28:26 06/11/06)
     Homepage:            http://www.kernel.org/ http://www.gentoo.org/
     Description:         Linux system headers


Se per aggiornare PAM devo aggiornare tutto questo, mi sa che aspetto (per sicurezza, non scateniamo Murphy) di essermi laureato :)...
Grazie del tip!
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Mon Nov 19, 2007 3:59 pm    Post subject: Reply with quote

ok, quando lo farai leggiti tutte le guide che erano sticky tempo fa sull'update dei due pacchetti e se hai problemi posta pure.
;) in bocca al lupo per la tesi
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Flameeyes
Retired Dev
Retired Dev


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Tue Nov 20, 2007 7:44 pm    Post subject: Reply with quote

Ho corretto il problema di RLIMIT_NICE da un po', quindi dovresti poter ora aggiornare senza problemi, a patto di fare un emerge --sync prima :)

Anzi nel frattempo è stato stabilizzato almeno su alcune architetture (amd64 e x86 comprese) PAM 0.99.9.0 quindi ti sei risparmiato una compilazione, va ;)

(Ed è caldamente suggerito aggiornare visto che lo 0.78 è vulnerabile con pam_console abilitato e in aggiunta non è più supportato.)
_________________
You want to know what I'm working on right now? Just follow my blog.
Back to top
View user's profile Send private message
LastHope
Apprentice
Apprentice


Joined: 11 May 2005
Posts: 237
Location: Mordor

PostPosted: Wed Nov 21, 2007 9:43 pm    Post subject: Reply with quote

Ciao,
in effetti questa volta pam e' stato emerso correttamente...tuttavia, adesso non mi parte piu' Firefox da utente (invece da root va).
Gli altri programmi invece mi sembra che funzionino correttamente...
Questo e' il mio system-auth...ho sbagliato qualcosa?
Code:

auth       required     pam_env.so
auth       sufficient   pam_unix.so try_first_pass likeauth nullok
auth       required     pam_deny.so

account    required     pam_unix.so

password   required     pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 try_first_pass retry=3
password   sufficient   pam_unix.so try_first_pass use_authtok nullok md5 shadow
password   required     pam_deny.so

session    required     pam_limits.so
session    required     pam_unix.so

Ho dimenticato/sbagliato qualcosa?
Grazie a tutti! :)

EDIT: riavviando il sistema, firefox e' partito correttamente...metto [risolto] :)
Back to top
View user's profile Send private message
Flameeyes
Retired Dev
Retired Dev


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Fri Nov 23, 2007 11:04 am    Post subject: Reply with quote

Che io sappia comunque Firefox non ha nulla a che vedere con PAM.
_________________
You want to know what I'm working on right now? Just follow my blog.
Back to top
View user's profile Send private message
LastHope
Apprentice
Apprentice


Joined: 11 May 2005
Posts: 237
Location: Mordor

PostPosted: Fri Nov 23, 2007 1:08 pm    Post subject: Reply with quote

Flameeyes wrote:
Che io sappia comunque Firefox non ha nulla a che vedere con PAM.

Secondo me, era dovuto ad una extension di firefox per cui non partiva piu'...ne ho diverse, ma ho il sospetto che AllPeers (di cui mi compariva l'output su console se lanciavo firefox da aterm che era stato caricato) avesse un qualche problema...
Ciao a tutti

LastHope
Back to top
View user's profile Send private message
adam_z
Guru
Guru


Joined: 22 Jul 2005
Posts: 335
Location: EUROPE - ITALY - Bologna

PostPosted: Sun Jan 13, 2008 5:17 pm    Post subject: Reply with quote

stesso problema ... stessa soluzione.

ora xdm dove lo metto? o lo posso cancellare ?

GRAZIE
_________________
*** affittasi ***
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum