Joined: 12 May 2004
|Posted: Wed Nov 07, 2007 8:26 pm Post subject: [ GLSA 200711-06 ] Apache: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: Apache: Multiple vulnerabilities (GLSA 200711-06)
Date: November 07, 2007
Multiple vulnerabilities have been discovered in Apache, possibly resulting in a Denial of Service or the disclosure of sensitive information.
The Apache HTTP server is one of the most popular web servers on the Internet.
Vulnerable: < 2.2.6
Unaffected: >= 2.0.59-r5 < 2.0.60
Unaffected: >= 2.2.6
Architectures: All supported architectures
Multiple cross-site scripting vulnerabilities have been discovered in mod_status and mod_autoindex (CVE-2006-5752, CVE-2007-4465). An error has been discovered in the recall_headers() function in mod_mem_cache (CVE-2007-1862). The mod_cache module does not properly sanitize requests before processing them (CVE-2007-1863). The Prefork module does not properly check PID values before sending signals (CVE-2007-3304). The mod_proxy module does not correctly check headers before processing them (CVE-2007-3847).
A remote attacker could exploit one of these vulnerabilities to inject arbitrary script or HTML content, obtain sensitive information or cause a Denial of Service.
There is no known workaround at this time.
All Apache users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/apache-2.0.59-r5"
Last edited by GLSA on Sat Feb 02, 2008 4:18 am; edited 2 times in total