Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox aspetto insolito
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
nillkheope
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2005
Posts: 92

PostPosted: Wed Nov 07, 2007 12:20 pm    Post subject: Firefox aspetto insolito Reply with quote

ciao e scusate il nome del post, non saprei come definire questo problema.
uso gentoo su amd64 e come interfaccia grafica uso xfce4.

in pratica sembra che firefox non abbia i font per aprire correttamente il mio file manager thunar.
Se clicco su File->Apri File mi si presenta una finestra tipo thunar ma tutti i caratteri sono sostituiti dai soliti quadratini che
indicano la mancanza di font adatti alla codifica di tali caratteri.

Si è capito qualcosa?
Adesso prendo uno screenshot e poi lo metto online così potete guardare con i vostri occhi.

Grazie ad ogni aiuto.
Back to top
View user's profile Send private message
nillkheope
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2005
Posts: 92

PostPosted: Wed Nov 07, 2007 12:59 pm    Post subject: Reply with quote

il problema mi sembra che sia pango.

questo è l'output a terminale quando lancio firefox (bin).

Code:

(firefox-bin:24901): Pango-WARNING **: No builtin or dynamically
loaded modules were found. Pango will not work correctly.
This probably means there was an error in the creation of:
  '/etc/pango/pango.modules'
You should create this file by running pango-querymodules.

(firefox-bin:24901): Pango-WARNING **: pango_shape called with bad font, expect ugly output

(firefox-bin:24901): Pango-WARNING **: pango_font_get_glyph_extents called with bad font, expect ugly output

(firefox-bin:24901): Pango-WARNING **: _pango_cairo_font_install called with bad font, expect ugly output

(firefox-bin:24901): Pango-WARNING **: pango_font_get_metrics called with bad font, expect ugly output


Suggerimenti?
Ho provato a riemergerlo e a lanciare etc-update...nessun cambiamento.
Back to top
View user's profile Send private message
nillkheope
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2005
Posts: 92

PostPosted: Wed Nov 07, 2007 1:21 pm    Post subject: Reply with quote

ok mi mancano questi
Code:

pango_shape
pango_font_get_glyph_extents
_pango_cairo_font_install
pango_font_get_metrics


se provo con
Code:

nill@babylon ~ $ ls /usr/lib64/pango/1.6.0/modules/
pango-arabic-fc.la    pango-hangul-fc.la   pango-khmer-fc.la
pango-arabic-fc.so    pango-hangul-fc.so   pango-khmer-fc.so
pango-arabic-lang.la  pango-hebrew-fc.la   pango-syriac-fc.la
pango-arabic-lang.so  pango-hebrew-fc.so   pango-syriac-fc.so
pango-basic-fc.la     pango-indic-fc.la    pango-thai-fc.la
pango-basic-fc.so     pango-indic-fc.so    pango-thai-fc.so
pango-basic-x.la      pango-indic-lang.la  pango-tibetan-fc.la
pango-basic-x.so      pango-indic-lang.so  pango-tibetan-fc.so


dove li trovo i mancanti?
Back to top
View user's profile Send private message
morellik
l33t
l33t


Joined: 03 Feb 2003
Posts: 629
Location: Firenze

PostPosted: Wed Nov 07, 2007 2:40 pm    Post subject: Reply with quote

Io uso xfce4 e non ho di questi problemi pur avendo nella directory /usr/lib64/pango/1.6.0/modules/ i tuoi
stessi file.

Hai provato a dare il comando suggerito da firefox: pango-querymodules per vedere che tu non abbia errori di diverso tipo?
Back to top
View user's profile Send private message
nillkheope
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2005
Posts: 92

PostPosted: Tue Nov 13, 2007 5:31 pm    Post subject: Reply with quote

scusate il ritardo nella risposta...

è proprio con pango-querymodules che ho notato ciò che veniva linkato o meno.

se lanci firefox da terminale e non lo metti in background, mentre provi ad aprire un file da File->Apri non viene segnalato nessun errore sul terminale?
Immagino di no...chissà che caizer di problema che ho??
Back to top
View user's profile Send private message
morellik
l33t
l33t


Joined: 03 Feb 2003
Posts: 629
Location: Firenze

PostPosted: Wed Nov 14, 2007 11:51 am    Post subject: Reply with quote

Purtroppo non mi segnala l'errore che hai tu.
Potrebbe essere un problema legato all'architettura. Io ho un 32bit.
Usi il pacchetto binario di firefox? Usi pacchetti ~?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum