Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
disco usb da 500gb non riconosciuto...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Wed Jun 13, 2007 7:50 am    Post subject: disco usb da 500gb non riconosciuto... Reply with quote

Ciao, ho collegato al mio computer un disco lacie esterno usb da 500gb...
Non sono stato in grado di montare l'unità :cry:
Lanciando un dmesg però ricevo questo:

Code:

ohci_hcd 0000:00:0f.2: OHCI Host Controller
ohci_hcd 0000:00:0f.2: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:0f.2: irq 9, io mem 0xfeb7d000
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
USB Universal Host Controller Interface driver v3.0
Initializing USB Mass Storage driver...
usb 1-1: new full speed USB device using ohci_hcd and address 2
usb 1-1: device descriptor read/64, error -110
usb 1-1: device descriptor read/64, error -110
usb 1-1: new full speed USB device using ohci_hcd and address 3
usb 1-1: device descriptor read/64, error -110
usb 1-1: device descriptor read/64, error -110
usb 1-1: new full speed USB device using ohci_hcd and address 4
usb 1-1: device descriptor read/8, error -110
usb 1-1: device descriptor read/8, error -110
usb 1-1: new full speed USB device using ohci_hcd and address 5
usb 1-1: device descriptor read/8, error -110
usb 1-1: device descriptor read/8, error -110
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.


Qualche suggerimento?
grazie
ciao
Fede
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Wed Jun 13, 2007 10:00 am    Post subject: Reply with quote

disco nuovo?
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Wed Jun 13, 2007 10:12 am    Post subject: Reply with quote

Partizionarlo?
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Jun 13, 2007 10:20 am    Post subject: Reply with quote

MeMyselfAndI wrote:
Partizionarlo?


Ho un LACIE usb da 120G e all'acquisto era già formattato in FAT32 ed è stato riconosciuto subito!
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Wed Jun 13, 2007 10:27 am    Post subject: Reply with quote

MeMyselfAndI wrote:
Partizionarlo?


Teoricamente dovrebbe già esserlo .... ma.... :oops: se l'unità non è la sda, sdb, sdc, sdd, hda, hdb, hdc, hdd... qual è?? :oops: :oops:
Perdonate la domanda.....
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Wed Jun 13, 2007 10:31 am    Post subject: Reply with quote

No scusa perdonami tu perche' ti ho dato un suggerimento frettoloso, avevo letto frettolosamente il tuo post. Sei sicuro che sia ben alimentato il tuo hard disk? Io ho un hard disk esterno e non ne vuole sapere di funzionare se lo collego ad una sola porta usb, devo usare l'adattatore per collegarlo a due porte usb.
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Jun 13, 2007 10:31 am    Post subject: Reply with quote

prova a dare dmesg prima e dopo l'attacco dell' hd esterno e vedi se trovi un dispositivo sdx che prima non c'èra. Se lo trovi, sdx è il disco LACIE
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Wed Jun 13, 2007 10:35 am    Post subject: Reply with quote

MeMyselfAndI wrote:
No scusa perdonami tu perche' ti ho dato un suggerimento frettoloso, avevo letto frettolosamente il tuo post. Sei sicuro che sia ben alimentato il tuo hard disk? Io ho un hard disk esterno e non ne vuole sapere di funzionare se lo collego ad una sola porta usb, devo usare l'adattatore per collegarlo a due porte usb.


Si son sicuro sia alimentato correttamente perchè ha l'alimentazione a parte non è di quelli autoalimentati.
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Wed Jun 13, 2007 10:36 am    Post subject: Reply with quote

Tigerwalk wrote:
prova a dare dmesg prima e dopo l'attacco dell' hd esterno e vedi se trovi un dispositivo sdx che prima non c'èra. Se lo trovi, sdx è il disco LACIE


Purtroppo non posso rimuoverlo perchè son collegato in remoto.. ma da quella che è la mia conoscenza dovrebbe poter essere una di quelle 8 unità no? c'è possibilità che abbia un altro nome?
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Wed Jun 13, 2007 10:37 am    Post subject: Reply with quote

Peach wrote:
disco nuovo?


Aggiungo: lo hai provato su un altro PC/Altro sistema operativo?
_________________
Ciao da me!
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Wed Jun 13, 2007 10:40 am    Post subject: Reply with quote

randomaze wrote:
Peach wrote:
disco nuovo?


Aggiungo: lo hai provato su un altro PC/Altro sistema operativo?


Ehm no effettivamente no..
Back to top
View user's profile Send private message
jiojio74
n00b
n00b


Joined: 12 Jan 2007
Posts: 24

PostPosted: Wed Jun 13, 2007 10:54 am    Post subject: Reply with quote

Un bel:
Code:
# lsusb

dovrebbe darti un primo segno che il disco sia stato riconosciuto effettivamente
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Wed Jun 13, 2007 10:59 am    Post subject: Reply with quote

jiojio74 wrote:
Un bel:
Code:
# lsusb

dovrebbe darti un primo segno che il disco sia stato riconosciuto effettivamente


Questo è l'output:

Code:

# lsusb
Bus 001 Device 001: ID 0000:0000


L'avevo già lanciato.. non l'ho trovato molto utile però.. :(
Back to top
View user's profile Send private message
jiojio74
n00b
n00b


Joined: 12 Jan 2007
Posts: 24

PostPosted: Wed Jun 13, 2007 11:13 am    Post subject: Reply with quote

Dalla guida in inglese:
Code:
ls -l /dev/disk/by-id/usb*

Ti restituisce qualcosa?

Prova a guardare questa guida per vedere se hai tutto nel kernel: http://gentoo-wiki.com/HOWTO_USB_Mass_Storage_Device
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Wed Jun 13, 2007 12:36 pm    Post subject: Reply with quote

jiojio74 wrote:
Dalla guida in inglese:
Code:
ls -l /dev/disk/by-id/usb*

Ti restituisce qualcosa?

Prova a guardare questa guida per vedere se hai tutto nel kernel: http://gentoo-wiki.com/HOWTO_USB_Mass_Storage_Device


Si confermo che ho tutto...

Comunque non ho un /dev/disk/by-id/usb* :cry:

Code:


# ls /dev/disk/
by-path  by-uuid

# ls -l /dev/disk/by-path/
total 0
lrwxrwxrwx 1 root root 9 Jun 10 16:14 pci-0000:00:0f.1-ide-0:0 -> ../../hda

# ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 Jun 10 16:14 225e2ef0-66bd-44e6-b5af-0ec07b3e4416 -> ../../sda6
lrwxrwxrwx 1 root root 10 Jun 10 16:14 22744d6d-208e-455a-9a87-6f36c0f11249 -> ../../sda2
lrwxrwxrwx 1 root root 10 Jun 10 16:14 22d5569d-121f-4293-8e74-cfe3c242a7f8 -> ../../sda8
lrwxrwxrwx 1 root root 10 Jun 10 16:14 29f46732-b918-4ea4-9eab-985eae5dc3dd -> ../../sda1
lrwxrwxrwx 1 root root 10 Jun 10 16:14 8270f7cd-30ce-449d-962e-2cb60f39e91c -> ../../sda5
lrwxrwxrwx 1 root root 10 Jun 10 16:14 d72cd291-abb2-4660-a4e2-5dba19a567f6 -> ../../sda7



Faccio notare che le partizioni sda* sono del mio disco fisso scsi in raid e che hda è il lettore cd-rom
Back to top
View user's profile Send private message
jiojio74
n00b
n00b


Joined: 12 Jan 2007
Posts: 24

PostPosted: Wed Jun 13, 2007 2:19 pm    Post subject: Reply with quote

Con un bel:
Code:
# cat /proc/partitions
major minor  #blocks  name

   3     0   80418240 hda
   3     1    8233281 hda1
   3     2   72180045 hda2

Vedi qualcosa di diverso fra quando è attaccato e quando non lo è?

Cercando un pò in giro ho trovato questo in inglese... su questo stesso forum :)
https://forums.gentoo.org/viewtopic-p-4076609.html?sid=a1df1d8239f302080c40cd96577f216a

Quote:
Try removing device, unloading ehci and loading ohci and re-connect device. Worked for me.


scricare ehci e caricare ohci rinunciando a collegarlo alla velocità massima

leggendo più avanti:

Quote:
Generally, those errors are signs of compatibility problems. Maybe you could check the relevant parts of "lspci -v" and dmesg for unkown hardware versions/revisions.


Qui si ipotizza che sia un problema di compatibilità... ovvero: che sia il controller USB ad essere mal supportato

Postare qui un bel:
Code:
dmesg |grep USB

ed un bel
Code:
lspci -v


Potrebbe far illuminare una lampadina a qualcuno

Anche una controllata che nel kernel sia compilato il modulo giusto per il controller usb sarebbe auspicabile
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Wed Jun 13, 2007 3:56 pm    Post subject: Reply with quote

jiojio74 wrote:
Con un bel:
Code:
# cat /proc/partitions
major minor  #blocks  name

   3     0   80418240 hda
   3     1    8233281 hda1
   3     2   72180045 hda2

Vedi qualcosa di diverso fra quando è attaccato e quando non lo è?

Cercando un pò in giro ho trovato questo in inglese... su questo stesso forum :)
https://forums.gentoo.org/viewtopic-p-4076609.html?sid=a1df1d8239f302080c40cd96577f216a

Quote:
Try removing device, unloading ehci and loading ohci and re-connect device. Worked for me.


scricare ehci e caricare ohci rinunciando a collegarlo alla velocità massima

leggendo più avanti:

Quote:
Generally, those errors are signs of compatibility problems. Maybe you could check the relevant parts of "lspci -v" and dmesg for unkown hardware versions/revisions.


Qui si ipotizza che sia un problema di compatibilità... ovvero: che sia il controller USB ad essere mal supportato

Postare qui un bel:
Code:
dmesg |grep USB

ed un bel
Code:
lspci -v


Potrebbe far illuminare una lampadina a qualcuno

Anche una controllata che nel kernel sia compilato il modulo giusto per il controller usb sarebbe auspicabile



Dunque nel kernel è tutto ok, oltretutto non ho compilato come moduli ma compilo sempre tutto statico...
Non ho potuto fare la prima prova che mi hai suggerito... La farò appena possibile.. di seguito posto gli output dei due comandi..

Code:

 # dmesg | grep USB
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd 0000:00:0f.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
USB Universal Host Controller Interface driver v3.0
Initializing USB Mass Storage driver...
usb 1-1: new full speed USB device using ohci_hcd and address 2
usb 1-1: new full speed USB device using ohci_hcd and address 3
usb 1-1: new full speed USB device using ohci_hcd and address 4
usb 1-1: new full speed USB device using ohci_hcd and address 5
USB Mass Storage support registered.
drivers/usb/input/hid-core.c: v2.6:USB HID core driver




Code:


 # lspci -v
00:00.0 Host bridge: Broadcom CNB20LE Host Bridge (rev 06)
        Flags: bus master, medium devsel, latency 96

00:00.1 Host bridge: Broadcom CNB20LE Host Bridge (rev 06)
        Flags: bus master, medium devsel, latency 96

00:01.0 VGA compatible controller: S3 Inc. Savage 4 (rev 04) (prog-if 00 [VGA])
        Subsystem: IBM Unknown device 7000
        Flags: bus master, medium devsel, latency 248, IRQ 255
        Memory at feb80000 (32-bit, non-prefetchable) [size=512K]
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        [virtual] Expansion ROM at 30000000 [disabled] [size=64K]
        Capabilities: [dc] Power Management version 1

00:02.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 08)
        Subsystem: IBM Netfinity 10/100
        Flags: bus master, medium devsel, latency 100, IRQ 16
        Memory at feb7f000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 2200 [size=64]
        Memory at fea00000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [dc] Power Management version 2

00:0a.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 08)
        Subsystem: IBM Netfinity 10/100
        Flags: bus master, medium devsel, latency 100, IRQ 17
        Memory at feb7e000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 2240 [size=64]
        Memory at fe900000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [dc] Power Management version 2

00:0f.0 ISA bridge: Broadcom OSB4 South Bridge (rev 50)
        Subsystem: Broadcom OSB4 South Bridge
        Flags: bus master, medium devsel, latency 0

00:0f.1 IDE interface: Broadcom OSB4 IDE Controller (prog-if 8a [Master SecP PriP])
        Flags: bus master, medium devsel, latency 64
        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
        I/O ports at 0700 [size=16]

00:0f.2 USB Controller: Broadcom OSB4/CSB5 OHCI USB Controller (rev 04) (prog-if 10 [OHCI])
        Subsystem: Broadcom OSB4/CSB5 OHCI USB Controller
        Flags: bus master, medium devsel, latency 96, IRQ 9
        Memory at feb7d000 (32-bit, non-prefetchable) [size=4K]

01:03.0 SCSI storage controller: Adaptec AIC-7892P U160/m (rev 02)
        Subsystem: Adaptec AIC-7892P U160/m
        Flags: bus master, 66MHz, medium devsel, latency 100, IRQ 18
        BIST result: 00
        I/O ports at 2300 [disabled] [size=256]
        Memory at effff000 (64-bit, non-prefetchable) [size=4K]
        [virtual] Expansion ROM at 30020000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2

01:05.0 RAID bus controller: IBM ServeRAID Controller
        Subsystem: IBM ServeRAID-4L
        Flags: bus master, medium devsel, latency 96, IRQ 19
        Memory at edffe000 (32-bit, prefetchable) [size=8K]
        [virtual] Expansion ROM at 30010000 [disabled] [size=32K]

Back to top
View user's profile Send private message
jiojio74
n00b
n00b


Joined: 12 Jan 2007
Posts: 24

PostPosted: Wed Jun 13, 2007 5:20 pm    Post subject: Reply with quote

Questo:
Code:
USB Controller: Broadcom OSB4/CSB5 OHCI USB Controller (rev 04) (prog-if 10 [OHCI])

è effettivamente il tuo controller?
Prova a bootare da un livecd e fare un bel
Code:
lspci -v
per vedere se coincide ed ad attaccare il disco. Già che ci sei anche un
Code:
lsmod
nel caso il disco funzioni
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Tue Jun 26, 2007 4:26 pm    Post subject: Reply with quote

Dunque, ho staccato l'hard disk, collegato ad un computer con windows per verificarne il funzionamento... Il disco è partizionato e già formattato dalla fabbrica con fat32.
Ho ricollegato il disco al server linux e lanciando un lsusb magicamente:

Code:
                           
Bus 001 Device 002: ID 059f:0a51 LaCie, Ltd
Bus 001 Device 001: ID 0000:0000 


Però non capisco ancora tramite cosa posso montarlo visto che non ho un sdX o un hdX adeguato in /dev/ ... Qualche idea?

grazie
ciao
Fede
Back to top
View user's profile Send private message
codadilupo
Advocate
Advocate


Joined: 05 Aug 2003
Posts: 3135

PostPosted: Tue Jun 26, 2007 4:55 pm    Post subject: Reply with quote

Code:
grep sg /var/message


aiuta :?:

Coda
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Tue Jun 26, 2007 8:14 pm    Post subject: Reply with quote

codadilupo wrote:
Code:
grep sg /var/message


aiuta :?:

Coda


A dire il vero no xchè non ho /var/message ... Però con un dmesg mi sono aiutato e ho visto che si chiama uba ...
Buono a sapersi.. Pensavo si potessero solo chiamare sdX

Grazie
Ciao
Fede
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Tue Jun 26, 2007 11:20 pm    Post subject: Reply with quote

iko wrote:
A dire il vero no xchè non ho /var/message

coda è un po' dislessico :D è /var/log/messages il posto giusto :D
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
iko
Apprentice
Apprentice


Joined: 10 Mar 2004
Posts: 232
Location: Lissone

PostPosted: Wed Jun 27, 2007 2:17 pm    Post subject: Reply with quote

.:deadhead:. wrote:
iko wrote:
A dire il vero no xchè non ho /var/message

coda è un po' dislessico :D è /var/log/messages il posto giusto :D


Ah ok.. infatti immaginavo! :lol: :lol:
Grazie mille a tutti
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Wed Nov 07, 2007 9:51 pm    Post subject: Reply with quote

Avevi risolto quindi? Ma avevi problemi solo con il Lacie (possibile prossimo acquisto/regalo) o anche con le pendrive?

Una domanda, ma di solito /dev/uba non si riferisce ad un dispositivo su porta USB lenta (immagino usb1.1)?

Andrea
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum