Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Quickcam messenger litiga con l'hub usb2
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Fri Nov 02, 2007 5:44 pm    Post subject: Quickcam messenger litiga con l'hub usb2 Reply with quote

Questa è una cosa strana..molto strana.
Ho una quickcam messenger. Installo il driver qc-usb-messenger, provo la webcam..ma nulla..schermata della cam nera (in amsn).
Faccio diversi tentativi, sia con awtv, sia combiando la versione del driver (c'è la 1.7 masked).
Nulla.
Ultimo stupido tentativo (su debian andava, deve andare anche qui!), stacco la cam dall'hub usb2.0 e la collego direttamente alla porta sul pc [TA-TAMMM] la webcam funziona 8O 8O 8O 8O

Secondo voi, il problema a cosa può essere legato? devo alimentare l'hub? (purtroppo non ricordo se su debian usassi o meno l'hub)

Ecco alcuni log:

dmesg:
Code:
usb 1-3.4: new full speed USB device using ehci_hcd and address 7
usb 1-3.4: configuration #1 chosen from 1 choice
quickcam: QuickCam USB camera found (driver version QuickCam Messenger/Communicate USB 1.7 $Date: 2007/09/02 00:00:00 $)
quickcam: Kernel:2.6.23-kamikaze5 bus:1 class:FF subclass:FF vendor:046D product:08F6
quickcam [36.608539]: poisoning qc in qc_usb_init
quickcam [36.611246]: E00A contains 08F6
quickcam: Sensor VV6450 detected
input: Quickcam snapshot button as /class/input/input13
quickcam [36.614625]: Quickcam snapshot button registered on usb-0000:00:1d.7-3.4/input0
quickcam: Registered device: /dev/video0
usb 2-1: new low speed USB device using uhci_hcd and address 4
usb 2-1: configuration #1 chosen from 1 choice
input: HID 062a:0000 as /class/input/input14
input: USB HID v1.10 Mouse [HID 062a:0000] on usb-0000:00:1d.0-1
quickcam [41.472164]: open users=1
quickcam [41.478402]: qc_sensor_init: call qc_sensor_setsize0 (324,248)
quickcam [41.478628]: set sensor=324x248 vwin=324x248
quickcam [41.480534]: failed qc_v4l_ioctl()=-515
quickcam [41.482079]: close users=0
quickcam [41.483172]: open users=1
quickcam [41.493882]: qc_sensor_init: call qc_sensor_setsize0 (324,248)
quickcam [41.494125]: set sensor=324x248 vwin=324x248
quickcam [41.496033]: failed qc_v4l_ioctl()=-515
quickcam [41.496075]: close users=0
quickcam [41.496535]: open users=1
quickcam [41.504998]: qc_sensor_init: call qc_sensor_setsize0 (324,248)
quickcam [41.505690]: set sensor=324x248 vwin=324x248
quickcam [41.507914]: failed qc_v4l_ioctl()=-515
quickcam [41.511846]: close users=0
quickcam [41.512599]: open users=1
quickcam [41.518991]: qc_sensor_init: call qc_sensor_setsize0 (324,248)
quickcam [41.519996]: set sensor=324x248 vwin=324x248
quickcam [41.522379]: failed qc_v4l_ioctl()=-515
quickcam [52.473381]: set sensor=162x124 vwin=160x120
quickcam [52.473418]: submit ISOC_URB 0 failed
quickcam [52.473421]: failed qc_isoc_init()=-28
quickcam: unable start isoc
quickcam [52.473436]: failed qc_capt_get()=-28
quickcam [52.473439]: failed qc_v4l_ioctl()=-28
quickcam [52.473608]: unsupported image format 15
quickcam [52.473615]: failed qc_v4l_ioctl()=-22
quickcam [52.473875]: unsupported image format 9
quickcam [52.473878]: failed qc_v4l_ioctl()=-22
quickcam [52.474147]: submit ISOC_URB 0 failed
quickcam [52.474150]: failed qc_isoc_init()=-28
quickcam: unable start isoc
quickcam [52.474153]: failed qc_capt_get()=-28
quickcam [52.474155]: failed qc_v4l_ioctl()=-28
quickcam [52.474277]: submit ISOC_URB 0 failed
quickcam [52.474280]: failed qc_isoc_init()=-28
quickcam: unable start isoc
quickcam [52.474283]: failed qc_capt_get()=-28
quickcam [52.474285]: failed qc_v4l_ioctl()=-28
quickcam [52.474403]: submit ISOC_URB 0 failed
quickcam [52.474406]: failed qc_isoc_init()=-28
quickcam: unable start isoc
quickcam [52.474409]: failed qc_capt_get()=-28
quickcam [52.474411]: failed qc_v4l_ioctl()=-28
quickcam [52.474883]: submit ISOC_URB 0 failed
quickcam [52.474886]: failed qc_isoc_init()=-28
quickcam: unable start isoc
quickcam [52.474889]: failed qc_capt_get()=-28
quickcam [52.474892]: failed qc_v4l_ioctl()=-28
quickcam [11.740376]: close users=0
quickcam [14.656313]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
quickcam [14.672300]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
quickcam [14.688294]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
quickcam [14.704296]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
quickcam [14.720289]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
quickcam [14.736285]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
quickcam [14.752281]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
quickcam [14.768276]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
quickcam [14.784273]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
quickcam [14.800178]: INT URB error status=-71 tb_length=1 act_length=0 interval=16 frame=-1 data=00
usb 1-3.4: USB disconnect, address 7
quickcam [14.803007]: poisoning qc in qc_usb_exit


xawtv
Code:
$ xawtv -c /dev/video0
This is xawtv-3.95, running on Linux/i686 (2.6.23-kamikaze5)
WARNING: v4l-conf is compiled without DGA support.
/dev/video0 [v4l]: no overlay support
v4l-conf had some trouble, trying to continue anyway
ioctl: VIDIOC_QUERYCAP(driver="";card="";bus_info="";version=0.0.0;capabilities=0x0 []): Unknown error 515
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion
ioctl: VIDIOCSYNC(int=0): No space left on device
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format=15): Invalid argument
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format=9): Invalid argument
ioctl: VIDIOCSYNC(int=0): No space left on device
ioctl: VIDIOCSYNC(int=0): No space left on device
ioctl: VIDIOCSYNC(int=0): No space left on device
ioctl: VIDIOCSYNC(int=0): No space left on device

l'errore 515 esce anche quando la cam funziona.

Che qualcuno mi illumini :lol: :lol: :lol: :lol: :lol:

//EDIT
forse era più adatto nel forum di discussione :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum