Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
errore compilazione gnome-panel-2.18.3[RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Thu Nov 01, 2007 10:24 am    Post subject: errore compilazione gnome-panel-2.18.3[RISOLTO] Reply with quote

ottengo questo errore nella ricompilazione di gnome-base/gnome-panel-2.18.3 propostami da un revdep-rebuild.
Preciso che uso KDE ma ho attiva la use gnome perchè utilizzo alcuni programmi che si appoggiano alle librerie di gnome.
Code:
/bin/sh ../../libtool --tag=CC --mode=link i686-pc-linux-gnu-gcc  -march=prescott -O2 -pipe -fomit-frame-pointer   -o testtray  fixedtip.o na-marshal.o na-tray.o na-tray-manager.o obox.o testtray.o -lSM -lICE  -lX11  -lXau -pthread -Wl,--export-dynamic -lgnome-desktop-2 -lgnomeui-2 -lSM -lICE -lstartup-notification-1 -lbonoboui-2 -lgnome-keyring -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lbonobo-2 -lbonobo-activation -lgnomevfs-2 -lglade-2.0 -lgtk-x11-2.0 -lxml2 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgmodule-2.0 -ldl -lgconf-2 -lORBit-2 -lgthread-2.0 -lrt -lgnome-menu -ldbus-glib-1 -ldbus-1 -lgobject-2.0 -lglib-2.0
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgnomeui-2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libSM.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libICE.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgnomevfs-2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgnome-keyring.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libglade-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libxml2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libbonoboui-2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgnomecanvas-2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgnome-2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libpopt.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libart_lgpl_2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libpangoft2-1.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgtk-x11-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgdk-x11-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libatk-1.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgdk_pixbuf-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libpangocairo-1.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libpango-1.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libcairo.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libbonobo-2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libbonobo-activation.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgconf-2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libORBit-2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgthread-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../..//libglib-2.0.la' seems to be moved
...............................................................................
P -MF .deps/libwnck_applet_la-wncklet.Tpo -c wncklet.c -o libwnck_applet_la-wncklet.o >/dev/null 2>&1
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.18.3/work/gnome-panel-2.18.3/applets/wncklet'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.18.3/work/gnome-panel-2.18.3/applets'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.18.3/work/gnome-panel-2.18.3'
make: *** [all] Error 2
 *
 * ERROR: gnome-base/gnome-panel-2.18.3 failed.
 * Call stack:
 *       ebuild.sh, line 1695:  Called dyn_compile
 *       ebuild.sh, line 1033:  Called qa_call 'src_compile'
 *       ebuild.sh, line   44:  Called src_compile
 *       ebuild.sh, line 1377:  Called gnome2_src_compile
 *   gnome2.eclass, line   71:  Called die
 * The specific snippet of code:
 *      emake || die "compile failure"
 *  The die message:
 *   compile failure
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/gnome-base/gnome-panel-2.18.3/temp/build.log'.

Come dovrei fare per risolvere il problema e portare a termine la compilazione?
Grazie
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)


Last edited by Tigerwalk on Tue Dec 04, 2007 9:11 am; edited 1 time in total
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Nov 21, 2007 10:58 am    Post subject: Reply with quote

Up :?
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
Flameeyes
Retired Dev
Retired Dev


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Wed Nov 21, 2007 11:45 am    Post subject: Reply with quote

L'errore non si vede nel messaggio, probabilmente perché usi -j2 o simili e quindi appare per ultimo l'output di un comando che non è fallito. Per quanto la sfilza di warnings possano confondere, non mi pare di vedere alcun errore in quella parte, quindi deve essere prima.
_________________
You want to know what I'm working on right now? Just follow my blog.
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Nov 21, 2007 12:03 pm    Post subject: Reply with quote

Flameeyes wrote:
L'errore non si vede nel messaggio, probabilmente perché usi -j2 o simili e quindi appare per ultimo l'output di un comando che non è fallito. Per quanto la sfilza di warnings possano confondere, non mi pare di vedere alcun errore in quella parte, quindi deve essere prima.


ok, ho messo tutto il log della compilazione su http://pastebin.ca/792428
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Nov 21, 2007 12:22 pm    Post subject: Reply with quote

ho dato solo uno sguardo veloce ma prova con fix_libtool_files.sh, riemergi libtool, controlla che non hai keeptemp nelle features(per sicurezza pialla /var/portage/tmp) e prova a riselezionare il compilatore con gcc-config/eselect compiler.

locales.gen come è configurato?

lo so che è un tantino ot ma
Flameeyes wrote:
probabilmente perché usi -j2 o simili e quindi appare per ultimo l'output di un comando che non è fallito
come ovviare?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:


Last edited by djinnZ on Wed Nov 21, 2007 12:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Wed Nov 21, 2007 12:30 pm    Post subject: Reply with quote

djinnZ wrote:
(per sicurezza pialla /var/portage/tmp)


/var/tmp/portage/
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Nov 21, 2007 12:49 pm    Post subject: Reply with quote

djinnZ wrote:
ho dato solo uno sguardo veloce ma prova con fix_libtool_files.sh, riemergi libtool, controlla che non hai keeptemp nelle features(per sicurezza pialla /var/portage/tmp) e prova a riselezionare il compilatore con gcc-config/eselect compiler.

locales.gen come è configurato?

lo so che è un tantino ot ma
Flameeyes wrote:
probabilmente perché usi -j2 o simili e quindi appare per ultimo l'output di un comando che non è fallito
come ovviare?


Code:
locale.gen
it_IT ISO-8859-1
it_IT UTF-8


Code:
FEATURES="buildpkg ccache parallel-fetch"

per fix_libtool_files.sh devo eseguire lo script e basta?

cancellato il contenuto di /var/tmp/portage/

EDIT:
Code:
gcc-config -l
 [1] i686-pc-linux-gnu-3.3.6
 [2] i686-pc-linux-gnu-4.1.2 *

_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Nov 21, 2007 1:38 pm    Post subject: Reply with quote

Tigerwalk wrote:
[1] i686-pc-linux-gnu-3.3.6


che te lo porti a fare ancora dietro? Installa libstc++-v3 e levalo, se proprio ti serve retrocompatibilità.

Se non crei le locales US (predefinite) e hai userlocale come flag (verificare, vado a memoria e sono artereosclertotico) alcuni generatori di documentazione portano rogna.

se lanci il comando ti esce l'help, in ogni caso basta che aggiungi la versione del gcc corrente.

Non ho letto con minuzia il log ma sono gli unici problemi che mi sono saltati all'occhio.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Wed Nov 21, 2007 7:56 pm    Post subject: Reply with quote

aggiornamento: ho messo il linguaggio nativo in locale.gen, aggiunta la flag nls nel make.conf, rimosse le gcc 3.3.6-r1, emerso libstdc++-v3-3.3.6, dato fix_libtool_files.sh,.

Code:
#locale -a
C
en_US
en_US.utf8
it_IT
POSIX


all'inizio della compilazione vedo qualcosa che si riferisce a perl ed al linguaggio di sistema
Code:
Emerging (1 of 1) gnome-base/gnome-panel-2.18.3 to /
 * Wiping /var/tmp/portage
 *   Umounting temporary portage compile dir [ /var/tmp/portage/gnome-base/gnome-panel-2.18.3 ]              [ ok ]
 *   Removing content of the local portage compile dir [ /var/tmp/portage/gnome-base/gnome-panel-2.18.3 ]    [ ok ]
 * now /var/tmp/portage it's spick and span!

 * gnome-panel-2.18.3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                [ ok ]
 * checking ebuild checksums ;-) ...                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                       [ ok ]
 * checking gnome-panel-2.18.3.tar.bz2 ;-) ...                                                               [ ok ]
 * Determine new optimal TMPFS value: [ 2534M ]
 * Mounting /var/tmp/portage/gnome-base/gnome-panel-2.18.3 of [ 2534M ] ...                                  [ ok ]
 * Please remember that ccache data dir is outside the newly mounted
 * portage temporary directory, to preserve the spool between merges.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "it_IT.UTF-8 en_US.UTF-8,",
        LC_ALL = "it_IT.UTF-8,",
        LANG = "it_IT.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
>>> cfg-update-1.8.2-r1: Skipping checksum index updating...

cos'altro devo fare?
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Nov 23, 2007 12:56 pm    Post subject: Reply with quote

hai lanciato il comando per generare le locali (non sono in ufficio e non me lo ricordo)?
la situazione è rimasta invariata o l'unica segnalazione rimasta è questa?
c'era un comando per fare un ripristino sui moduli perl...
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Fri Nov 23, 2007 5:44 pm    Post subject: Reply with quote

ho dato locale-gen.
La situazione è rimasta invariata. Quella parte che ho postato, non so perchè, non compare nel file di log.
Il comando per il ripristino dei moduli perl non lo conosco, provo a guardare le pagine di man. Se nel frattempo te lo ricordi, sarebbe cosa gradita se me lo indicassi.
Grazie
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Tue Dec 04, 2007 9:09 am    Post subject: Reply with quote

L'ultimo -uND world mi ha compilato la versione 2.20.1 di gnome-panel, senza errori. Ho controllato anche con revdep-rebuild ed è tutto o.k.
Metto risolto anche se non ho capito il motivo della mancata compilazione della versione 2.18.3.....
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum