Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] sistema "messo male" ?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sun Oct 28, 2007 9:39 pm    Post subject: [risolto] sistema "messo male" ? Reply with quote

Ciao. Ho notato che i programmi non partono più... nè xchat, nè terminal, etc etc... allora stupito, provo ad avviarli da un terminale già in esecuzione... e compaio degli errori

Code:

$ xchat
xchat: symbol lookup error: xchat: undefined symbol: g_once_init_enter_impl


allora provo con un revdep-rebuild ma esce un errore strano (e cmq, non risolve il problema)

Code:

# revdep-rebuild               
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... Nothing to rebuild

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

Dynamic linking on your system is consistent... All done.


Come potrei risolvere? Non posso neanche spegnere, dopo mi sa che non lo riaccendo più... cmq non partono più i programmi... :S


Last edited by lordalbert on Mon Oct 29, 2007 3:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Sun Oct 28, 2007 9:50 pm    Post subject: Reply with quote

sparo quasi a caso...prova a vedere che il link /usr/src/linux punti ai sorgenti del kernel corretti.
_________________
LP
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sun Oct 28, 2007 10:09 pm    Post subject: Reply with quote

si...

Code:

# ls -l /usr/src/linux
lrwxrwxrwx 1 root root 22 31 ago 15:19 /usr/src/linux -> linux-2.6.22-gentoo-r5
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sun Oct 28, 2007 10:25 pm    Post subject: Reply with quote

bah, ora sembra tutto sistemato... le varie applicazioni sembrano andare, xchat invece persisteva con lo stesso errore... ho provato a ricompilarlo, e ora va. :S Boh, meglio così :)
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sun Oct 28, 2007 10:26 pm    Post subject: Reply with quote

Prova a darci qualche aiutino altrimenti io compro una vocale :lol:

Per esempio hai per caso fatto un aggiornamento prima del casino ?
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sun Oct 28, 2007 10:39 pm    Post subject: Reply with quote

si, ho aggiornato il sistema. Ha aggiornato wine e qualche dipendenza (sua? non ricordo...)

cmq quello che non capisco è

Code:

Packages containing binaries and libraries broken by a package update
will be emerged
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sun Oct 28, 2007 10:52 pm    Post subject: Reply with quote

lordalbert wrote:
si, ho aggiornato il sistema. Ha aggiornato wine e qualche dipendenza (sua? non ricordo...)

cmq quello che non capisco è

Code:

Packages containing binaries and libraries broken by a package update
will be emerged

Mi pare che quello sia una scritta che appare sempre, avvisa semplicemente che "i pacchetti contenenti binari e le librerie rotte da un aggiornamento saranno emersi" (traduzione abbastanza libera) quindi non capisco cosa tu non capisca :?

La mia domanda sull'aggiornamento è relativa al fatto che ieri (almeno su amd64 non so su altre piattaforme) e stato messo stabile sys-apps/portage-2.1.3.16 e quindi avevo pensato ad un eventuale problema nell'aggiornamento o nel sistemare la configurazione con dispatch-conf (o etc-update).
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sun Oct 28, 2007 11:05 pm    Post subject: Reply with quote

si, ho aggiornato anche portage ieri. Ma i problemi non si sono presentati subito.
Cmq, come detto sopra, sembra essersi risolto :)
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Mon Oct 29, 2007 6:20 am    Post subject: Reply with quote

un altro problema brillantemente risolto :lol: (contento tu contenti tutti)
metti [risolto] nel titolo
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Mon Oct 29, 2007 3:10 pm    Post subject: Reply with quote

Kernel78 wrote:
(contento tu contenti tutti)


scusa ma non l'ho capita :)
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Mon Oct 29, 2007 4:11 pm    Post subject: Reply with quote

lordalbert wrote:
Kernel78 wrote:
(contento tu contenti tutti)


scusa ma non l'ho capita :)

Quando a me capita che un problema si risolva da solo mi impegno maggiormente a capire cosa sia successo mentre mi sembrava che tu fossi soddisfatto dal fatto che non si ripresentasse più (e il fatto che tu abbia messo il tag [risolto] sembrerebbe darmi ragione).

Da qui nasceva il mio :"contento tu, contenti tutti", ovvero se tu non lo consideri un problema il nostro aiuto non ti serve più e quindi possiamo dedicarci ad altro.
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Mon Oct 29, 2007 7:02 pm    Post subject: Reply with quote

Beh, sicuramente capirne il motivo è senz'altro utile.... anche solo al fine didattico.... Anche se non credo di averne le conoscenze per capirlo...
Cmq, espongo la situazione :) :
Innanzitutto ho fatto un aggiornamento del sistema, ha aggiornato wine e qualche libreria, non ricordo più... Poi dopo un po' ho avviato xchat (da menu) e non partiva.... allora sempre da menu ho provato ad avviare il terminale ma non partiva neanche lui... Poi ho visto che avevo un terminale già aperto sull'altro dekstop, e provo ad avviare da li xchat, ed è comparso il messaggio che ho riportato precedentemente. Ho provato a dare un revdep-rebuild ma non ha ricompilato nulla (ho postato il log sopra). Alla fine ho provato ricompilando xchat (era l'unico che continuava a dare problemi) e ora che è stato ricompilato, funziona correttamente.
Io non saprei da dove iniziare per capire il problema...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum