Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]Usare www-client/seamonkey-bin
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
silvius
Guru
Guru


Joined: 16 May 2006
Posts: 364

PostPosted: Wed Oct 24, 2007 11:15 am    Post subject: [RISOLTO]Usare www-client/seamonkey-bin Reply with quote

Ho sempre avuto installato:
Code:

www-client/seamonkey


Ora vorrei utilizzare il
Code:

www-client/seamonkey-bin


ho fatto :
Code:

emerge -C www-client/seamonkey
emerge --oneshot www-client/seamonkey-bin


Ma al successivo :

Code:
emerge -uDNpv world


mi richiede
Code:

www-client/seamonkey


Come posso fare ?

Devo cambiare le dipendenze in qualche ebuild ? o togliere qualche use da make.conf ?


EDIT:

le mie USE:

Code:
USE=" mplayer amuled mplayerplug-in nptl nptlonly -ipv6 firefox xcomposite -doc -apm lm_sensors gtk -gnome nvidia samba pcmcia kde qt dvd alsa cdr mozilla java nsplugin browserplugin userlocales usb dvdr win32codecs real win32codecs hal ldap v4l xml v4l2 X pdf glitz dell unicode"



Saluto


Last edited by silvius on Sun Oct 28, 2007 4:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Wed Oct 24, 2007 11:18 am    Post subject: Reply with quote

controlla chi richiede il pacchetto con
Code:
emerge -uNDpvt world

_________________
LP
Back to top
View user's profile Send private message
silvius
Guru
Guru


Joined: 16 May 2006
Posts: 364

PostPosted: Wed Oct 24, 2007 11:28 am    Post subject: Reply with quote

Code:
emerge -uDNptv world

These are the packages that would be merged, in reverse order:

Calculating world dependencies... done!
[nomerge      ] kde-base/kdebase-startkde-3.5.7  USE="arts -debug -kdeenablefinal -xinerama" [?]
[nomerge      ]  kde-base/kreadconfig-3.5.6  USE="arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" [?]
[nomerge      ]   x11-libs/qt-3.3.8-r4  USE="cups gif opengl -debug -doc -examples -firebird -immqt -immqt-bc -ipv6 -mysql -nas -nis -odbc -pertty -postgres -qt-copy -sqlite -xinerama" [1]
[ebuild     U ]    net-print/cups-1.2.12-r1 [1.2.10-r1] USE="X dbus jpeg ldap nls pam png samba ssl tiff -php -ppds -slp" 0 kB
[nomerge      ] dev-util/eclipse-sdk-3.2  USE="opengl -cairo -gnome -no-seamonkey" [?]
[ebuild  N    ]  www-client/seamonkey-1.1.5  USE="crypt java ldap -debug -gnome -ipv6 -mozdevelop -moznocompose -moznoirc -moznomail -moznopango -moznoroaming -postgres -xforms -xinerama -xprint" 0 kB
[nomerge      ] net-www/mplayerplug-in-3.45  USE="gtk nls quicktime -divx -gmedia (-mplayer-bin) -realmedia -wmp" LINGUAS="it -da -de -en_US -es -fr -hu -ja -ko -nb -nl -pl -pt_BR -ru -se -zh_CN"
[ebuild  N    ]  www-client/mozilla-firefox-2.0.0.8  USE="java -bindist -debug -filepicker -gnome -ipv6 -mozdevelop -moznopango -restrict-javascript -xforms -xinerama -xprint" LINGUAS="it -af -ar -be -bg -ca -cs -da -de -el -en_GB -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -zh -zh_CN -zh_TW" 36,606 kB

Total: 3 packages (1 upgrade, 2 new), Size of downloads: 36,606 kB


C'è mplayer che mi richiede anche firefox NON -bin......che faccio qui ? Tolgo la USE firefox ?
Mentre eclipse mi richiede seamonkey...come è corretto procedere in questi casi ?


Saluto
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Wed Oct 24, 2007 1:14 pm    Post subject: Reply with quote

basta che attivi la use xulrunner e levi le use firefox e seamonkey. Inoltre ti richiedera' l'installazione del pacchetto xulrunner al posto di firefox o seamonkey. Tutto questo e' inevitabile perche' alcuni programmi che si appoggiano a gecko (motore di rendering di firefox e mozilla e altri) hanno bisogno delle sue librerie per compilarsi correttamente. Con il mio metodo eviti di avere 400 browser sparsi in giro per il sistema anche se poi fondamentalmente cambia poco o nulla.
Back to top
View user's profile Send private message
dark_knight
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2006
Posts: 112

PostPosted: Thu Oct 25, 2007 11:56 am    Post subject: Reply with quote

Secondo me c'è anche un altro problema. La versione di Eclipse che usi (dev-util/eclipse-sdk-3.2) è un pochino vecchiotta, ed è stata rimossa da portage il 25 aprile di quest'anno. Quella versione dell'ebuild utilizzava una USE dalla semantica opposta (cioè dovevi aggiungere "no-seamonkey" alle flags per rompere la dipendenza con quest'ultimo). Il suggerimento di MeMyselfAndI (cioè togliere esplicitamente le use "firefox" e "seamonkey") sortirà il suo effetto solo se aggiornerai all'ultima versione stabile di Eclipse (eclipse-sdk-3.2.1-r2 su tutte le architetture).
Altrimenti, se per qualche motivo vuoi rimanere con la versione vecchia, aggiungi anche "no-seamonkey" alle tue USE.
_________________
You can say that you are a true Gentoo-addicted when you type emerge --update --deep --newuse happiness.
Back to top
View user's profile Send private message
silvius
Guru
Guru


Joined: 16 May 2006
Posts: 364

PostPosted: Thu Oct 25, 2007 2:02 pm    Post subject: Reply with quote

Stavo provando adesso, solo che attualmente :
Code:

emerge -uDNpvt world

These are the packages that would be merged, in reverse order:

Calculating world dependencies... done!
[ebuild     U ] dev-util/eclipse-sdk-3.2.1-r2 [3.2] USE="cairo* opengl -branding% -gnome -seamonkey% (-no-seamonkey%)" 80,586 kB
[nomerge      ] net-www/mplayerplug-in-3.45  USE="gtk nls quicktime -divx -gmedia (-mplayer-bin) -realmedia -wmp" LINGUAS="it -da -de -en_US -es -fr -hu -ja -ko -nb -nl -pl -pt_BR -ru -se -zh_CN"
[ebuild  N    ]  www-client/mozilla-firefox-2.0.0.8  USE="java -bindist -debug -filepicker -gnome -ipv6 -mozdevelop -moznopango -restrict-javascript -xforms -xinerama -xprint" LINGUAS="it -af -ar -be -bg -ca -cs -da -de -el -en_GB -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -zh -zh_CN -zh_TW" 36,606 kB
[nomerge      ] x11-base/xorg-server-1.3.0.0-r1  USE="dri nptl sdl xorg -3dfx -debug -dmx -ipv6 -kdrive -minimal -xprint" INPUT_DEVICES="evdev keyboard mouse penmount synaptics -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -spaceorb -summa -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="nv nvidia vesa -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx -glint -i128 -i740 -i810 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nsc -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vga -via -vmware -voodoo"
[nomerge      ]  x11-apps/xinit-1.0.4  USE="-debug -minimal" [?]
[nomerge      ]   x11-apps/xsm-1.0.1  USE="-debug -xprint" [?]
[nomerge      ]    net-misc/netkit-rsh-0.17-r8  USE="pam" [?]
[ebuild     U ]     sys-libs/pam-0.99.8.1-r1 [0.78-r5] USE="cracklib%* nls%* -audit% (-selinux) -vim-syntax% (-berkdb%*) (-nis%) (-pam_chroot%) (-pam_console%) (-pam_timestamp%) (-pwdb%)" 886 kB
[ebuild     U ] dev-lang/python-2.4.4-r6 [2.4.4-r5] USE="berkdb gdbm ncurses readline ssl -bootstrap -build -doc -examples -ipv6 -nocxx -nothreads -tk -ucs2" 7,977 kB
[ebuild     U ] sys-apps/sandbox-1.2.18.1-r1 [1.2.17] 232 kB



c'è "mplayerplug" che vuole installare firefox, anche se io ho attualmente installato firefox-bin..............cheh fare ??

Saluto
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Thu Oct 25, 2007 3:57 pm    Post subject: Reply with quote

guarda che ti ho gia' risposto -> DEVI installare uno tra firefox seamonkey o xulrunner e sistemare le tue useflag.
Back to top
View user's profile Send private message
silvius
Guru
Guru


Joined: 16 May 2006
Posts: 364

PostPosted: Thu Oct 25, 2007 4:27 pm    Post subject: Reply with quote

Grazie, ma non ho capito.....ma usare seamonkey-bin invece di seamonkey è impossibile ?


Saluto
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Thu Oct 25, 2007 9:16 pm    Post subject: Reply with quote

certi programmi (yelp o mplayerplug-in ad esempio) hanno bisogno dei sorgenti del motore di rendering gecko per compilare. Questi sorgenti sono forniti da uno tra
a) firefox
b) seamonkey
c) xulrunner

E' chiaro, a questo punto, che uno dei tre lo devi avere installato. Quindi se vuoi seamonkey-bin ti devi cuccare xulrunner. Quindi aggiusta di conseguenza le USE e
Code:
# emerge -DuNav world


L'introduzione della possibilità c, cioè xulrunner, è relativamente recente in portage quindi non tutti gli ebuild del ramo stabile potrebbero essere aggiornati di conseguenza. Ergo se un certo pacchetto ( individuato tramite emerge -tDuNav world) ti richiede seamonkey o firefox la soluzione è cercare un workaround (o meglio un ebuild aggiornato) qui nel forum oppure in bugzilla.

Sono stato spiegato? :)
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
silvius
Guru
Guru


Joined: 16 May 2006
Posts: 364

PostPosted: Thu Oct 25, 2007 9:53 pm    Post subject: Reply with quote

ok, chiaro !!!!!
faccio delle prove e vi faccio sapere.


Saluto
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum