Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errore Emerge su alcune pacchetti[RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Tue Oct 23, 2007 1:39 pm    Post subject: Errore Emerge su alcune pacchetti[RISOLTO] Reply with quote

Ciao, fra ieri è oggi mi è capitato in maniera corrente questo errore, vale a dire provando a installare domino e crystal come decoratori di finestre per kde, non riuscendoci sono andato su beryl per poter mettere emerald, non appena è arrivato a installare aquamarine, necessario per completare l'installazione di beryl mi rida il seguente errore e quindi non posso andare avanti, la cosa mi sta facendo innervosire...perchè non capisco che errore possa essere, capisco solo che potrebbe provenire da kdelibs o qt, ma non so come risolvere!!

If you did install kdelibs, then the Qt version that is picked up by
this configure is not the same version you used to compile kdelibs.
The Qt Plugin installed by kdelibs is *ONLY* loadable if it is the
_same Qt version_, compiled with the _same compiler_ and the same Qt
configuration settings.

Spero che qualcuno riesca a darmi una mano....
Ciao a tutti e grazie in anticipo.


Last edited by niugentoo on Tue Oct 23, 2007 3:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
!ico
Apprentice
Apprentice


Joined: 26 Oct 2005
Posts: 199
Location: Bassano del Grappa (VI)

PostPosted: Tue Oct 23, 2007 1:55 pm    Post subject: Reply with quote

Premetto che scrivere meglio oltre ad un progresso personale potrebbe portarti un maggior numero di risposte considerato che si capirebbe meglio il problema. :roll:

Secondo me basta ricompilare kdelibs, comunque posta prima il risultato di eix -I x11-libs/qt, magari con il Tag Code...

ola ;)
_________________
" I tasti iniziano. I tasti finiscono. Tu sai che sono 88; su questo nessuno può fregarti. Non sono infiniti loro. Tu, tu sei infinito, e dentro quei tasti, infinita è la musica che puoi fare. Loro sono 88. Tu sei infinito".
Novecento (Baricco)
Back to top
View user's profile Send private message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Tue Oct 23, 2007 3:52 pm    Post subject: Reply with quote

Credo di aver risolto riemergendo kdelibs...ma non capisco se l'ho reinstallato praticamente nello stesso modo perchè com'era prima non gli andava bene, perchè era installato!
Comunque grazie a tutti
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Oct 23, 2007 4:03 pm    Post subject: Reply with quote

perchè kde è basato su kdelibs che a sua volta è basato su qt che a sua volta è basato su libc e compagnia. Se aggiorni o compili con opzioni differenti qt devi ricompilare linkando le funzioni alla nuova libreria kdelibs.
Semplice.

Consiglio: Installa protage-utils e lancia revdep-rebuild (cerca gli errori di linking e ricompila i pacchetti "danneggiati" da un aggiornamento delle librerie su cui si appoggiano) dopo ogni aggiornamento la prossima volta.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum