Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Alcuni programmi non hanno la localizzazione italiana
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Sat Oct 20, 2007 8:45 pm    Post subject: Alcuni programmi non hanno la localizzazione italiana Reply with quote

Ho notato che alcuni programmi non presentano la localizzazione italiana, programmi che io anche sulla stessa sabayon mi pare li avevo in italiano, per fare un banale esempio sono sicuro che Kuroo era in italiano, qui invece è inglese e non ha la localizzazione italiana, un altro è gimp o vlc, altri non mi vengono in mente, ma questi intanto bastano....
Spero qualcuno abbia la soluzione, sai mi piacerebbe averli in italiano
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Sat Oct 20, 2007 8:55 pm    Post subject: Reply with quote

http://www.gentoo.org/doc/it/guide-localization.xml
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Sat Oct 20, 2007 9:02 pm    Post subject: Reply with quote

Quella guida l'ho seguita e ho quindi il sistema in italiano come la maggior parte dei programmi, sopratutto kde, ma io parlo di alcuni, in particolare per farti un esempio k3b ha come variabile use LINGUAS_IT, ma io ho impostato LINUGAS="it" nel make.conf, e quindi k3b lo ha compilato in italiano perchè ha trovato quella direttiva nel make.conf, ma gimp per esempio non ha questa flag, quindi non ha proprio la localizzazione italiana, e neanche kuroo, ma questi programmi mi ricordo che in sabayon erano già installati e in italiano, kuroo no, ma quando l'avevo installato era in italiano! Io il sistema l'ho localizzato in italiano!
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Sat Oct 20, 2007 9:14 pm    Post subject: Reply with quote

potrebbe essere un problema di versione dei pacchetti installati. Io ad es. ho compilato kuroo-0.81_rc1 ed è in inglese; gimp-2.2.17 ed è in italiano. Alcune versioni possono non essere disponibili in tutte le lingue.
_________________
Linux user N°447789
Carpe diem (quam minimum credula postero) -Orazio (I,11)
Back to top
View user's profile Send private message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Sat Oct 20, 2007 9:22 pm    Post subject: Reply with quote

Ma io l'ultima versione di kuroo mi ricordo che su sabayon ce l'avevo in italiano se non sbaglio...è anche vero che sabayon aveva già tutto messo e installato e bello che pronto...e kuroo lo avevo installato dopo....però la versione era la stessa, io il sistema ce l'ho italiano! Pure vlc sia la versione 0.86 che la 0.90 sempre inglese...su vlc devo dire installarlo una fatica pazzesca...quando mi dimentico la flag skin o wxwidget, è un casino, ma questo va fuori argomento! :)
Back to top
View user's profile Send private message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Sun Oct 21, 2007 9:56 am    Post subject: Reply with quote

Siamo sempre lì ... come nell'altro 3D .... sei sicuro di avere eseguito tutto alla lettera?

P.S. non te la prendere ma i tuoi sono problemi di impazienza ..... le guide vanno lette bene ed altrettanto bene vanno eseguiti i passaggi ...Gimp e VLC hanno la localizzazione in italiano, quindi se li hai emersi e sono in inglese, hai qualche file di configurazione settato male

In quanto a Kuroo ... usa il terminale ... è moooolto meglio :wink:
Back to top
View user's profile Send private message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Sun Oct 21, 2007 10:22 am    Post subject: Reply with quote

Io ho controllato le use flag che ha per esempio open office con quella di gimp, gimp non ha la use flag LINGUAS_IT e openoffice si, di fatto openoffice è in italiano e gimp no, tutto kde anche è in italiano, ho seguito la guida!
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Sun Oct 21, 2007 5:50 pm    Post subject: Reply with quote

Una cosa che vorrei io invece, sarebbe sudo in italiano... per esempio,
Code:
nano
è in italiano, mentre
Code:
sudo nano
no!
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sun Oct 21, 2007 6:08 pm    Post subject: Reply with quote

Io ho gimp in italiano quindi sono pronto a scommettere soldi che tu hai sbagliato qualche configurazione ...
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Sun Oct 21, 2007 6:27 pm    Post subject: Reply with quote

Tu che hai gimp in italiano per caso hai pure installato gnome? E magari anche in italiano? E che versione hai di gimp? io ho la 2.4.0-r2...
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Sun Oct 21, 2007 6:35 pm    Post subject: Reply with quote

niugentoo wrote:
Tu che hai gimp in italiano per caso hai pure installato gnome? E magari anche in italiano? E che versione hai di gimp? io ho la 2.4.0-r2...

2.2.17 è in italiano ed è l'ultima versione stable...
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Sun Oct 21, 2007 7:23 pm    Post subject: Reply with quote

Si ma fammi capire, non c'entra niente che i pacchetti che hanno le flag LINGUAS_IT hanno la localizzazione italiana e gli altri non sempre?
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sun Oct 21, 2007 9:15 pm    Post subject: Reply with quote

1) gnome lo evito da anni e quindi non posso aiutarti
2) gimp, ultima versione stabile
3) ovviamente un pacchetto deve essere stato tradotto in italiano, se ha LINGUAS_IT hai l'esplicita certezza, in tutti gli altri casi non puoi saperlo a priori limitandoti a guardare le USE e questi pacchetti utilizzano le variabili LANG o LC_ALL (di default sono per la lingua inglese)
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Sun Oct 21, 2007 9:31 pm    Post subject: Reply with quote

Quindi in poche parole cosa dovrei fare? Dichiarare nel sistema LANG="it" e ricompilarlo?
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sun Oct 21, 2007 10:07 pm    Post subject: Reply with quote

niugentoo wrote:
Quindi in poche parole cosa dovrei fare? Dichiarare nel sistema LANG="it" e ricompilarlo?

Visto che dici di aver già seguito la guida ti elenco le possibilità che vedo io:
- hai seguito pedissequamente la guida e ti si verificano queste anomali, si tratta quindi di un bug o di un'errata documentazione, segnalalo su bugs.gentoo.org
- hai letto solo una parte della guida o non l'hai letta per niente, seguila come se fosse la bibbia (se sei cristiano, altrimenti seguila come se fosse il testo sacro che preferisci) e se si verificano ancora problemi sono bug o errori nella documentazione, segnalalo su bugs.gentoo.org

Spero di non aver usato un tono troppo fastidioso ma se tu avessi seguito la guida avresti anche letto
Quote:
Tutte le variabili accettano valori secondo il formato specificato più su: (ab_CD).
forse sono soltanto malfidente o stanco ma ho l'impressione che tu non padroneggi molto bene i concetti espressi in quella guida ...
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Mon Oct 22, 2007 12:48 pm    Post subject: Reply with quote

Riproverò...a me sembrava di aver fatto tutto, può anche essere semplicemente il fatto che la versione testing non è in italiano...boh..quando risolvo vi farò sapere....e qualcuno di voi a invece vlc o kuroo in italiano? Perchè abbiamo scoperto che gimp, almeno quella versione è in italiano, e io non lo ho, cercherò di risolverlo, pure se non mi cambia la vita, e vlc e kuroo invece qualcuno di voi lo ha in italiano o sono standard in inglese?
Grazie comunque...
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Mon Oct 22, 2007 12:54 pm    Post subject: Reply with quote

OT
Non vorrei impicciarmi troppo nei fatti tuoi ma non ti converrebbe utilizzare gentoo stabile prima di buttarti su quella testing ? almeno fino a quando non prendi confidenza con il sistema, altrimenti va a finire che ti continui a scontrare con noie, problemi e bug ...
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Mon Oct 22, 2007 12:58 pm    Post subject: Reply with quote

Io ho VLC in italiano :wink: ...

... scusa la curiosità ... ma tu hai installato tutto con la flag ACCEPT_KEYWORDS="~x86"?

... altra curiosità .... lanciando il comando
Code:
env | grep -i LC_

cosa ti dice?
Back to top
View user's profile Send private message
niugentoo
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2007
Posts: 95

PostPosted: Mon Oct 22, 2007 1:12 pm    Post subject: Reply with quote

Lanciando quel comando non mi viene niente...
Back to top
View user's profile Send private message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Mon Oct 22, 2007 1:19 pm    Post subject: Reply with quote

niugentoo wrote:
Lanciando quel comando non mi viene niente...


Questo vuol dire che il tuo sistema non è localizzato al meglio ...

Ecco quello che fa per te .... CLICCK
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum