Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] etqw-demo alsa buffer problem, Quake Wars
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
BadSquishy
n00b
n00b


Joined: 17 Jun 2005
Posts: 44
Location: Northern California

PostPosted: Tue Oct 16, 2007 2:37 pm    Post subject: [SOLVED] etqw-demo alsa buffer problem, Quake Wars Reply with quote

Enemy Territory: Quake Wars demo is out and unfortunately, when I run it, I have no sound. When I run the demo from the command line I see the following in the output:
Code:
------ Alsa Sound Initialization -----
dlopen(libasound.so.2)
asoundlib version: 1.0.14a
opened Alsa PCM device default for playback
buffer size select failed: Invalid argument
close pcm
dlclose
WARNING: sound subsystem disabled

--------------------------------------
----------- Alsa Shutdown ------------

I ran equery and found I do not have the alsa-drivers package installed, so I 'm using the in-kernel alsa. So far it has worked for the first Enemy Territory, UT2004, Doom3, Quake4 and many other games. Maybe I need to increase the buffer size? Any suggestions?
_________________
- BadSquishy


Last edited by BadSquishy on Wed Oct 17, 2007 6:05 am; edited 1 time in total
Back to top
View user's profile Send private message
whig
l33t
l33t


Joined: 27 Nov 2004
Posts: 970
Location: New Zealand

PostPosted: Tue Oct 16, 2007 8:05 pm    Post subject: Reply with quote

I don't have alsa-drivers either (using kernel alsa), see below, but sound is good here. Slightly different asoundlib/alsa-lib version though.
Code:
------ Alsa Sound Initialization -----
dlopen(libasound.so.2)
asoundlib version: 1.0.15rc2
opened Alsa PCM device default for playback
device buffer size: 5461 frames ( 21844 bytes )
allocated a mix buffer of 16384 bytes

 ~ $ epm -qa | grep alsa
alsa-lib-1.0.15_rc2
alsa-headers-1.0.14
alsa-utils-1.0.15_rc1
gst-plugins-alsa-0.10.14
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1882
Location: Germany

PostPosted: Tue Oct 16, 2007 8:35 pm    Post subject: Reply with quote

JUST FOR THE BOOKS:

Code:
------ Alsa Sound Initialization -----
dlopen(libasound.so.2)
asoundlib version: 1.0.14a
opened Alsa PCM device default for playback
device buffer size: 5461 frames ( 21844 bytes )
allocated a mix buffer of 16384 bytes


The Sound Initialization works fine here. But when i am start the game, its awful!

Then i got tons of Error-Messages in the back:

Code:
idAudioHardwareALSA::Write: 39 frames overflowed and dropped
idAudioHardwareALSA::Write: 39 frames overflowed and dropped
idAudioHardwareALSA::Write: 13 frames overflowed and dropped


I use an Build-in Kernel too. Nothing with alsa-drivers or Compiled as module.

My feelings say, here its a universal Issue..
Back to top
View user's profile Send private message
-=GGW=- $ol!d $n4>|e
Veteran
Veteran


Joined: 12 Apr 2004
Posts: 1607
Location: USA

PostPosted: Wed Oct 17, 2007 3:31 am    Post subject: Reply with quote

sound is choppy at start as well for me, in both linux and windows, i think its the game loading other things in the background.
Back to top
View user's profile Send private message
BadSquishy
n00b
n00b


Joined: 17 Jun 2005
Posts: 44
Location: Northern California

PostPosted: Wed Oct 17, 2007 4:12 am    Post subject: Reply with quote

Just to see if Whig's situation would work for me as well, I've added alsa-lib and alsa-utils to /etc/portage/package.keywords and updated my system. Unfortunately I still get the error.
Code:
------ Alsa Sound Initialization -----
dlopen(libasound.so.2)
asoundlib version: 1.0.15rc2
opened Alsa PCM device default for playback
buffer size select failed: Invalid argument
close pcm
dlclose
WARNING: sound subsystem disabled

--------------------------------------
----------- Alsa Shutdown ------------

$ equery l alsa
[ Searching for package 'alsa' in all categories among: ]
 * installed packages
[I--] [ ~] media-libs/alsa-lib-1.0.15_rc2 (0)
[I--] [M ] media-plugins/gst-plugins-alsa-0.8.11 (0.8)
[I--] [  ] media-plugins/gst-plugins-alsa-0.10.14 (0.10)
[I--] [  ] media-sound/alsa-headers-1.0.14 (0)
[I--] [ ~] media-sound/alsa-utils-1.0.15_rc1 (0.9)


I don't know why equery shows multiple versions of gst-plugins-alsa, but I am sure that all of the gst plug-ins could be completely broken and it wouldn't affect alsa or the game.

So, what other possibilities are there? Is there a way to change the size of the buffer to match the argument? Is there a way to change the argument to match the appropriate buffer size? I found a text file, ~/.etqw/base/etwqconfig.cfg Here is the sound config section:
Code:
seta s_decompressionLimit "6"
seta s_libOpenAL "libopenal.so.0"
seta s_driver "alsa"
seta s_dsp "/dev/dsp"
seta s_alsa_lib "libasound.so.2"
seta s_alsa_pcm "default"
seta s_maxLowPrioritySounds "8"
seta s_useAdpcmCompression "1"
seta s_numberOfSpeakers "2"
seta s_globalFraction "0.8"
seta s_subFraction "0.75"
seta s_playDefaultSound "1"
seta s_voipVolumeOut_dB "0"
seta s_voipVolumeIn_dB "0"
seta s_volume_dB "0"
seta s_meterTopTime "2000"
seta s_reverse "0"
seta s_spatializationDecay "2"
seta s_maxSoundsPerShader "3"

Unfortunately there's no straightforward s_alsaBufferSize variable. Any guess what s_decompressionLimit is? I think I'll try setting s_maxLowPrioritySounds to 4, fewer sounds should require less buffer, but that doesn't mean it won't still ask for the usual size and fail.

Come to think of it, before I do that I'll see what settings I can change in-game, since much of these text file settings come from the option menu, and I'll only change the text file directly if that doesn't work first.

Any suggestions would be greatly appreciated.
Regards,
_________________
- BadSquishy
Back to top
View user's profile Send private message
BadSquishy
n00b
n00b


Joined: 17 Jun 2005
Posts: 44
Location: Northern California

PostPosted: Wed Oct 17, 2007 6:03 am    Post subject: [SOLVED] etqw-demo alsa buffer problem, Quake Wars Reply with quote

Figured out the fix from a couple of posts I found on the Ubuntu forums. First thread and Second thread. I figured if you can use a ~/.asoundrc file there must be a system wide file in /etc as well. Found /etc/asound.conf
I found out first-hand that you can get strange results if you modify this file before running
Code:
# /etc/init.d/alsasound stop
Once you've stopped alsa, change the line
Quote:
buffer_size 4096}
to
Quote:
buffer_size 16384}
Setting the size to 8192 also works, but a small jump to 5120 does not. After modifying the file restart the service with
Code:
/etc/init.d/alsasound start
and away you play, with sound.

Regards,
_________________
- BadSquishy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum