Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage-2.0.5 through 2.0.7 Semi-Broken
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Dolio
l33t
l33t


Joined: 17 Jun 2002
Posts: 650

PostPosted: Thu Jun 27, 2002 11:49 pm    Post subject: 2.0.8 Reply with quote

Portage 2.0.8 seems just as fast as 2.0.4, and emerge -pu world seems to work again.

However, when I do emerge -pe world, I get the following error:


Calculating world dependencies -Traceback (most recent call last):
File "/usr/bin/emerge", line 1227, in ?
if not mydepgraph.syscreate(getworldlist()):
File "/usr/bin/emerge", line 523, in syscreate
if not self.create(self.match(myline,mykey="syscreate1")):
File "/usr/bin/emerge", line 466, in create
if not self.create(mynew,mybigkey):
File "/usr/bin/emerge", line 466, in create
if not self.create(mynew,mybigkey):
File "/usr/bin/emerge", line 410, in create
edepend=portage.db[myroot]["porttree"].dbapi.aux_get(mykey,portage.auxdbkeys)
File "/usr/lib/python2.2/site-packages/portage.py", line 2565, in aux_get
self.auxcache[mycpv][auxdbkeys[x]]=mylines[x][:-1]
IndexError: list index out of range


Anyone else have this problem?

Edit: seems anything with the -e option causes that error for me. I've rsynced several times to see if that helped, but it hasn't.

PS: it seems you can pretend to emerge while not the root user in this version. Seems like a great feature to me. Thanks.
_________________
They don't have a good bathroom to do coke in.
Back to top
View user's profile Send private message
daos
n00b
n00b


Joined: 18 Apr 2002
Posts: 50
Location: Virginia, USA

PostPosted: Fri Jun 28, 2002 12:17 am    Post subject: Reply with quote

I still don't know why the portage 2.0.5 and later version no longer display the receiving file list. With the number shown in the receiving file list, at least I know, the "emerge sync" command is working and not hanging. Quite a few times, when I notice that "emerge sync" connect to a mirror site in Venezuala, it's progressing so slow that I kill the process with ctrl-c and then do "emerge sync" again. After this, it connects to a different site next time and the process is quick again.
Back to top
View user's profile Send private message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 287

PostPosted: Fri Jun 28, 2002 2:29 am    Post subject: Reply with quote

Bug filed.
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Fri Jun 28, 2002 2:48 am    Post subject: Reply with quote

Yes it really makes sense to have the ability to do all things in portage except actually emerge or unmerge.
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
Mnemia
Guru
Guru


Joined: 17 May 2002
Posts: 476

PostPosted: Fri Jun 28, 2002 5:10 am    Post subject: Reply with quote

Hmm, 2.0.8 still doesn't work for me...I've yet to get any portage higher than 2.0.4 to work correctly. 2.0.8 now works correctly with emerge -s, and it is fast again, but portage crashes with python errors whenever I do an emerge -pu world or (it seems) emerge -pu gnome.
I haven't found any other packages it fails for but then again I couldn't think of anything else to try that would require a lot of dependencies I don't have installed... (my kde is up to date).

Here's the output:
Code:

oowah pkg # emerge -pu world

These are the packages that I would merge, in order.

Calculating world dependencies -Traceback (most recent call last):
  File "/usr/bin/emerge", line 1227, in ?
    if not mydepgraph.syscreate(getworldlist()):
  File "/usr/bin/emerge", line 513, in syscreate
    if not self.create(self.match(myline,mykey="update (likely old /var/db/pkg entry)")):
  File "/usr/bin/emerge", line 410, in create
    edepend=portage.db[myroot]["porttree"].dbapi.aux_get(mykey,portage.auxdbkeys)
  File "/usr/lib/python2.2/site-packages/portage.py", line 2565, in aux_get
    self.auxcache[mycpv][auxdbkeys[x]]=mylines[x][:-1]
IndexError: list index out of range


And for gnome:
Code:

oowah pkg # emerge -pu gnome

These are the packages that I would merge, in order.

Calculating dependencies /Traceback (most recent call last):
  File "/usr/bin/emerge", line 1259, in ?
    if not mydepgraph.create(mytype+" "+portage.root+" "+mykey,None,"--onlydeps" not in myopts):
  File "/usr/bin/emerge", line 466, in create
    if not self.create(mynew,mybigkey):
  File "/usr/bin/emerge", line 466, in create
    if not self.create(mynew,mybigkey):
  File "/usr/bin/emerge", line 410, in create
    edepend=portage.db[myroot]["porttree"].dbapi.aux_get(mykey,portage.auxdbkeys)
  File "/usr/lib/python2.2/site-packages/portage.py", line 2565, in aux_get
    self.auxcache[mycpv][auxdbkeys[x]]=mylines[x][:-1]
IndexError: list index out of range


Since I haven't seen too many complaints about 2.0.8 here from other people, could there be something else screwed up on my system?

BTW, 2.0.4 still works if I downgrade to it...
Back to top
View user's profile Send private message
Sivar
Apprentice
Apprentice


Joined: 25 May 2002
Posts: 266
Location: USA

PostPosted: Fri Jun 28, 2002 5:13 am    Post subject: Reply with quote

Perhaps I am just lucking, but I have been using Gentoo since the day 1.1a was released, have updated everything almost every day, and have never had a single problem with any version of portage.
_________________
The greatest deeds are still undone, the greatest songs are still unsung...
Back to top
View user's profile Send private message
Mnemia
Guru
Guru


Joined: 17 May 2002
Posts: 476

PostPosted: Fri Jun 28, 2002 5:20 am    Post subject: Reply with quote

Sivar wrote:
Perhaps I am just lucking, but I have been using Gentoo since the day 1.1a was released, have updated everything almost every day, and have never had a single problem with any version of portage.


I've been here since RC6, and I had never had a serious problem either until 2.0.5+...

Portage 2 was great up until then...I'm sure they'll work the kinks out soon.
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Fri Jun 28, 2002 6:13 am    Post subject: Reply with quote

Mnemia wrote:
Sivar wrote:
Perhaps I am just lucking, but I have been using Gentoo since the day 1.1a was released, have updated everything almost every day, and have never had a single problem with any version of portage.


I've been here since RC6, and I had never had a serious problem either until 2.0.5+...

Portage 2 was great up until then...I'm sure they'll work the kinks out soon.


Ditto, I did break 2.0.5 and that is only because it was causing problems but I fixed it and am still happily using 2.0.4.
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
CowMike
n00b
n00b


Joined: 16 May 2002
Posts: 52
Location: Ede, NL

PostPosted: Fri Jun 28, 2002 8:20 am    Post subject: Reply with quote

I have the same errors with portage 2.0.8, so I merged portage 2.0.4 and removed 2.0.8, and it's working again for me :)

Does portage unmerge the older package first? Or stays the old package on the system ? Example: update of irssi: now I see two different versions, but I'm using (of course) the latest one. Does the older version of irssi still exists on my system ?
Back to top
View user's profile Send private message
yogin
n00b
n00b


Joined: 15 Jun 2002
Posts: 6
Location: Bydgoszcz, Poland

PostPosted: Fri Jun 28, 2002 8:51 am    Post subject: Reply with quote

Just a few questions: I'm going to install gentoo soon (as soon as I buy 2nd hdd), but I'm a bit terrified by the previous messages. So:
- is emerge and packaging system so unstable, that I should be prepared for regular backup/reinstall?
- shouldn't it be better tested? It is obvious, that there are buggy packages and there will never be a bug-free distro as a whole. But emerge/ebuild is essential for the system, so special attention must be paid to it.
- is there a way to distinct stable and unstable emerge relases? I it possible to stick with the emerge packed in stage-3 tarball and upgrade to 2.x series only if it is safe?
I've been reading the forum for a few weeks (not having gentoo installed yet, due to lack of hdd space) and I think gentoo's philosophy is great (after almost 3 years I'm already tired RPM package-system). But, uhm..., if I'd have to reinstall gentoo every few weeks, I'd really reconsider installing it. Please, tell me it's not so bad :lol:
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Fri Jun 28, 2002 9:02 am    Post subject: Reply with quote

there has to break much more than portage to force someone into re-installing the system. actually there should be no need to ever re-install everything ;)
concerning the current portage problems: it seems like it's having problems with the meta-packages like world or system, and this maybe only combined with --pretend - if someone still has installed a 2.0.5 to 2.0.8 please try and post!

you can install anyway, just do an emerge -p system - take a look at the list and emerge all the packages exept for portage :) you can do this in one step by emerge packagea other onemore ... :)

* ElCondor pasa *
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Fri Jun 28, 2002 9:17 am    Post subject: Reply with quote

yogin wrote:
Just a few questions: I'm going to install gentoo soon (as soon as I buy 2nd hdd), but I'm a bit terrified by the previous messages. So:
- is emerge and packaging system so unstable, that I should be prepared for regular backup/reinstall?
- shouldn't it be better tested? It is obvious, that there are buggy packages and there will never be a bug-free distro as a whole. But emerge/ebuild is essential for the system, so special attention must be paid to it.
- is there a way to distinct stable and unstable emerge relases? I it possible to stick with the emerge packed in stage-3 tarball and upgrade to 2.x series only if it is safe?
I've been reading the forum for a few weeks (not having gentoo installed yet, due to lack of hdd space) and I think gentoo's philosophy is great (after almost 3 years I'm already tired RPM package-system). But, uhm..., if I'd have to reinstall gentoo every few weeks, I'd really reconsider installing it. Please, tell me it's not so bad :lol:


All versions up to 2.0.4 have been stable so far. You are always able to emerge a particular version (I'd suggest you upgrade just to this version and then wait until problems have sorted out) and beside that you don't have to upgrade the day the latest versions of portage comes out :-)
I broke my portage with the 2.0.7 version but could recover the 2.0.4 with my emergency rescue portage. So I think there is no need to reinstall the whole system.

You are right with testing! I didn't understand why the lastest 2.0.5 to 2.0.8 have been masked a while for testing...

Don't get confused by this thread. Although Gentoo is a bleeding edge distro, the ppl here in this thread are always trying to get a little bit closer to the edge.
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
daos
n00b
n00b


Joined: 18 Apr 2002
Posts: 50
Location: Virginia, USA

PostPosted: Fri Jun 28, 2002 11:07 am    Post subject: Reply with quote

The portage 2.0.4 seems like the most stable version of the 2.x before 2.0.5.
I wonder why the ebuild is gone if "emerge --clean rync". This version no longer exists. If someone would like to go back to this version after trying 2.0.5 or later, there is problem unless you use 'emerge -b " option.
Back to top
View user's profile Send private message
JefP@@
Apprentice
Apprentice


Joined: 09 May 2002
Posts: 179
Location: Belgium

PostPosted: Fri Jun 28, 2002 2:38 pm    Post subject: Reply with quote

well, upgraded to portage 2.0.8

emerge -p -u system works

emerge -p -u world :

Code:
These are the packages that I would merge, in order.

Calculating world dependencies /
!!! Error: couldn't find match for virtual/glu in x11-libs/qt-3.0.4.20020606-r1


portage seems faster though ...

Hope they sort this out quickly !
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Fri Jun 28, 2002 4:19 pm    Post subject: Reply with quote

CowMike wrote:
I have the same errors with portage 2.0.8, so I merged portage 2.0.4 and removed 2.0.8, and it's working again for me :)

Does portage unmerge the older package first? Or stays the old package on the system ? Example: update of irssi: now I see two different versions, but I'm using (of course) the latest one. Does the older version of irssi still exists on my system ?


Try:

Code:

emerge -p --clean

_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
strife
n00b
n00b


Joined: 14 Jun 2002
Posts: 22

PostPosted: Sat Jun 29, 2002 12:41 am    Post subject: Still broken Reply with quote

I just did an emerge --update world which installed Portage 2.0.8 and when I did an emerge to install a package:

Calculating dependencies \Traceback (most recent call last):
File "/usr/bin/emerge", line 1259, in ?
if not mydepgraph.create(mytype+" "+portage.root+" "+mykey,None,"--onlydeps" not in myopts):
File "/usr/bin/emerge", line 410, in create
edepend=portage.db[myroot]["porttree"].dbapi.aux_get(mykey,portage.auxdbkeys)
File "/usr/lib/python2.2/site-packages/portage.py", line 2565, in aux_get
self.auxcache[mycpv][auxdbkeys[x]]=mylines[x][:-1]
IndexError: list index out of range
Back to top
View user's profile Send private message
akhkharu99
Apprentice
Apprentice


Joined: 08 Jun 2002
Posts: 162
Location: Gainesville, FL

PostPosted: Sat Jun 29, 2002 12:59 am    Post subject: Reply with quote

this all seems a bit strange to me, since i have used portage 2.0.8 since it was unmasked and i have never had a problem with it, or any other version of portage for that matter.
curious...
and elcondor is right. even if portage breaks, that will not cause you to have to reinstall everything.
Back to top
View user's profile Send private message
FINITE
Guru
Guru


Joined: 10 May 2002
Posts: 449

PostPosted: Sat Jun 29, 2002 1:16 am    Post subject: Reply with quote

I just updated to 2.0.4 and am unable to unmerge 1.9.11. After the update 1.9.11 cannot be found. Is this normal or do I have a problem? Thanks.
Back to top
View user's profile Send private message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 287

PostPosted: Sat Jun 29, 2002 1:23 am    Post subject: Reply with quote

akhkharu99 wrote:
this all seems a bit strange to me, since i have used portage 2.0.8 since it was unmasked and i have never had a problem with it, or any other version of portage for that matter.
curious...


Me niether, but I think we are the only two :lol:
Back to top
View user's profile Send private message
rottie
n00b
n00b


Joined: 29 Jun 2002
Posts: 10
Location: vancouver, canada

PostPosted: Sat Jun 29, 2002 2:09 am    Post subject: Reply with quote

I get this error .. even though I have installed and uninstalled it acouple times

Calculating dependencies \
!!! Error: couldn't find match for # in net-mail/qpopper-4.0.4

I can emerge it I cant install it ???
Back to top
View user's profile Send private message
Jowilly
Guru
Guru


Joined: 22 Jun 2002
Posts: 319

PostPosted: Sat Jun 29, 2002 8:41 am    Post subject: Portage 2.0.8 WHERE is emerge ?????????<Y Reply with quote

I have upgraded to portage 2.0.8. It has merged 2.0.8 and unmerged 2.0.6 successfully. Now emerge isn't there anymore, where is it ????

/bin/sh: emerge: command not found

Also, in /usr/share/doc I still have docs for portage 2.0.6, but I can't see anything for 2.0.8.



Where is emerge ? Please help, thx !
Back to top
View user's profile Send private message
Jowilly
Guru
Guru


Joined: 22 Jun 2002
Posts: 319

PostPosted: Sat Jun 29, 2002 4:03 pm    Post subject: ok Reply with quote

Ok, I have installed portage-rescue, and then installed portage 2.0.8 again.

Its ok now.

That was a strange bug.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18154

PostPosted: Sat Jun 29, 2002 5:14 pm    Post subject: Reply with quote

FINITE wrote:
I just updated to 2.0.4 and am unable to unmerge 1.9.11. After the update 1.9.11 cannot be found. Is this normal or do I have a problem? Thanks.

I had some unmerging troubles as well. I had to do an emerge unmerge '=sys-apps/portage.blah' or
whatever it is (if not sys-apps). I probably don't have the syntax correct, so man emerge, and look
at the unmerge options.
_________________
Those who know what's best for us must rise and save us from ourselves.
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Sat Jun 29, 2002 5:30 pm    Post subject: Reply with quote

kanuslupus wrote:
FINITE wrote:
I just updated to 2.0.4 and am unable to unmerge 1.9.11. After the update 1.9.11 cannot be found. Is this normal or do I have a problem? Thanks.

I had some unmerging troubles as well. I had to do an emerge unmerge '=sys-apps/portage.blah' or
whatever it is (if not sys-apps). I probably don't have the syntax correct, so man emerge, and look
at the unmerge options.


You can do this also:

Code:

ebuild /usr/portage/sys-apps/portage/portage-X.X.xx unmerge

_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
Jowilly
Guru
Guru


Joined: 22 Jun 2002
Posts: 319

PostPosted: Sat Jun 29, 2002 5:31 pm    Post subject: 2.0.8 the Ghost ! Reply with quote

Portage 2.0.8 is a Ghost ! 8O

It has finly been working fine for the last 30 minutes.... and suddenly all the portage 2.0.8 files have disapeared...

The only file left in /usr/lib/portage/bin is use.

So I had to install portage-rescue AGAIN, and then reinstall 2.0.8 AGAIN.... now it's been working AGAIN for 10 minutes... will see !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 3 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum