Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemi scrivendo un ebuild
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
stefanonafets
l33t
l33t


Joined: 10 Feb 2003
Posts: 644

PostPosted: Sat Oct 13, 2007 4:43 pm    Post subject: problemi scrivendo un ebuild Reply with quote

Ciao a tutti !

Stavo cercando di installare questo tema per xfce .
In quanto gentoo-addicted ormai da tempo, mi sono detto: "Perchè non creare un ebuild?" (quel tema va compilato...)
Per cui eccomi qui...

Vi posto innanziutto l'ebuild che ho scritto (un pò scopiazzando, un pò leggendo la documentazione):

Code:

# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

DESCRIPTION="Aurora Gtk Engine"
HOMEPAGE="http://www.xfce-look.org/content/show.php/Aurora+Gtk+Engine?content=56438"
SRC_URI="http://www.xfce-look.org/CONTENT/content-files/56438-Aurora-1.2.tar.bz2"
KEYWORDS="x86"

SLOT="0"
RDEPEND=">=x11-libs/gtk+-2.10"
DEPEND="${RDEPEND}
        xfce-base/xfce4"

src_compile() {

        tar xvzf $P.tar.gz

        cd $P

        local myconf
        myconf="-enable-animation"

        econf ${myconf} \
                || die "configuration failed"
        emake \
                || die "make failed"
}

src_install () {
        emake install \
                || die "make install failed"
}


Il problema: dopo aver fatto il digest, dando "emerge aurora", l'errore è il seguente:

Code:

>>> Install aurora-1.2 into /var/tmp/portage/x11-themes/aurora-1.2/image/ category x11-themes
make[1]: Entering directory `/var/tmp/portage/x11-themes/aurora-1.2/work/aurora-1.2'
make[1]: Nothing to be done for `install-exec-am'.
test -z "/usr/lib/gtk-2.0/2.10.0/engines" || /bin/mkdir -p "/usr/lib/gtk-2.0/2.10.0/engines"
 /bin/sh ./libtool --mode=install /usr/bin/install -c  'libaurora.la' '/usr/lib/gtk-2.0/2.10.0/engines/libaurora.la'
/usr/bin/install -c .libs/libaurora.so /usr/lib/gtk-2.0/2.10.0/engines/libaurora.so
ACCESS DENIED  open_wr:   /usr/lib/gtk-2.0/2.10.0/engines/libaurora.so
/usr/bin/install: cannot create regular file `/usr/lib/gtk-2.0/2.10.0/engines/libaurora.so': Permission denied
make[1]: *** [install-engineLTLIBRARIES] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-themes/aurora-1.2/work/aurora-1.2'
make: *** [install-am] Error 2
 *
 * ERROR: x11-themes/aurora-1.2 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_install
 *   ebuild.sh, line 1089:   Called qa_call 'src_install'
 *   ebuild.sh, line 44:   Called src_install
 *   aurora-1.2.ebuild, line 34:   Called die
 *
 * make install failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/x11-themes:aurora-1.2:20071013-163350.log'.
 * This ebuild is from an overlay: '/usr/local/portage/'
 *


Il problema è evidente, ovvero non riesce a copiare .libs/libaurora.so in /usr/lib/gtk-2.0/2.10.0/engines/libaurora.so
per un fantomatico problema di permessi.
Dico fantomatico non per niente, nel senso che root PUO' scrivere in /usr/lib/gtk-2.0/2.10.0/engines/ .

Altra cosa, se mi "metto" in /var/tmp/portage/x11-themes/aurora-1.2/work/aurora-1.2 e do un bel "make install" (dopo aver lasciato portage compilare e fallire l'istallazione),
le librerie vengono installate correttamente...
Ho provato anche a sostituire "emake install" con "make install", ma non cambia niente.

Non capisco...
HELP!
_________________
registered Linux user number #411324
sed 's/ke/che/g'

<The Deployment Slave is initializing>
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Sat Oct 13, 2007 5:02 pm    Post subject: Reply with quote

Prova a modificare
Code:

emake install

con
Code:

emake DESTDIR="{D}" install || die "emake install failed"

Per info su "D": http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=1#doc_chap2_sect3
Manuale Sviluppatori wrote:

D The root directory that the package is installed to, treat it as the virtual /.

_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sat Oct 13, 2007 5:10 pm    Post subject: Reply with quote

Scen wrote:
Prova a modificare
Code:

emake install

con
Code:

emake DESTDIR="{D}" install || die "emake install failed"

Per info su "D": http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=1#doc_chap2_sect3
Manuale Sviluppatori wrote:

D The root directory that the package is installed to, treat it as the virtual /.

Come mai dai il link ad una documentazione in inglese ? cosa aspetti a tradurla ? :lol:
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
stefanonafets
l33t
l33t


Joined: 10 Feb 2003
Posts: 644

PostPosted: Sat Oct 13, 2007 5:11 pm    Post subject: Reply with quote

Ok, così funziona !!!!!!!!

Anche se in realtà non capisco perchè...

Vabbè, le domande filosofiche le lascio per un altro momento :-)

Posto l'ebuild finale:

Quote:

# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

DESCRIPTION="Aurora Gtk Engine"
HOMEPAGE="http://www.xfce-look.org/content/show.php/Aurora+Gtk+Engine?content=56438"
SRC_URI="http://www.xfce-look.org/CONTENT/content-files/56438-Aurora-1.2.tar.bz2"
KEYWORDS="x86"

SLOT="0"
RDEPEND=">=x11-libs/gtk+-2.10"
DEPEND="${RDEPEND}
xfce-base/xfce4"


src_compile() {

tar xvzf $P.tar.gz

cd $P

local myconf
myconf="-enable-animation"

econf ${myconf} \
|| die "configuration failed"
emake \
|| die "make failed"
}

src_install () {

emake DESTDIR="${D}" install \
|| die "make install failed"
}


_________________
registered Linux user number #411324
sed 's/ke/che/g'

<The Deployment Slave is initializing>
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Sun Oct 14, 2007 12:13 pm    Post subject: Reply with quote

Kernel78 wrote:
Come mai dai il link ad una documentazione in inglese ? cosa aspetti a tradurla ? :lol:

'stardo :P

Mi ero distratto, mannaggia :roll:

stefanonafets wrote:

Ok, così funziona !!!!!!!!

Anche se in realtà non capisco perchè...

In pratica Portage, prima di installare il pacchetto sul filesystem reale, lo installa in una root virtuale, in modo da non danneggiare accidentalmente il sistema (sovrascritture/cancellazione errate, ecc.)
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum