Joined: 12 May 2004
|Posted: Sat Oct 13, 2007 12:26 pm Post subject: [ GLSA 200710-13 ] Ampache: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: Ampache: Multiple vulnerabilities (GLSA 200710-13)
Date: October 13, 2007
An SQL injection vulnerability and a possible identity theft have been discovered in Ampache.
Ampache is a PHP-based tool for managing, updating and playing audio files via a web interface.
Vulnerable: < 126.96.36.199
Unaffected: >= 188.8.131.52
Architectures: All supported architectures
LT discovered that the "match" parameter in albums.php is not properly sanitized before being processed. The Ampache development team also reported an error when handling user sessions.
A remote attacker could provide malicious input to the application, possibly resulting in the execution of arbitrary SQL code. He could also entice a user to open a specially crafted link to steal the user's session.
There is no known workaround at this time.
All Ampache users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/ampache-184.108.40.206"