Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Open office macro security
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
grooveman
Veteran
Veteran


Joined: 24 Feb 2003
Posts: 1176

PostPosted: Fri Oct 12, 2007 2:00 pm    Post subject: Open office macro security Reply with quote

Hello.

I need to run some macros in open office, but it tells me that the current security settings prevent this.

So, I:
Code:
Tools->Options->OpenOffice.org->Security


Then I click on the button "Macro Security..."

But nothing happens!

It is supposed to pop-up a window where I can set certain options... but I get Nothing! Nichts Nada! Rein! Naubol!

Anyone else have this problem? How do I fix this?

Thanks!

G

Running oo 2.3.0 from ebuild...
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
eldacar
n00b
n00b


Joined: 22 Feb 2005
Posts: 64
Location: Göteborg, Sweden

PostPosted: Tue Dec 18, 2007 8:21 am    Post subject: Reply with quote

I have this problem as well on OO.o 2.3.1.
Back to top
View user's profile Send private message
darkangel92
Apprentice
Apprentice


Joined: 19 Nov 2006
Posts: 202

PostPosted: Wed Jan 23, 2008 9:24 am    Post subject: Reply with quote

Hi

UP!!!

i have the same problem . Is it solved ?

Txs
_________________
Gigabyte P35 DS4 Rev 2.0 Bios F14C, Q6600 GO 2,4GHZ@3,6GHz (8*450MHz) , 2Go PC6400 GSKILLS PK , GeForce 8600 GT 512Mo
Sonata III 500W, 2 MAxtor DD SATA II, 1 WD Velociraptor 300Go, WIFI Hercules (RT61)
Gentoo 64 bits, KUbuntu 64 bits, Win XP Pro 32 bits
Back to top
View user's profile Send private message
eldacar
n00b
n00b


Joined: 22 Feb 2005
Posts: 64
Location: Göteborg, Sweden

PostPosted: Wed Jan 23, 2008 2:57 pm    Post subject: Reply with quote

No the problem is still present.
Back to top
View user's profile Send private message
thom_raindog
Guru
Guru


Joined: 16 May 2008
Posts: 400

PostPosted: Sat Jun 14, 2008 2:13 pm    Post subject: Reply with quote

Same here, almost 5 months later..?
Edit: Here
https://forums.gentoo.org/viewtopic-p-5121596.html#5121596
I posted how I solved it for ME.
Back to top
View user's profile Send private message
TheAl
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jan 2004
Posts: 134

PostPosted: Tue Nov 18, 2008 2:59 pm    Post subject: Reply with quote

Same too,

A bug is open but no real solution yet.
https://bugs.gentoo.org/show_bug.cgi?id=244917
Back to top
View user's profile Send private message
monsm
Guru
Guru


Joined: 26 Sep 2007
Posts: 467
Location: London, UK

PostPosted: Fri Apr 03, 2009 3:21 pm    Post subject: Reply with quote

1 1/2 year later and v3.0.0, still no solution?

I put a question on the bug. Could it be a simple use flag we are missing?
Anyone managed to solve it?

Mons
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Mon Apr 20, 2009 5:38 am    Post subject: Reply with quote

monsm wrote:
1 1/2 year later and v3.0.0, still no solution?

I put a question on the bug. Could it be a simple use flag we are missing?
Anyone managed to solve it?

Mons


Edit file (backup this file first):
.ooo3/user/registry/data/org/openoffice/Office/Common.xcu

find section:
Scroll to the end of the file. The last XML tag should be
"</oor:component-data>".

Before that tag, insert the following (valid values are: 0 - the lowest; 3 - the highest; 2 - default:
Code:
<node oor:name="Security">
  <node oor:name="Scripting">
   <prop oor:name="MacroSecurityLevel" oor:type="xs:int">
    <value>1</value>
   </prop>
  </node>
</node>


it worked for me.
_________________
#Thelma
Back to top
View user's profile Send private message
monsm
Guru
Guru


Joined: 26 Sep 2007
Posts: 467
Location: London, UK

PostPosted: Wed Apr 22, 2009 12:54 pm    Post subject: Reply with quote

Will give it a try when I'm home again.

Strange that the dialogue don't work though. It ought to be an easy thing to fix...

Mons
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Wed Apr 22, 2009 1:03 pm    Post subject: Reply with quote

No, the menu option will not work, but play with the "value number" for my best is "1" so it asks me every time I open a spreadsheet if I want to run a macro; if you put "0" it should not ask you any more.
_________________
#Thelma
Back to top
View user's profile Send private message
monsm
Guru
Guru


Joined: 26 Sep 2007
Posts: 467
Location: London, UK

PostPosted: Fri Apr 24, 2009 2:39 pm    Post subject: Reply with quote

Thanks, yes it works. I think I prefer to be asked. Bit annoying with the dialogue that won't start though.

By the way, do you know how compatibe the OOObasic is with VBA?

Mons
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Fri Apr 24, 2009 3:03 pm    Post subject: Reply with quote

monsm wrote:
Thanks, yes it works. I think I prefer to be asked. Bit annoying with the dialogue that won't start though.

By the way, do you know how compatibe the OOObasic is with VBA?

Mons


No, I've never tried to run VBA so I'm not sure about it, google for it. Good start would be:
http://www.oooforum.org/forum/viewtopic.phtml?t=23910
_________________
#Thelma
Back to top
View user's profile Send private message
h2sammo
Veteran
Veteran


Joined: 11 Mar 2009
Posts: 1025
Location: Michigan

PostPosted: Thu Oct 15, 2009 7:17 pm    Post subject: Reply with quote

it works, here is my file (it prompts me to enable macros every time with setting of 1 selected), the stuff i added is in bold:
Quote:

GNU nano 2.1.9 File: /home/bobby/.ooo3/user/registry/data/org/openoffice/Office/Common.xcu

<?xml version="1.0" encoding="UTF-8"?>
<oor:component-data xmlns:oor="http://openoffice.org/2001/registry" xmlns:xs="http://www.w3.org/2001/XMLSchema" oor:name="Common" oor:package="org.openoffice.$
<node oor:name="Internal">
<prop oor:name="CurrentTempURL" oor:type="xs:string">
<value/>
</prop>
</node>
<node oor:name="Misc">
<prop oor:name="FirstRun" oor:type="xs:boolean">
<value>false</value>
</prop>
</node>
<node oor:name="Help">
<node oor:name="HelpAgent">
<node oor:name="IgnoreList">
<node oor:name="URL12423" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>0</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://swriter/33368?Language=en-US&amp;System=UNIX#bm_id3159242</value>
</prop>
</node>
<node oor:name="URL30806" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>1</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://swriter/34116?Language=en-US&amp;System=UNIX#bm_id3155354</value>
</prop>
</node>
<node oor:name="URL17439" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>0</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://swriter/10296?Language=en-US&amp;System=UNIX#bm_id7592030</value>
</prop>
</node>
<node oor:name="URL47676" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>2</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://scalc/34099?Language=en-US&amp;System=UNIX#bm_id3148671</value>
</prop>
</node>
<node oor:name="URL48813" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>2</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://scalc/33368?Language=en-US&amp;System=UNIX#bm_id3159242</value>
</prop>
</node>
<node oor:name="URL62562" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>0</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://swriter/34106?Language=en-US&amp;System=UNIX#bm_id3146936</value>
</prop>
</node>
<node oor:name="URL52291" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>2</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://swriter/10297?Language=en-US&amp;System=UNIX#bm_id1815464</value>
</prop>
</node>
<node oor:name="URL62562" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>0</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://swriter/34106?Language=en-US&amp;System=UNIX#bm_id3146936</value>
</prop>
</node>
<node oor:name="URL52291" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>2</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://swriter/10297?Language=en-US&amp;System=UNIX#bm_id1815464</value>
</prop>
</node>
<node oor:name="URL16934" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>2</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://swriter/34120?Language=en-US&amp;System=UNIX#bm_id3147519</value>
</prop>
</node>
<node oor:name="URL64885" oor:op="replace">
<prop oor:name="Counter" oor:type="xs:int">
<value>2</value>
</prop>
<prop oor:name="Name" oor:type="xs:string">
<value>vnd.sun.star.help://swriter/34102?Language=en-US&amp;System=UNIX#bm_id3153882</value>
</prop>
</node>
</node>
</node>
</node>
<node oor:name="Security">
<node oor:name="Scripting">
<prop oor:name="MacroSecurityLevel" oor:type="xs:int">
<value>1</value>
</prop>
</node>
</node>

</oor:component-data>
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3224

PostPosted: Wed Jan 27, 2010 3:13 pm    Post subject: Reply with quote

I just ran into this today... I can't believe it's been an issue for so long. The solution Joseph_sys mentioned above worked great.
Back to top
View user's profile Send private message
jancici
Apprentice
Apprentice


Joined: 27 Jan 2004
Posts: 284
Location: Slovakia

PostPosted: Sun Jan 09, 2011 4:07 pm    Post subject: Reply with quote

I get into same problem
not able to start macros, and not able to change settings over GUI, so I did edit that file and put one section more

now it is working ...
Back to top
View user's profile Send private message
jancici
Apprentice
Apprentice


Joined: 27 Jan 2004
Posts: 284
Location: Slovakia

PostPosted: Mon Jan 31, 2011 9:25 pm    Post subject: Reply with quote

I did swap OpenOffice with LibreOffice and this problem with macros is here again.
problem is that I can not find that file ...

any idea how to solve this in LibreOffice? thanks
Back to top
View user's profile Send private message
sphakka
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2003
Posts: 76

PostPosted: Thu Dec 01, 2011 2:26 pm    Post subject: Reply with quote

jancici wrote:
I did swap OpenOffice with LibreOffice and this problem with macros is here again.
problem is that I can not find that file ...

any idea how to solve this in LibreOffice? thanks


sh*t, me too, with libreoffice-bin :-(

For the compiled version 'USE=nsplugin' should do the trick:
https://bugs.gentoo.org/show_bug.cgi?id=364069

But for the bin version there's no such (local) flag; and my global one is disabled to avoid unwanted plugins... Has anybody tried libreoffice-bin with *global* 'USE=nsplugin'?

Cheers,

^s
Back to top
View user's profile Send private message
jancici
Apprentice
Apprentice


Joined: 27 Jan 2004
Posts: 284
Location: Slovakia

PostPosted: Thu Dec 01, 2011 3:18 pm    Post subject: Reply with quote

did you check my another thread?
https://forums.gentoo.org/viewtopic-t-873833-highlight-libreoffice+macro.html
maybe that will help in case of bin package
Back to top
View user's profile Send private message
sphakka
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2003
Posts: 76

PostPosted: Thu Dec 01, 2011 3:42 pm    Post subject: Reply with quote

jancici wrote:
did you check my another thread?
https://forums.gentoo.org/viewtopic-t-873833-highlight-libreoffice+macro.html
maybe that will help in case of bin package


Thanks, I got the trick over there!
The related bug report also says that with lo(-bin)-3.5 everything should be OK.

Cheers,

^s
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum