Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[netbeans] Install cpp failed (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 732
Location: France - Bordeaux

PostPosted: Thu Oct 11, 2007 12:07 pm    Post subject: [netbeans] Install cpp failed (résolu) Reply with quote

Bonjour,
dans le cadre de mes études je suis amené à utiliser netbeans.
J'ai donc tenté de l'installer sur ma gentoo mais voilà au moment de l'installation : erreur.

Code:
 *
 * ERROR: dev-util/netbeans-5.5.1 failed.
 * Call stack:
 *               ebuild.sh, line 1687:  Called dyn_install
 *               ebuild.sh, line 1124:  Called qa_call 'src_install'
 *               ebuild.sh, line   44:  Called src_install
 *   netbeans-5.5.1.ebuild, line  175:  Called install_extra 'cpp'
 *   netbeans-5.5.1.ebuild, line  268:  Called die
 * The specific snippet of code:
 *      java "-Duser.home=${T}" -cp "${WORKDIR}/${cluster}/setup.jar" run \
 *         -silent \
 *         -W "license.selection=1" \
 *         -W "beanNbSelectionPanel.nbHome=${D}/${DESTINATION}" || \
 *         die "Install ${cluster} failed"
 *  The die message:
 *   Install cpp failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-util/netbeans-5.5.1/temp/build.log'.
 *


Avez-vous des solutions ?

Merci d'avance


Last edited by SnowBear on Fri Nov 09, 2007 7:56 am; edited 1 time in total
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Thu Oct 11, 2007 12:56 pm    Post subject: Re: [netbeans] Install cpp failed Reply with quote

Quote:
* ERROR: dev-util/netbeans-5.5.1 failed.
* Call stack:

[snip]

* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/dev-util/netbeans-5.5.1/temp/build.log'.
Il nous faudrait aussi le message d'erreur, tu n'as mis que le "call stack".

Et tant qu'a faire, poste aussi tes USEflags pour netbeans. :wink:

Enjoy !
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 732
Location: France - Bordeaux

PostPosted: Thu Oct 11, 2007 1:58 pm    Post subject: Reply with quote

Code:
>>> Source compiled.
>>> Test phase [not enabled]: dev-util/netbeans-5.5.1

>>> Install netbeans-5.5.1 into /var/tmp/portage/dev-util/netbeans-5.5.1/image/ category dev-util
 * Installing the program...
 * Installing cpp...
Exception in thread "main" java.lang.NoClassDefFoundError: run
 *
 * ERROR: dev-util/netbeans-5.5.1 failed.
 * Call stack:
 *               ebuild.sh, line 1687:  Called dyn_install
 *               ebuild.sh, line 1124:  Called qa_call 'src_install'
 *               ebuild.sh, line   44:  Called src_install
 *   netbeans-5.5.1.ebuild, line  175:  Called install_extra 'cpp'
 *   netbeans-5.5.1.ebuild, line  268:  Called die
 * The specific snippet of code:
 *      java "-Duser.home=${T}" -cp "${WORKDIR}/${cluster}/setup.jar" run \
 *         -silent \
 *         -W "license.selection=1" \
 *         -W "beanNbSelectionPanel.nbHome=${D}/${DESTINATION}" || \
 *         die "Install ${cluster} failed"
 *  The die message:
 *   Install cpp failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-util/netbeans-5.5.1/temp/build.log'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6  CLASSPATH="." JAVA_HOME="/opt/sun-jdk-1.6.0.03"
JAVACFLAGS="-source 1.5 -target 1.5" COMPILER="javac"
and of course, the output of emerge --info


les USE :
Code:
[ebuild     U ] dev-util/netbeans-5.5.1 [5.5-r6] USE="c++%* -debug -doc" 0 kB


Le emerge --info :
Code:
Portage 2.1.3.12 (default-linux/x86/2007.0, gcc-4.2.1, glibc-2.6.1-r0, 2.6.22-gentoo-r6 i686)
=================================================================
System uname: 2.6.22-gentoo-r6 i686 Genuine Intel(R) CPU T2300 @ 1.66GHz
Timestamp of tree: Thu, 11 Oct 2007 01:47:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.1
dev-lang/python:     2.5.1-r2
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r3
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.modulix.net/gentoo/"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr fr_FR"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage.divers"
SYNC="rsync://gentoo.modulix.net/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa bash-completion berkdb bitmap-fonts bluetooth bzip2 cairo cddb cdparanoia cdr cli cpudetection cracklib crypt cups curl dbus dga dri dts dv dvd dvdr dvdread encode exif fbcon fbsplash ffmpeg firefox flac fortran ftp fuse gdbm gif gphoto2 gpm graphviz hal iconv ieee1394 imagemagick ipv6 isdnlog jabber java javascript jpeg jpeg2k kde libcaca live midi mmx mmxext mozilla mp3 mpeg mplayer msn mudflap musepack ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl png postgres pppd python qt4 quicktime readline reflection ruby sdl session smp sox spell spl sse sse2 ssl startup-notification svg svga tcpd tetex theora tiff truetype truetype-fonts type1-fonts unicode usb v4l videos vim-syntax vorbis wifi win32codecs x264 x86 xcomposite xine xorg xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CAMERAS="canon ricoh sonix spca50x" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Thu Oct 11, 2007 2:03 pm    Post subject: Reply with quote

la 5.5.1 est pas encore "stable", mais je vois que tu as déjà installé la précédente: 5.5-r6, elle suffit pas?
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 732
Location: France - Bordeaux

PostPosted: Thu Oct 11, 2007 2:10 pm    Post subject: Reply with quote

Elle me suffit surement le truc c'est que je suis en ~x86 et que je n'ai pas forcément envie de toucher à mon package.mask (enfin je le ferais s'il n'y a pas d'autres solutions).
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Thu Oct 11, 2007 2:13 pm    Post subject: Reply with quote

SnowBear wrote:
le truc c'est que je suis en ~x86

Ces gens qui vivent avec le risque à toutes heures, comment faites vous? :lol:
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 732
Location: France - Bordeaux

PostPosted: Thu Oct 11, 2007 2:16 pm    Post subject: Reply with quote

:D .

J'ai rarement eu de gros ennuis (sauf lors de la transition à Xorg modulaire) en ~x86, après en unstable là par contre je ne dit pas :) .
Back to top
View user's profile Send private message
SnowBear
l33t
l33t


Joined: 03 Sep 2005
Posts: 732
Location: France - Bordeaux

PostPosted: Fri Nov 09, 2007 7:56 am    Post subject: Reply with quote

Problème résolu : histoire de dépendances non satisfaite.
Il fallait installer bc pour le USE +cpp.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum