Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
QT not being detected correctly [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
sdfg
Apprentice
Apprentice


Joined: 11 Feb 2005
Posts: 200

PostPosted: Wed Oct 10, 2007 10:25 am    Post subject: QT not being detected correctly [SOLVED] Reply with quote

Hello.

I have tried to emerge a number of KDE apps over the past week, and I've suddenly hit a brick wall.

Code:

checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (headers and libraries) not found. Please check your installation!


So, I did check my installation:

Code:

Sirius kasyx # el qt
[ Searching for package 'qt' in all categories among: ]
 * installed packages
[I--] [ -] app-emulation/emul-linux-x86-qtlibs-10.0 (0)
[I--] [  ] dev-libs/dbus-qt3-old-0.70 (0)
[I--] [  ] x11-libs/qt-3.99 (3)
[I--] [  ] x11-libs/qt-4.3.1-r1 (4)
[I--] [ ~] x11-themes/gtk-engines-qt-0.8 (2)


I even tried manually remerging Qt but it had the same effect. So the next step was a revdep-rebuild - and there are packages that need rebuilt, but they require Qt! So I hit this error again.

My emerge --info.
Code:

Portage 2.1.3.9 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r8 x86_64)
 =================================================================
 System uname: 2.6.22-gentoo-r8 x86_64 Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz
 Timestamp of tree: Fri, 05 Oct 2007 10:30:01 +0000
 ccache version 2.4 [enabled]
 app-shells/bash:     3.2_p17
 dev-java/java-config: 1.3.7, 2.0.33-r1
 dev-lang/python:     2.4.4-r5
 dev-python/pycrypto: 2.0.1-r6
 dev-util/ccache:     2.4-r7
 sys-apps/baselayout: 1.12.9-r2
 sys-apps/sandbox:    1.2.17
 sys-devel/autoconf:  2.13, 2.61-r1
 sys-devel/automake:  1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
 sys-devel/binutils:  2.17-r1
 sys-devel/gcc-config: 1.3.16
 sys-devel/libtool:   1.5.24
 virtual/os-headers:  2.6.21
 ACCEPT_KEYWORDS="amd64"
 CBUILD="x86_64-pc-linux-gnu"
 CFLAGS="-O2 -march=nocona -fomit-frame-pointer -pipe"
 CHOST="x86_64-pc-linux-gnu"
 CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
 CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
 CXXFLAGS="-O2 -march=nocona -fomit-frame-pointer -pipe"
 DISTDIR="/usr/portage/distfiles"
 FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
 GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
 LC_ALL="en_GB.UTF-8"
 LINGUAS="en_GB"
 MAKEOPTS="-j3"
 PKGDIR="/usr/portage/packages"
 PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
 PORTAGE_TMPDIR="/var/tmp"
 PORTDIR="/usr/portage"
 PORTDIR_OVERLAY="/usr/portage/local/layman/gentoo-de /usr/portage/local/layman/xen /usr/portage/local/layman/rox /usr/portage/local/layman/kolab2-dev /usr/portage/local/layman/pd-overlay /usr/portage/local/layman/openoffice-geki /usr/portage/local/layman/wrobel /usr/portage/local/layman/enlightenment /usr/portage/local/layman/drizzt-overlay /usr/portage/local/layman/live-ebuilds /usr/portage/local/layman/zugaina /usr/portage/local/layman/wschlich-testing /usr/portage/local/layman/kde-experimental /usr/portage/local/layman/xeffects"
 SYNC="rsync://rsync.gentoo.org/gentoo-portage"
 USE="X aac acl alsa amd64 audiofile autoreplace bash-completion berkdb bitmap-fonts cdr cli connectionstatus cracklib crypt css cups dri dv dvd dvdr dvdread encode ffmpeg flac fortran gdbm gif gpm hal highlight history hou iconv ipv6 irc isdnlog java jpeg jpeg2k kde latex midi mmx mono mp3 mpeg mudflap mysql ncurses netmeeting nls nptl nptlonly ogg opengl openmp pam pcre perl png pppd python qt qt3 qt3support qt4 quicktime readline reflection samba sdl session sms sndfile sou spell spl sse sse2 ssl svg tcpd tiff truetype truetype-fonts type1-fonts unicode v4l v4l2 vorbis winpopup xcomposite xml xorg xscreensaver xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" USERLAND="GNU" VIDEO_CARDS="vesa nv nvidia"
 Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


An example emerge -aqtv:
Code:

Sirius kasyx # e konq-plugins
[ebuild  N    ] kde-base/konq-plugins-3.5.7  USE="-arts -debug -kdeenablefinal -xinerama"
[ebuild  N    ]  kde-base/kdeaddons-docs-konq-plugins-3.5.7  USE="-arts -debug -kdeenablefinal -xinerama"

Would you like to merge these packages? [Yes/No]


The config.log for that attempt is located here, and the full build.log is here. I don't know what other information is needed just now.

Can anyone help please?

-K


Last edited by sdfg on Wed Oct 10, 2007 8:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
dentharg
Guru
Guru


Joined: 10 Aug 2004
Posts: 438
Location: /poland/wroclaw

PostPosted: Wed Oct 10, 2007 11:02 am    Post subject: Reply with quote

Where did you get qt-3.99 from???
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Oct 10, 2007 11:30 am    Post subject: Re: QT not being detected correctly Reply with quote

Kasyx wrote:
Hello.

I have tried to emerge a number of KDE apps over the past week, and I've suddenly hit a brick wall.

Code:

checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (headers and libraries) not found. Please check your installation!



What packages? Overlay?


Quote:
So, I did check my installation:

Code:

Sirius kasyx # el qt
[ Searching for package 'qt' in all categories among: ]
 * installed packages
[I--] [ -] app-emulation/emul-linux-x86-qtlibs-10.0 (0)
[I--] [  ] dev-libs/dbus-qt3-old-0.70 (0)
[I--] [  ] x11-libs/qt-3.99 (3)
[I--] [  ] x11-libs/qt-4.3.1-r1 (4)
[I--] [ ~] x11-themes/gtk-engines-qt-0.8 (2)



I don't know where your qt-3.99 comes from. But usually, .99 versions are just cvs pre-releases or snapshots from the next version. So, that ebuilds that you are using could be a qt-4 experimental ebuild. Assuming you installed it along with the regular qt-4, it can just only have messed your qt-4 installation. Seriously, you are using stuff from an overlay, I hope you understand that this it not a gentoo problem at all.

Code:

 PORTDIR_OVERLAY="/usr/portage/local/layman/gentoo-de /usr/portage/local/layman/xen /usr/portage/local/layman/rox /usr/portage/local/layman/kolab2-dev /usr/portage/local/layman/pd-overlay /usr/portage/local/layman/openoffice-geki /usr/portage/local/layman/wrobel /usr/portage/local/layman/enlightenment /usr/portage/local/layman/drizzt-overlay /usr/portage/local/layman/live-ebuilds /usr/portage/local/layman/zugaina /usr/portage/local/layman/wschlich-testing /usr/portage/local/layman/kde-experimental /usr/portage/local/layman/xeffects"


Gosh...

And you still wonder what the problem is... arch is the lesser of your problems.

EDIT; By the way: heck, I don't know why you are using qt-3.99. It will:

1.- break qt-4.0, since 3.99 is already a pre for 4.0 as I explained above.
2.- provide no support at all for 3.x

In addition to that, if you look at this:

Code:

checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (headers and libraries) not found. Please check your installation!


You can see ">=3.3", which means, greater than or equal to qt-3.3. There are ebuilds for that in portage, as you can easily check:

Code:

$ eix x11-libs/qt
[U] x11-libs/qt
     Available versions: 
        (3)     3.3.4-r8 3.3.8-r3 3.3.8-r4

_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Wed Oct 10, 2007 11:37 am    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software.

You need to emerge a version of Qt 3.3.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
sdfg
Apprentice
Apprentice


Joined: 11 Feb 2005
Posts: 200

PostPosted: Wed Oct 10, 2007 8:54 pm    Post subject: Reply with quote

Solved. I forgot I had asked layman to install every overlay under the sun. Stupid me.

-K
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum