Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Nvidia/X/OpenGL] Affichage: des petits carrés partout!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
obpt
n00b
n00b


Joined: 25 Sep 2007
Posts: 9
Location: Suisse

PostPosted: Tue Oct 02, 2007 8:23 am    Post subject: [Nvidia/X/OpenGL] Affichage: des petits carrés partout! Reply with quote

Bonjour tous,

J'ai un problème gênant d'affichage pour tout ce qui est 3D: des petits carrés très moches polluent mon écran.
Voici un exemple avec glxgears: http://home.citycable.ch/obpt/pics/gentoo_forums/glxgears_squares.png
Et un autre avec Google Earth: http://home.citycable.ch/obpt/pics/gentoo_forums/earth_squares.png

Par contre, Beryl tourne sans ces problèmes d'affichage.

Ma config est un P4 2.8GHz, 512Mo RAM avec une GeForce FX 5600.

J'ai essayé d'activer ou de désactiver différentes options dans mon xorg.conf mais je n'ai réussi ni à améliorer ni à dégrader mon affichage. La dernière chose que j'ai essayée est de passer de la version 100.14.09 à la version 100.14.19 des drivers Nvidia.

[ma vie]
Peut-être que ce problème date un peu, mais je ne l'ai découvert que récemment en essayant d'installer le client d'Eve-Online.
[/ma vie]

Merci pour votre aide!
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Tue Oct 02, 2007 8:43 am    Post subject: Reply with quote

Et tu fais tourner ça avec ou sans Beryl en même temps?
(parce que Beryl sur une 5600 ... je l'ai tenté sur un 5500, c'était une horreur!
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
obpt
n00b
n00b


Joined: 25 Sep 2007
Posts: 9
Location: Suisse

PostPosted: Tue Oct 02, 2007 9:02 am    Post subject: Reply with quote

Temet wrote:
Et tu fais tourner ça avec ou sans Beryl en même temps?
(parce que Beryl sur une 5600 ... je l'ai tenté sur un 5500, c'était une horreur!


Non, non, je désactive Beryl quand je lance une application 3D.
Back to top
View user's profile Send private message
obpt
n00b
n00b


Joined: 25 Sep 2007
Posts: 9
Location: Suisse

PostPosted: Wed Oct 03, 2007 8:26 am    Post subject: Reply with quote

Bon... voici les nouvelles du front:

- J'ai essayé de revenir à une version de driver nvidia plus ancienne et je suis passé de la version 100.14.19 à la version 1.0.9639. Mais cela n'a rien amélioré.

- En désactivant l'accéleration matérielle (avec "eselect opengl set xorg-x11"), les petits carrés s'en vont mais les performances chutent dramatiquement.

Ce qui me dérange, c'est qu'avant, ça marchait... (le problème est que je ne sais plus quand est "avant")

Voici mon emerge --info et le résultat de glxinfo. Et voilà mes fichiers de config: xorg.conf et package.keywords.
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Wed Oct 03, 2007 9:00 am    Post subject: Reply with quote

Dans ton xorg.conf, commente:
Code:
Option "AddARGBGLXVisuals" "true"

Section "Extensions"
   Option "Composite" "Enable"
EndSection

Et relance le serveur X pour voir.
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
obpt
n00b
n00b


Joined: 25 Sep 2007
Posts: 9
Location: Suisse

PostPosted: Wed Oct 03, 2007 9:59 pm    Post subject: Reply with quote

Temet wrote:
Dans ton xorg.conf, commente:
Code:
Option "AddARGBGLXVisuals" "true"

Section "Extensions"
   Option "Composite" "Enable"
EndSection

Et relance le serveur X pour voir.


J'ai commenté ces lignes, mais au lieu de redémarrer le serveur, j'ai aussi redémarré l'ordi (eh oui, une lubie comme ça). Et le miracle a eu lieu! Glxgears ne m'affichait plus de petits carrés parasites. :) Alors j'ai lancé Eve-Online et mon vaisseau était tout beau! :D Et puis il y a eu un freeze de quelques secondes de l'affichage... :( et puis les carrés sont revenus... :cry: Après voir quitté Eve, j'ai lancé glxgears et les carrés étaient là. J'ai redémarré le serveur X mais les carrés restaient.

J'ai remis toutes les options que j'avais enlevé dans mon xorg.conf et j'ai redémarré la machine. Et maintenant tout va bien, mis à part le fait que je ne peux pas lancer Eve sans devoir rebooter mon ordi pour retrouver un affichage 3d normal...

Au moins je sais ce que je ne dois pas faire pour ne pas détériorer mon affichage.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum