Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
revdep-rebuild is never satisfied...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
fooz44
n00b
n00b


Joined: 23 Jul 2005
Posts: 25

PostPosted: Mon Oct 01, 2007 1:33 am    Post subject: revdep-rebuild is never satisfied... Reply with quote

Hello,

After completing my emerge world update, I went back and did revdep-rebuild -X, and it keeps suggesting I emerge the same package. Here is the output from revdep-rebuild -X -p:

Code:

localhost zak # revdep-rebuild -X -p
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
  broken /usr/bin/cdxa2mpeg (requires  libcdio.so.5 libiso9660.so.4)
  broken /usr/bin/gcdmaster (requires  libgnomecanvasmm-2.6.so.1 libgnomemm-2.6.so.1 libgnomeuimm-2.6.so.1 libgnomevfsmm-2.6.so.1)
  broken /usr/bin/vcdimager (requires  libcdio.so.5 libiso9660.so.4)
  broken /usr/bin/vcd-info (requires  libcdio.so.5 libiso9660.so.4)
  broken /usr/bin/vcdxbuild (requires  libcdio.so.5 libiso9660.so.4)
  broken /usr/bin/vcdxgen (requires  libcdio.so.5 libiso9660.so.4)
  broken /usr/bin/vcdxminfo (requires  libcdio.so.5 libiso9660.so.4)
  broken /usr/bin/vcdxrip (requires  libcdio.so.5 libiso9660.so.4)
  broken /usr/lib64/libaprutil-0.so.0.9.12 (requires  libexpat.so.0)
  broken /usr/lib64/libgtkhtml-3.8.so.15.3.9 (requires  libgailutil.so.17)
  broken /usr/lib64/libvcdinfo.so.0.1.0 (requires  libcdio.so.5 libiso9660.so.4)
  broken /usr/lib/libaprutil-0.so.0.9.12 (requires  libexpat.so.0)
  broken /usr/lib/libgtkhtml-3.8.so.15.3.9 (requires  libgailutil.so.17)
  broken /usr/lib/libvcdinfo.so.0.1.0 (requires  libcdio.so.5 libiso9660.so.4)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to packages...
  /usr/bin/cdxa2mpeg -> media-video/vcdimager
  /usr/bin/gcdmaster -> app-cdr/cdrdao
  /usr/bin/vcdimager -> media-video/vcdimager
  /usr/bin/vcd-info -> media-video/vcdimager
  /usr/bin/vcdxbuild -> media-video/vcdimager
  /usr/bin/vcdxgen -> media-video/vcdimager
  /usr/bin/vcdxminfo -> media-video/vcdimager
  /usr/bin/vcdxrip -> media-video/vcdimager
  /usr/lib64/libaprutil-0.so.0.9.12 -> dev-libs/apr-util
  /usr/lib64/libgtkhtml-3.8.so.15.3.9 -> gnome-extra/gtkhtml
  /usr/lib64/libvcdinfo.so.0.1.0 -> media-video/vcdimager
  /usr/lib/libaprutil-0.so.0.9.12 -> dev-libs/apr-util
  /usr/lib/libgtkhtml-3.8.so.15.3.9 -> gnome-extra/gtkhtml
  /usr/lib/libvcdinfo.so.0.1.0 -> media-video/vcdimager
 done.
  (/root/.revdep-rebuild.4_packages_raw, /root/.revdep-rebuild.4_package_owners)

Cleaning list of packages to rebuild... done.
  (/root/.revdep-rebuild.4_packages)

Assigning packages to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot -p =dev-libs/apr-util-1.2.8

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-libs/apr-util-1.2.8
Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.
localhost zak #   


And every time I go ahead and reemerge apr-util, I get the same result when I delete the temp files and redo revdep-rebuild -X -p. Why is this? Any ideas?
Back to top
View user's profile Send private message
tuam
l33t
l33t


Joined: 04 May 2004
Posts: 763
Location: CGN, Germany

PostPosted: Mon Oct 01, 2007 6:51 am    Post subject: Reply with quote

apr-util is SLOTted, and the lower versioned one is broken. Insisting on -X is not recommended :wink:

FF,

Daniel
_________________
Logic clearly dictates that the needs of the many outweigh the needs of the few. - Spock
The needs of the one outweigh the needs of the many. - Kirk
I refuse to let arithmetic decide questions like that. - Picard
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Mon Oct 01, 2007 7:02 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, refer to topic "Upgrade to expat-2.0.x needs revdep-rebuild" specifically a post by drumgod and the response by isolationism.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum