Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] Wine, ATI e OpenGL
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Gr3yFox
Apprentice
Apprentice


Joined: 11 May 2006
Posts: 218
Location: Genoa, Italy

PostPosted: Sun Sep 30, 2007 8:26 pm    Post subject: [risolto] Wine, ATI e OpenGL Reply with quote

Ho emerso felicemente wine 0.9.39 con le seguenti use flags:

Code:
 + + X       : Adds support for X11
 + + alsa    : Adds support for media-libs/alsa-lib (Advanced Linux Sound Architecture)
 + + cups    : Add support for CUPS (Common Unix Printing System)
 - - dbus    : Enable dbus support for anything that needs it (gpsd, gnomemeeting, etc)
 - - esd     : Adds support for media-sound/esound (Enlightened Sound Daemon)
 - - hal     : Enable Hardware Abstraction Layer (HAL) support
 - - jack    : Adds support for the JACK Audio Connection Kit
 + + jpeg    : Adds JPEG image support
 - - lcms    : Adds lcms support (color management engine)
 - - ldap    : Adds LDAP support (Lightweight Directory Access Protocol)
 - - nas     : Adds support for network audio sound
 + + ncurses : Adds ncurses support (console display library)
 + + opengl  : Adds support for OpenGL (3D graphics)
 - - oss     : Adds support for OSS (Open Sound System)
 - - scanner : Adds support for scanner hardware (e.g. build the sane frontend in kdegraphics)
 - - xml     : Add support for XML files


sulla mia gentoo x86_64. Aggiungo un emerge --info, non si sa mai:

Code:
Portage 2.1.3.9 (default-linux/amd64/2006.0, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.21-gentoo-r4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Timestamp of tree: Fri, 28 Sep 2007 15:30:09 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php4/ext-active/ /etc/php/cgi-php4/ext-active/ /etc/php/cli-php4/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ ftp://ftp.unina.it/pub/linux/distributions/gento http://mirror.switch.ch/ftp/mirror/gentoo/"
LANG="it_IT"
LINGUAS="it en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-overlays/initng"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="4vl X aac alsa amd64 apache2 avi berkdb bitmap-fonts cdr cli cracklib crypt cups dri dvd dvdr eds emboss encode foomaticdb fortran gif gnome gpm gstreamer gtk gtk2 iconv icq imlib ipv6 isdnlog java jpeg lzw lzw-tiff midi mp3 mpeg msn mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdflibs perl png ppds pppd python qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd tiff truetype-fonts type1-fonts usb vcd vorbis wxwindows xorg xpm xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INITNG_PLUGINS="also bash_launcher chdir chroot conflict cpout critical cron daemon dev dllaunch envparser find fstat history idleprobe initctl interactive iparser last limit logfile netprobe ngc4 pause pidfile reload renice rlparser simple_launcher stcmd stdout suid syncron syslog unneeded provide" INPUT_DEVICES="mouse keyboard joystick evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" LIRC_DEVICES="serial" USERLAND="GNU" VIDEO_CARDS="fglrx vesa"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Quanto al DRI, funziona benissimo con gli fglrx 8.39.4
Ho provato poco fa a far andare un gioco, quanto all'installazione tutto andato perfetto. Quanto all'esecuzione, il test iniziale dei requisiti minimi passa tutti i test tranne quello della memoria video, dove proprio non ne rivela. Lancio lo stesso il gioco e aspetto 10 minuti per arrivare al menu principale, tutto rallentatissimo. Penso proprio che ci sia qualche problema con l'opengl in wine, ma non so ne come verificare se sia vero ne come (eventualmente) rimediare.

Spero che (come al solito ;) ) qualche anima buona qui sappia darmi una mano.

Grazie, ciao :)
_________________
GreyFox (Linux registered user #435102)
greyfox.imente.org - GreyFox's shots (photoblog)


Last edited by Gr3yFox on Wed Oct 03, 2007 7:03 am; edited 1 time in total
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Mon Oct 01, 2007 2:00 pm    Post subject: Reply with quote

ho il tuo stesso problema...ma con i driver ati open..in realtà non mi succede solo con wine...compiz-fusion va benissimo ma anche google earth va leeeentissimo inutilizzabile...per non parlare dei giochi 3d con wine...pensavo fosse un problema dei driver open ma a quanto pare....
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
Gr3yFox
Apprentice
Apprentice


Joined: 11 May 2006
Posts: 218
Location: Genoa, Italy

PostPosted: Mon Oct 01, 2007 9:32 pm    Post subject: Reply with quote

No, apps 3d normali mi vanno benissimo. Solo, non capisco se sia un problema proprio di wine: anche se riesce ad eseguirlo evidentemente non è in grado di tenere tempi di risposta anche solo appena accettabili con "prince of persia i due troni". L'alternativa è che non riesca a collegarsi al rendering 3d: quest'idea me la suggerisce il fatto che il testing dei requisiti di gioco non trovi memoria video.
Vorrei sapere come fare per stabilire se ci sono problemi con il collegamento al DRI oppure se è il gioco troppo nuovo per funzionare bene. Qualche idea?
_________________
GreyFox (Linux registered user #435102)
greyfox.imente.org - GreyFox's shots (photoblog)
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Oct 02, 2007 7:00 am    Post subject: Reply with quote

Qui il gioco lo danno come funzionante?
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Gr3yFox
Apprentice
Apprentice


Joined: 11 May 2006
Posts: 218
Location: Genoa, Italy

PostPosted: Wed Oct 03, 2007 7:03 am    Post subject: Reply with quote

Un paio di bronzi ci sono: http://appdb.winehq.org/objectManager.php?sClass=version&iId=5612
Accidenti però, questo che scrive dice che il gioco è lentissimo. Mi sa proprio che per ora dovrò aspettare che wine avanzi, al momento continuerò a giocarlo con win. Grazie per il link ;)
_________________
GreyFox (Linux registered user #435102)
greyfox.imente.org - GreyFox's shots (photoblog)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum