Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[use flag] downgrade della use xcb
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Sep 29, 2007 8:26 pm    Post subject: [use flag] downgrade della use xcb Reply with quote

problemino per geek smanettoni cerca guai.

nel mio sistema avevo piazzato la use xcb.
non so perché, ma quando ho scoperto che crea problemi a java, ho deciso di affrontare il downgrade.
apparentemente tutto bene.
poi, per maggiore pulizia, provo un `emerge depclean -pv`.

mi toglie pochi pacchetti, tra i quali x11-libs/xcb-util . benissimo dico, e lascio fare.
segue revdep-rebuild. la lista è lunghissima, ma tiro avanti.

a questo punto il guasto:
moltissimi pacchetti falliscono la compilazione con questo errore:
Code:

grep: /usr/lib64/libxcb-render-util.la: No such file or directory
/bin/sed: can't read /usr/lib64/libxcb-render-util.la: No such file or directory
libtool: link: `/usr/lib64/libxcb-render-util.la' is not a valid libtool archive

gulp, mi dico... la ho appena tolta!
per gtk+ ho `risolto` ricompilando un insieme di pacchetti casualmente tratti da un qdepend, ma mi sembra lunghissimo continuare con questo passo.

esiste un modo pulito di prendere il toro per le corna?
nb: ho ripulito preventivamente ccache.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sun Sep 30, 2007 11:06 am    Post subject: Re: [use flag] downgrade della use xcb Reply with quote

cloc3 wrote:
problemino per geek smanettoni cerca guai.

nel mio sistema avevo piazzato la use xcb.
non so perché, ma quando ho scoperto che crea problemi a java, ho deciso di affrontare il downgrade.
apparentemente tutto bene.

Probabilmente è una domanda inutile ma visto che non sei stato molto chiaro preferisco chiedere:
dopo aver rimosso la USE hai dato emerge -uDN world ?
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Sep 30, 2007 11:10 am    Post subject: Re: [use flag] downgrade della use xcb Reply with quote

Kernel78 wrote:
hai dato emerge -uDN world ?

si. certo.
credo che il problema sia a un livello più profondo.
sembra che revdep-rebuild non sia capace di programmare correttamente la ricompilazione.
adesso credo di avere sbloccato la situazione, ma con la tecnica ad esaustione descritta sopra.
(cercare di indovinare i pacchetti colpevoli).
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum