Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dhcp timeout probleem met init script.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
wouzer
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2003
Posts: 82
Location: The Hague, The Netherlands

PostPosted: Sat Sep 22, 2007 11:24 am    Post subject: dhcp timeout probleem met init script. Reply with quote

Hallo,
Ik heb een raar probleem met mijn rt73-usb wireless adapter.

Met het initscript krijg ik een timeout op dhcp.

/etc/init.d/net.wlan0 start
Code:

 * Caching service dependencies ...                                                                    [ ok ]
 * Starting wlan0
 *   Configuring wireless network for wlan0
 *     wlan0 connected to ESSID "my_essid"
 *     in managed mode on channel 1 (WEP enabled)
 *   Bringing up wlan0
 *     dhcp
 *       Running dhcpcd ...
Error, timed out waiting for a valid DHCP server response


Als ik de boel handmatig configureer, werkt het perfect:
Code:

ifconfig wlan0 up
iwconfig wlan0 essid my_essid
iwconfig wlan0 key my_key
dhcpcd wlan0


mijn /etc/conf.d/net ziet er als volgt uit:
Code:

modules=( "iwconfig" )
essid_wlan0=( "my_essid" )
key_kleinbureau="s:my_key"
preferred_aps=( "my_essid" )
config_wlan0=( "dhcp" )
dhcpcd_wlan0="-t 10"


Heeft iemand een idee hoe dit komt?
alvast bedankt.
_________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt. (Mark Twain)
Back to top
View user's profile Send private message
koenderoo
Guru
Guru


Joined: 03 Jan 2004
Posts: 514
Location: Zwolle, The Netherlands

PostPosted: Mon Sep 24, 2007 5:48 pm    Post subject: Reply with quote

key_kleinbureau zou volgens mij key_wlan0 moeten zijn in conf.d/net
_________________
webmaster van www.koenderoo.nl
Back to top
View user's profile Send private message
wouzer
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2003
Posts: 82
Location: The Hague, The Netherlands

PostPosted: Wed Sep 26, 2007 6:10 am    Post subject: Reply with quote

Hey Koen,
Dank voor je suggestie. Ik heb het geprobeerd, maar helaas is het voor mij niet de oplossing.
Ik heb ook geprobeerd een andere dhcp client te installeren, ook zonder succes. Het lastige is dat ik met drie Gentoo machines zit die allemaal op een verschillende manier geconfigureerd zijn om verbinding te maken met wireless. De enige manier waarop ik het op deze machine (een oude laptop) voor elkaar krijg is met iwconfig, handmatig. Omdat het initscript niet gestart is, kunnen andere netafhankelijke scripts ook niet starten.

Heeft iemand wellicht nog andere ideeen? Ik zit behoorlijk omhoog met dit probleem.
_________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt. (Mark Twain)
Back to top
View user's profile Send private message
koenderoo
Guru
Guru


Joined: 03 Jan 2004
Posts: 514
Location: Zwolle, The Netherlands

PostPosted: Wed Sep 26, 2007 9:23 am    Post subject: Reply with quote

Een andere suggestie heb ik nog wel. Ik heb even die handmatige en automatische scripts bekeken en zie daar een klein verschil nog bij key. daar zet je in conf.d/net een s: voor. Je moet uiteraard je sleutel voor jezelf houden, maar is dat wel de juiste notatie voor die sleutel?
WEP is over het algemeen een string van een cijfertje of 12. Deze mag je zonder voorloop s: of anderszins opvoeren in conf.d/net. De "" zou ik er wel om heen laten.
_________________
webmaster van www.koenderoo.nl
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum