Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] HD SATA visto come ATA
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
morellik
l33t
l33t


Joined: 03 Feb 2003
Posts: 629
Location: Firenze

PostPosted: Thu Sep 27, 2007 10:20 am    Post subject: [RISOLTO] HD SATA visto come ATA Reply with quote

Ciao a tutti,

mi è successa una cosa strana. Ho riaggiornato il sistema dopo un bel po' di tempo (c.a. 140 pacchetti da aggiornare) sul
mio portatile (un Acer Aspire 5680 con disco SATA),
ed ho ricompilato il kernel (linux-2.6.22-gentoo-r7) prendendo il .config da quello precedente (linux-2.6.21-gentoo-r1).

Al primo riavvio, ho un kernel panic perché non riesce a trovare root=/dev/sda6 8O
ma funzionava col chiamiamolo vecchio kernel. Morale della favola questo kernel mi vede il disco SATA del mio portatile
come ATA (quindi root=/dev/hda6). E già qui la cosa mi suona strana.

Un lspci mi dà queste info per quanto riguarda il controller SATA:

Code:

 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)


La cosa peggiore è che ogni qualvolta ho un accesso al disco di un certo rilievo (apro OpenOffice per esempio), il
mouse va a scatti e devo aspettare l'apertura dell'applicazione prima di continuare a lavorare.
E non parliamo se masterizzo qualcosa. Posso fare una pausa caffè lunga mezz'ora prima di poter
avere prestazioni decenti sul disco.

Naturalmente hdparm risolve in parte certi problemi visto che non funziona granché su dischi SATA.

Ora proverò con un kernel vanilla.

Avete qualche dritta in proposito?

Grazie


Last edited by morellik on Thu Sep 27, 2007 12:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
Manwhe
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2007
Posts: 127

PostPosted: Thu Sep 27, 2007 12:02 pm    Post subject: Reply with quote

Secondo la mia umile opinione non sono compilati i driver libata nel kernel, controlla che sia settati :)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Sep 27, 2007 12:07 pm    Post subject: Re: HD SATA visto come ATA e downgrade delle prestazioni Reply with quote

morellik wrote:

Avete qualche dritta in proposito?

certo che no. se non dichiari esattamente il modulo del kernel che hai associato al tuo HD.
probabilemente stai utilizzando un driver generico che funziona un tanto al chilo.

capita ad ogni cambio di kernel. se la configurazione automatica non funziona per qualche motivo, bisogna correggerla manualmente.
questo dovrebbe essere un buon tip.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
morellik
l33t
l33t


Joined: 03 Feb 2003
Posts: 629
Location: Firenze

PostPosted: Thu Sep 27, 2007 12:41 pm    Post subject: [RISOLTO] HD SATA visto come ATA Reply with quote

Ho risolto disabilitando

Device Drivers ---> ATA/ATAPI/MFM/RLL support
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Thu Sep 27, 2007 2:32 pm    Post subject: Re: [RISOLTO] HD SATA visto come ATA Reply with quote

morellik wrote:
Ho risolto disabilitando

Device Drivers ---> ATA/ATAPI/MFM/RLL support


Cioé se qualcuno ha un sistema misto non riuscirà a sfruttare adeguatamente il SATA?
_________________
Ciao da me!
Back to top
View user's profile Send private message
morellik
l33t
l33t


Joined: 03 Feb 2003
Posts: 629
Location: Firenze

PostPosted: Thu Sep 27, 2007 3:26 pm    Post subject: Re: [RISOLTO] HD SATA visto come ATA Reply with quote

randomaze wrote:
morellik wrote:
Ho risolto disabilitando

Device Drivers ---> ATA/ATAPI/MFM/RLL support


Cioé se qualcuno ha un sistema misto non riuscirà a sfruttare adeguatamente il SATA?


Mah, nel mio caso il driver CONFIG_ATA_PIIX controlla sia il SATA che il PATA e potrebbe andare in
conflitto col CONFIG_IDE che sembra supportare controller più datati.
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Fri Sep 28, 2007 4:23 pm    Post subject: Reply with quote

Volevo aggiungere che stamani ho avuto lo stesso problema anch'io.

Ho tolto il supporto a tutto l'ambaradam ATA/ATAPI and company e finalmente mi ha visto l'hard disk come SATA (nonostante ci fosse il supporto attivo nell'omonima sezione).

Mah :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum