Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[conf] sistemare java
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Sep 25, 2007 9:00 pm    Post subject: [conf] sistemare java Reply with quote

ma è davvero così facile?

sono mortificato, ma a me non funziona.
sto provando ad usare tightvnc, un server che uso da sempre, ma appena lancio un browser qualunque, vengo rediretto inesorabilmente a installare i java.

le ho provate tutte. in questo momento sto messo così:
Code:

s939 ~ # java-check-environment
 * === Java Environment Checker ===
 * The purpose of this script is to check the sanity of your Java Environment.
 * We have significantly changed and improved the way Java is handled in many
 * respects.
 * Please refer to our upgrade guide for details:
 *      http://www.gentoo.org/proj/en/java/java-upgrade.xml

 * Checking fastjar ...                                                                                                                             [ ok ]

 * Checking vm_environment_files ...                                                                                                                [ ok ]

 * Checking user_settings ...
 * Running as root. Don't need to check user settings.                                                                                              [ ok ]

 * Checking generation_1_system_vm ...                                                                                                              [ ok ]

 * Checking virtual_provides ...                                                                                                                    [ ok ]

 * Checking overlays_eclasses ...                                                                                                                   [ ok ]

 * Checking package_env ...                                                                                                                         [ ok ]

 * Java environment is sane. Congratulations!
s939 ~ # java-config -L
The following VMs are available for generation-2:
1)      Blackdown JDK 1.4.2.03 [blackdown-jdk-1.4.2]
2)      Sun 32bit JRE 1.6.0.02 [emul-linux-x86-java-1.6]
*)      Sun JDK 1.5.0.12 [sun-jdk-1.5]

------
cloc3@s939 ~ $ echo $JAVA_HOME
/etc/java-config-2/current-system-vm
cloc3@s939 ~ $ ls -l $JAVA_HOME
lrwxrwxrwx 1 root root 25 25 set 22:42 /etc/java-config-2/current-system-vm -> /usr/lib/jvm//sun-jdk-1.5/

ma che cosa altro dovrei fare?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Dun
Apprentice
Apprentice


Joined: 17 Apr 2004
Posts: 172
Location: Amsterdam (NL) / Venice (IT)

PostPosted: Tue Sep 25, 2007 11:22 pm    Post subject: Reply with quote

La use nsplugin e' settata?
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Sep 26, 2007 3:08 am    Post subject: Reply with quote

Dun wrote:
La use nsplugin e' settata?
si

ps. però c'è qualcosa di strano sul quel fronte:
strace segnala una quantità di ricerche al file javaplugin.so, tutte fallite.

nel mio sistema quel file non esiste:
Code:

s939 ~ # qfile javaplugin.so
s939 ~ #
s939 ~ # ls /usr/lib64/nsbrowser/plugins/javaplugin.so -l
lrwxrwxrwx 1 root root 68 17 dic  2006 /usr/lib64/nsbrowser/plugins/javaplugin.so -> //usr/share/java-config-2/nsplugin/blackdown-jdk-1.4.2-javaplugin.so

il fatto di essere a 64bit dovrebbe essere ininfluente. ho gli stessi problemi a 32.
ora, la use che dici è stata tolta dai blackdown:
Code:

s939 ~ # USE="nsplugin" emerge -pv blackdown-jdk blackdown-jre

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-java/blackdown-jdk-1.4.2.03-r15  USE="-doc (-nsplugin)" 0 kB
[ebuild  N    ] dev-java/blackdown-jre-1.4.2.03-r14  USE="(-nsplugin)" 12,889 kB

sto scoprendo che sui forum ci sono molti riferimenti al javaplugin.so. ma leggo cose strane e non trovo soluzioni.
a voi funzionano?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Wed Sep 26, 2007 8:27 am    Post subject: Reply with quote

perchè non aggiorni la JDK di sun alla 1.6??? è già in portage da un pò. comunque la strada da seguire per aggiornare il tutto è quella della guida, per configurare invece java devi consultare l'altra guida ovvero questa.

ciauz
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Wed Sep 26, 2007 8:29 am    Post subject: Reply with quote

Se hanno tolto la use magari non fornisce più il plugin il pacchetto. Hai provato a cambiare jdk, magari con quella di Sun?
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Wed Sep 26, 2007 9:11 am    Post subject: Reply with quote

Io passerei ad usare jvm di sun (neanche la licenza è più un problema) , con l'aiuto delle guide gentoo e poi tramite
Code:
eselect java-nsplugin eselect java
mi assicurerei che tutto sia configurato a livello globale correttamente e per finire controllerei l'output di firefox quando nella barra degli indirizzi metti about:plugins .
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Sep 26, 2007 7:34 pm    Post subject: Reply with quote

Ahyakona!, ragazzi.

qui si leggono sintomi palesi di sonnambulismo.
qualcuno :roll: ha scritto xcb nel mio make.conf.
fatevi un giro in search e poi tornate a spiegarmi cosa può provocare...

a 64bit il problema persiste. d'altra parte l'ebuild si rifiuta di installare il plugin per java (sembra che non lo contenga proprio).
forse, attualmente è impossibile usare java su browser.
qualcuno consiglia di usare mplayer-plugin. ma sarebbe comunque una soluzione che esclude konqueror.

sto provando questo, ma è software non supportato.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Sun Sep 30, 2007 10:29 am    Post subject: Reply with quote

A me java su amd64 pare funzionare (solo su firefox, ma konqueror non mi interessa) usando mplayerplug-in.
Ho problema su http://www.nokia.it/A4344027.

Non capisco di che cosa ha bisogno per andare.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum